Conflito Entre Pacotes

1. Conflito Entre Pacotes

Rafael
santoskywalker

(usa Outra)

Enviado em 24/05/2006 - 15:38h

estou tentando instalar o f4l flash for linux, só que ele depende de alguns pacotes, só que esses pacotes estão em conflitos com pacotes do kernel anterior e quando temto remover o kernel anterior ele da a mensagem de erro que estou preste a fazer algo substancialmente destrutivo, e já fiz isso outras vezes e vi que era destrutivo mesmo.

f4l: Depende: libxrender1 (>= 1:0.9.0-2) mas 0.8.3-7 está para ser instalado
kernel-image-2.6.8-2-386: Depende: initrd-tools (>= 0.1.63) mas não vai ser instalado
kernel-image-2.6.8-3-686: Depende: initrd-tools (>= 0.1.63) mas não vai ser instalado
libgcc1: Depende: gcc-4.1-base (= 4.1.0-4) mas não está instalável
Depende: libc6 (>= 2.3.6-6) mas 2.3.2.ds1-22sarge3 está para ser instalado
E: Dependências desencontradas. Tente `apt-get -f install' sem nenhum pacote (ou especifique uma solução).

Este é um resumo da situação, alguém tem idéia do que fazer?


  


2. Re: Conflito Entre Pacotes

marcelo antonio atanasio
hccelo

(usa Gentoo)

Enviado em 24/05/2006 - 16:01h

tentou o apt-get install -f ???



3. sim

Rafael
santoskywalker

(usa Outra)

Enviado em 24/05/2006 - 17:04h

Quando dou o apt-get install -f (-f install) ele mostra uma montanha de pacotes básicos que vão ser afetados e alguns também básicos que vão ser removidos e me avisa sobre os danos que isso vai causar ao meu sistema e pede para que eu faça isso só se tiver total conhecimento do que estou preste a fazer, o que não é o caso.

Abraço.


4. Acho que agora consigo explicar melhor.

Rafael
santoskywalker

(usa Outra)

Enviado em 28/05/2006 - 18:43h

Estou tentando instalar o Flash for linux, já baixei o pacote e então dei um dpkg -i f4l...
Isso aqui:

debiansto:~# dpkg -i /mnt/arquivos/arquivos_compartilhados/gnu_inst/f4l_0.2-1_i386.deb
Selecionando pacote previamente não selecionado f4l.
(Lendo banco de dados ... 108884 arquivos e diretórios atualmente instalados.)
Descompactando f4l (de .../gnu_inst/f4l_0.2-1_i386.deb) ...
dpkg: problemas de dependência impedem configuração de f4l:
f4l depende de libqt3c102-mt (>= 3:3.3.4); porém:
Package libqt3c102-mt is not installed.
f4l depende de libqt3c102-mt (>= 3:3.3.4-3); porém:
Package libqt3c102-mt is not installed.
dpkg: erro processando f4l (--install):
problemas de dependência - deixando desconfigurado
Erros foram encontrados durante processamento de:
f4l

Então baixei e tentei instalar o libqt3c102-mt, só que isso acontece:

debiansto:~# dpkg -i Desktop/libqt3c102-mt_3.3.4-3_i386.deb
Selecionando pacote previamente não selecionado libqt3c102-mt.
dpkg: considerando remoção de libqt3-mt em favor de libqt3c102-mt ...
dpkg: não, não posso remover libqt3-mt (--auto-deconfigure vai te ajudar):
ksnapshot depende de libqt3-mt (>= 3:3.3.6)
libqt3-mt está para ser removido.
dpkg: sobre .../libqt3c102-mt_3.3.4-3_i386.deb contendo libqt3c102-mt:
libqt3c102-mt conflita com libqt3-mt
libqt3-mt (versão 3:3.3.6-2) está instalado.
dpkg: erro processando Desktop/libqt3c102-mt_3.3.4-3_i386.deb (--install):
pacotes conflitantes - não instalando libqt3c102-mt
Erros foram encontrados durante processamento de:
Desktop/libqt3c102-mt_3.3.4-3_i386.deb

Então pensei em remover o libqt3-mt, para colocar o libqt3c102-mt e acontece isso:

debiansto:~# apt-get remove libqt3-mt
Lendo Lista de Pacotes... Pronto
Construindo Árvore de Dependências... Pronto
Os pacotes a seguir serão REMOVIDOS:
amor ark arts artsbuilder dcoprss eyesapplet fifteenapplet k3b kalarm kalzium kamera kappfinder karm kasteroids kate
kate-plugins katomic kaudiocreator kbackgammon kbattleship kblackbox kbounce kbstate kcalc kcharselect kcoloredit
kcontrol kcron kde-i18n-ptbr kdeaddons-kfile-plugins kdeadmin-kfile-plugins kdeartwork-style kdeartwork-theme-window
kdebase-bin kdebase-kio-plugins kdegraphics-kfile-plugins kdelibs kdelibs-bin kdelibs4c2a kdelirc
kdemultimedia-kappfinder-data kdemultimedia-kfile-plugins kdemultimedia-kio-plugins kdenetwork-filesharing
kdenetwork-kfile-plugins kdepasswd kdepim-kfile-plugins kdepim-kio-plugins kdepim-kresources kdepim-wizards kdeprint
kdesktop kdessh kdetoys kdewebdev kdf kdict kdnssd kdvi kedit kenolaba kfilereplace kfind kfloppy kfouleggs kgamma kget
kghostview kgpg khelpcenter khexedit kicker kicker-applets kiconedit kimagemapeditor kjots kjumpingcube klaptopdaemon
klatin kleopatra klettres klickety klines klinkstatus klipper kmag kmahjongg kmenuedit kmid kmilo kmines kmix kmoon
kmousetool kmouth kmplot kmrml knetwalk knetworkconf knotes kodo kolourpaint kommander konq-plugins konqueror
konqueror-nsplugins konquest konsole konsolekalendar kooka kpackage kpat kpdf kpercentage kpersonalizer kpf kpilot krec
kreversi krfb kruler ksame kscd ksig ksim ksirtet ksmiletris ksmserver ksnake ksnapshot kspaceduel ksplash kstars ksvg
ksync ksysguard kteatime ktimer ktip ktouch ktuberling kturtle ktux kuickshow kuser kverbos kview kviewshell kvoctrain
kweather kwin kwin4 kwordquiz kworldclock kxsldbg libarts1-akode libarts1-audiofile libarts1-mpeglib libarts1-xine
libarts1c2a libavahi-qt3-1 libcvsservice0 libdbus-qt-1-1c2 libk3b2 libkcal2b libkcddb1 libkdeedu3 libkdegames1
libkdepim1a libkgantt0 libkiten1 libkleopatra1 libkmime2 libkonq4 libkpimexchange1 libkpimidentities1 libkscan1
libksieve0 libktnef1 libqt3-mt librss1 lskat mpeglib networkstatus noatun noatun-plugins pinentry-qt quanta secpolicy
superkaramba
0 pacotes atualizados, 0 pacotes novos instalados, 190 a serem removidos e 427 não atualizados.
É preciso fazer o download de 0B de arquivos.
Depois de desempacotar, 307MB de espaço em disco serão liberados.
Quer continuar? [S/n]n
Abortado.



Alguém tem uma sugestão? ? ?


Obrigado

Santo










Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts