Wi-Fi não funciona no Debian

1. Wi-Fi não funciona no Debian

Ewerton Nascimento Sant Anna
ensabr

(usa Debian)

Enviado em 10/12/2018 - 02:01h

Olá o meu nome é Ewerton, mas as pessoas me chamam por bigode.
Sou um fan do LINUX, sinceramente não gosto do Windows e não me apeguei ainda ao Android, talvez por ser da geração XP.
Bom, eu utilizo 2 desktops Dell (antigos) Optiplex 620 e 755 para me conectar em casa. E 2 notebooks CCE 4030 no serviço.
Ambos (desktop e notebooks) são Linux Mate, sendo um com Ubuntu e outro com Debian (foi o que gostei pela aparência da tela modesta).
Vou ser bem prático eu estou iniciando na informática (apesar de ter 52 anos e usar desde meus 20, tenham paciẽncia).
Uso muito a internet: para ler e-mails, navegar em diversos sites e atualmente BAIXAR e ASSISTIR Filmes e Seriados.
E apenas procuro aceitar os avisos de atualizar e pouco uso o programa de pacotes e nem sei mexer no TERMINAL.
Na pesquisa pelo Google li um artigo que me interessou na atual NECESSIDADE que tenho:
1} Meu notebook CCE (que era Windows 8 e foi transformado em 10 e que trabalhava com o Ubuntu está com problemas:
a) Eu DESISTI daquela porcaria de WINDOWS e com um DVD e instalei o Debian (que gosto) mas não está funcionando o WIFI.
1.a) Aparece no ícone a informação: Wi-Fi está desabilitado (sendo que antes funcionava) e o outro CCE esta com Ubuntu mate e funciona!
Qual seria a sugestão? Agradeço e péço desculpas se fui neste início bastante "chato" tentarei ser mais direto no futuro! Abraços!
Ewerton (bigode)
=============
Nossa estou ficando velho mesmo até esqueci que tinha cadastro por outro e-mail (acho que nem uso maIs) e postei um artigo em 2008 ... isso é há 10 anos ... me desculpe se não usei aquele espaço!
=============
Eu fui informado para resolver o ítem do Wi=Fi para digitar o comando: (em letras menores LSPCI) lspci
Bom ... O que eu fiz foi assim:
Com o mouse fui no icone iniciar do Linux Debian Mate e cliquei;
Fui em em ferramentas e cliquei;
Fui em TERMINAL Mate e cliquei Apareceu a tela e digitei o tal comando e apareceu a seguinte informação:
[email protected]:~$ lspci
00:00.0 Host bridge: Intel Corporation Atom Processor Z36xxx/Z37xxx Series SoC Transaction Register (rev 0e)
00:02.0 VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0e)
00:13.0 SATA controller: Intel Corporation Atom Processor E3800 Series SATA AHCI Controller (rev 0e)
00:14.0 USB controller: Intel Corporation Atom Processor Z36xxx/Z37xxx, Celeron N2000 Series USB xHCI (rev 0e)
00:1a.0 Encryption controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Trusted Execution Engine (rev 0e)
00:1b.0 Audio device: Intel Corporation Atom Processor Z36xxx/Z37xxx Series High Definition Audio Controller (rev 0e)
00:1c.0 PCI bridge: Intel Corporation Atom Processor E3800 Series PCI Express Root Port 1 (rev 0e)
00:1c.1 PCI bridge: Intel Corporation Atom Processor E3800 Series PCI Express Root Port 2 (rev 0e)
00:1f.0 ISA bridge: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Power Control Unit (rev 0e)
00:1f.3 SMBus: Intel Corporation Atom Processor E3800 Series SMBus Controller (rev 0e)
[email protected]:~$ lspci
00:00.0 Host bridge: Intel Corporation Atom Processor Z36xxx/Z37xxx Series SoC Transaction Register (rev 0e)
00:02.0 VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0e)
00:13.0 SATA controller: Intel Corporation Atom Processor E3800 Series SATA AHCI Controller (rev 0e)
00:14.0 USB controller: Intel Corporation Atom Processor Z36xxx/Z37xxx, Celeron N2000 Series USB xHCI (rev 0e)
00:1a.0 Encryption controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Trusted Execution Engine (rev 0e)
00:1b.0 Audio device: Intel Corporation Atom Processor Z36xxx/Z37xxx Series High Definition Audio Controller (rev 0e)
00:1c.0 PCI bridge: Intel Corporation Atom Processor E3800 Series PCI Express Root Port 1 (rev 0e)
00:1c.1 PCI bridge: Intel Corporation Atom Processor E3800 Series PCI Express Root Port 2 (rev 0e)
00:1f.0 ISA bridge: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Power Control Unit (rev 0e)
00:1f.3 SMBus: Intel Corporation Atom Processor E3800 Series SMBus Controller (rev 0e)
01:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTL8411B PCI Express Card Reader (rev 01)
02:00.1 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 12)
[email protected]:~$

[email protected]:~$

Ou seja este comando informou os HARDWARES instalados na máquina, e pelo que notei os ítens abaixo é que irão ser usados:
Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTL8411B PCI Express Card Reader (rev 01)
Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 12)

Valeu ... agora irei continuar a leitura do Forum para INICIANTES e aguardar a continuação ... mas tem um detalhe : Tentei responder e não apareceu separado e sim no tal QUOTE (o que que é isso?)
E pesquisando neste site descobri um comando que tem mais informações:

[email protected]:~$ lspci -k
00:00.0 Host bridge: Intel Corporation Atom Processor Z36xxx/Z37xxx Series SoC Transaction Register (rev 0e)
Subsystem: Device 1d05:1000
Kernel driver in use: iosf_mbi_pci
00:02.0 VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0e)
Subsystem: Device 1d05:1000
Kernel driver in use: i915
Kernel modules: i915
00:13.0 SATA controller: Intel Corporation Atom Processor E3800 Series SATA AHCI Controller (rev 0e)
Subsystem: Device 1d05:1000
Kernel driver in use: ahci
Kernel modules: ahci
00:14.0 USB controller: Intel Corporation Atom Processor Z36xxx/Z37xxx, Celeron N2000 Series USB xHCI (rev 0e)
Subsystem: Device 1d05:1000
Kernel driver in use: xhci_hcd
Kernel modules: xhci_pci
00:1a.0 Encryption controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Trusted Execution Engine (rev 0e)
Subsystem: Device 1d05:1000
00:1b.0 Audio device: Intel Corporation Atom Processor Z36xxx/Z37xxx Series High Definition Audio Controller (rev 0e)
Subsystem: Device 1d05:1000
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation Atom Processor E3800 Series PCI Express Root Port 1 (rev 0e)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:1c.1 PCI bridge: Intel Corporation Atom Processor E3800 Series PCI Express Root Port 2 (rev 0e)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:1f.0 ISA bridge: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Power Control Unit (rev 0e)
Subsystem: Device 1d05:1000
Kernel driver in use: lpc_ich
Kernel modules: lpc_ich
00:1f.3 SMBus: Intel Corporation Atom Processor E3800 Series SMBus Controller (rev 0e)
Subsystem: Device 1d05:1000
Kernel driver in use: i801_smbus
Kernel modules: i2c_i801
01:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
Subsystem: AzureWave AW-NE139H Half-size Mini PCIe Card
Kernel driver in use: rtl8192ce
Kernel modules: rtl8192ce
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTL8411B PCI Express Card Reader (rev 01)
Subsystem: Realtek Semiconductor Co., Ltd. RTL8411B PCI Express Card Reader
Kernel driver in use: rtsx_pci
Kernel modules: rtsx_pci
02:00.1 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 12)
Subsystem: Device 1d05:1000
Kernel driver in use: r8169
Kernel modules: r8169
[email protected]:~$

Ou seja, quando se digita um comando ele informa um assunto, mas, se digitar este comando com outro irá aparecer mais informações ... valeu e muito obrigado!


  


2. Re: Wi-Fi não funciona no Debian

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 10/12/2018 - 02:17h

nas versões oficiais do debian não vem instalados os firmwares wireless, o usuário tem que instalar no braço. manda aí.
lspci 


------------------------------------------| Linux User #621728 |-----------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------| Linux User #621728 |-----------------------------------------



3. Re: Wi-Fi não funciona no Debian

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 10/12/2018 - 09:58h

Conecte notebook CCE que Wi-Fi não funciona com Debian na internet via cabo
Abra terminal
Poste saída comando: lspci

----------------------------------------------------------------------------------
Itautec-w7535 (Ci3 + 4 GB/RAM + 120 GB/SSD + Intel HD 3000)




4. Olá pessoal! Ainda na luta ...

Ewerton Nascimento Sant Anna
ensabr

(usa Debian)

Enviado em 12/12/2018 - 12:28h

Olá pessoal! Ainda estou esperando por mais informações!
Entretanto hoje de madrugada (quarta-feira) notei que o notebook aparecia um quadradinho em habilitar wifi e banda larga, mas ao clicar ainda dava erro! Interessante!
E gostaria de pedir um conselho:
Será que devo instalar o Linux Ubuntu Mate?
Tal pergunta é devido que o DESKTOP com Debian também apresentou erro:
1) Não esta identificando o monitor correto;
2) Está solicitando senha do adminstrador toda hora ao ligar (que digito) e depois sou obrigado a digitar o comando exit e colocar o dvd debian live para este funcionar!
Ou deixo o Debian, e com estes erros vou aprendendo?
Abraços!


5. Re: Wi-Fi não funciona no Debian

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 12/12/2018 - 13:38h

-sugiro começar com xubuntu ou ubuntu-mate que são mais amigáveis e depois passar p/ debian-estavel em 2019 quando lançarem o debian-10

----------------------------------------------------------------------------------
Itautec-w7535 (Ci3 + 4 GB/RAM + 120 GB/SSD + Intel HD 3000)




6. Re: Wi-Fi não funciona no Debian

Xerxes Lins
xerxeslins

(usa Red Hat)

Enviado em 12/12/2018 - 15:43h

É por essas e outras que sempre se deve baixar o Debian non-free. O Debian padrão vem sem algumas coisas.

Por favor veja esta dica, pois te dar uma luz:

https://www.vivaolinux.com.br/dica/Wi-Fi-no-Dell-Inspiron-N4030-Configuracao-no-Debian-7




--
"There are lots of Linux users who don't care how the kernel works, but only want to use it. That is a tribute to how good Linux is." - Linus Torvalds



7. Re: Wi-Fi não funciona no Debian

Xerxes Lins
xerxeslins

(usa Red Hat)

Enviado em 12/12/2018 - 15:47h

Após habilitar o contrin e o non-free. Execute:

# apt-get update && apt-get install firmware-realtek

Depois disso deve funcionar seu wi-fi.

Pela sua placa de rede o tutorial do Debian está em:

https://wiki.debian.org/rtl819x

--
"There are lots of Linux users who don't care how the kernel works, but only want to use it. That is a tribute to how good Linux is." - Linus Torvalds



8. Agradecendo a colaboração e sugestões!

Ewerton Nascimento Sant Anna
ensabr

(usa Debian)

Enviado em 13/12/2018 - 12:43h

Olá quero agradecer pela colaboração e sugestões recebidas!
portanto, após tentar instalar o Wi-fi no Linux Debian Mate 9.4 em um notebook CCE4030 informo:
NÃO foi realizado com sucesso!
Motivo:
Ao tentar enviar um comando, este solicita senha!
Tentei a do usuário e Administrador e deu ERRO!
Então ... tentarei mais tarde, instalar o Linux Ubuntu Mate 16.04 ( que já tinha baixado e instalado com SUCESSO em outro notebook CCE4030 (pois o DVD Linux Ubuntu 12.04 deu ERRO (era um que uma pessoa me vendeu).
Mas fiquei curioso com 2 detalhes sugeridos que depois irei vereficar:
a) Tentar instalar a versão 10. não sei se daria certo, pois provavelment irá acontecer o mesmo erro!
b) Como este Notebook era um Windows 10, compartilhado com o Ubuntu 18 vou vereficar posteriormente então mudar o outro Notebook CCE4030 que já tem o Ubuntu Mate 16.04 ser trocado por um Debian 09 ou um futuro 10.
Motivo:
1) Talvez por este ser um notebook de fabrica ccom linux, aceite sem ERROS!
2) Assim testarei o Hardware se está funcionando corretamente!
3) Gostei de aprender alguns comandos, então será útil ter um aparelho para testes!
Apenas informando:
É estranho ter dado errado? Pois o DVD de instalação é o mesmo que tinha em outro notebook Positivo Sim +1955m
que funcionou muito bem até ser "confrontado" com um Ubuntu e aí "travou", é mais curioso ainda pensando que em um mero netbook Positivo Mobo tem instalado o Debian 2 e atualmente é o 8 ou 9 não me lembro bem agora! Em verdade o Notebook Positivo Sim+1955m, vei de fábrica com um Linux de fábrica que nem cheguei a usar, pois na época acabei instalando o Ubuntu 10 e est foi "maravilhoso" que só me arrependo ter atualizado, pois perdi o desktop padrão para o modelo atual (que não gosto). Tentei instalar um OpenSuse, sem sucesso! Não entendi (ainda o que deveria fazer)
Então, mais uma vez agradeço para todos e irei deixar este assunto (por minha parte) até ter mais informações!
Sem mais para o momento.
Atenciosamente.
Ewerton Nascimento Sant' Anna (bigode)
"Que homem é um HOMEM que não procura criar algo melhor"
... pois como gostam de frases mas não sabem da histórina que o SADAN não entendeu e tiveram que explicar:
"Um vez um passarinho com frio piou muito, com pena a vaca cagou muito nele e o calor esquentou e o frio passou ... mas o passarinho aquecido reclamou do fedor e piou muito ... um gato veio e o limpou, lambendo-o ... o passarinho feliz piou muito ... e o gato o comeu!"
Moral:
"Nem sempre aquele que te tira da [*****] é teu amigo"


9. Obrigado pela dica do link sobre a placa de rede

David Ricardo de Jesus Silva
davidsilva23

(usa Debian)

Enviado em 25/12/2018 - 12:02h

xerxeslins escreveu:

Após habilitar o contrin e o non-free. Execute:

# apt-get update && apt-get install firmware-realtek

Depois disso deve funcionar seu wi-fi.

Pela sua placa de rede o tutorial do Debian está em:

https://wiki.debian.org/rtl819x

--
"There are lots of Linux users who don't care how the kernel works, but only want to use it. That is a tribute to how good Linux is." - Linus Torvalds





10. Olá, quero agradecer pela ajuda.

Ewerton Nascimento Sant Anna
ensabr

(usa Debian)

Enviado em 02/01/2019 - 13:51h

obrigado pela ajuda problema resolvido!






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts