Após configuração com o nvidia-xconfig,x não sobe mais.

1. Após configuração com o nvidia-xconfig,x não sobe mais.

Rafael Lopes Adão
monrahcold

(usa Debian)

Enviado em 25/07/2011 - 22:28h

Galera,já pesquisei muito e não consigo encontra uma solução.
Estou com Debian em uma VM no Virtual Box.
Pois bem,depois de muito sacrificio(acho)que instalei o driver da nvidia para a 8400GS.
Segui o seguinte procedimento:
Instalando o Driver da Nvidia.

apt-get update
# apt-get install module-assistant nvidia-kernel-common build-essential
# m-a clean nvidia-kernel-source
# m-a purge nvidia-kernel-source
# m-a prepare
# aptitude install nvidia-kernel-source/stable
# m-a a-i nvidia-kernel-source
# apt-get install nvidia-glx
# apt-get install nvidia-libvdpau1 (não encontrou)
# apt-get install nvidia-settings
# apt-get install nvidia-libvdpau1-i (não encontrou)
Reiniciei o micro e apareçeu o icone da nvidia no sistema>Administração mas ele me informou que
era necessário configurar o nvidia-xconfig,executei e não foi encontrado,verificado que não estava
instalado.
# apt-get install nvidia-xconfig (escreveu um xorg em etc/X11/xorg.conf)
Comentários em parenteses são meus.
após isso fui configurar o xorg que o nvidia-xconfig cria (antes não tinha xorg.conf no /etc/X11/)
Segui esse tutorial:na parte de config do xorg a onde tem que adicionar algumas linhas: "http://www.hardware.com.br/dicas/nvidia-debian-lenny.html"
Fiz com outros xorg tbm nas nada o X não sobe mais e ficar com a tela de cursos piscando só,nem no modo texto consigo entrar mais.
Agradeço desde já a ajuda.



  


2. Atualização nvidia

Andre Luiz
andre_debian

(usa Debian)

Enviado em 25/07/2011 - 23:52h

O meu ta da mesma forma, mas ainda consigo voltar para o modo texto, mas não consigo subir o X. Depois que fiz algumas atualizações da Nvidia pelo gerenciador de pacotes Synaptic não sobe mais a parte grafica e no Grub tem varias versões para inicializar. Executei o comando Xorg -configure e apareceu a mensagem para executar o comando X -config /root/xorg.conf.new, mas dá erro.


3. Re: Após configuração com o nvidia-xconfig,x não sobe mais.

anna kamilla
annakamilla

(usa Manjaro Linux)

Enviado em 26/07/2011 - 00:16h

creio que ambos os casos seja a frequência do monitor, tente adicionar as frequencias de voces no xorg gerado pela nvidia.
uma outra coisinha, eu uso ubuntu 10.04 e rodo o driver compilado 275, existe um tutorial bom que ensina a compilar no ubuntu que deve servir para o debian.
mais ou menos fiz isso daqui ó:
http://www.ubuntugeek.com/howto-install-nvidia-drivers-manually-on-ubuntu-10-04-lucid-lynx.html
só que somente coloquei o nouveau e o vga16fb



4. Re: Após configuração com o nvidia-xconfig,x não sobe mais.

Perfil removido
removido

(usa Nenhuma)

Enviado em 26/07/2011 - 00:30h

O pc da minha irmã tem a mesma placa que a sua e eu sempre baixo direto do site da nvidia e instalo sem problema algum, inclusive ele já configura tudinho automático, não preciso alterar nada.

Tenho mais outros pcs com a 8200 e 8600, e faço o mesmo procedimento e tudo corre perfeitamente bem, o próprio utilitario desabilita drivers conflitantes, ajeita o xorg, o gl , tudin, não sei porque tanta gente tem dificuldade com isso.

Eu uso mais ubuntu (e derivadas), mas já testei o Debian aqui e fiz o mesmo procedimento ocorrendo tudo sem nenhum problema.

da um wget ai e instala pelo utilitário, é mais simples.


5. Xorg reconfigurado

Andre Luiz
andre_debian

(usa Debian)

Enviado em 26/07/2011 - 00:37h

Resolvido, executei os seguintes passos:
Xorg -configure => para criar um novo arquivo xorg.conf.new no /root
cd /root
cp xorg.conf.new /etc/X11/xorg.conf
startx
mas antes de tudo eu tinha parado o gdm3 com o /etc/init.d/gdm3 stop

espero que funcione para vc tb.


6. Re: Após configuração com o nvidia-xconfig,x não sobe mais.

Andre (pinduvoz)
pinduvoz

(usa Debian)

Enviado em 26/07/2011 - 01:10h

Pessoal, prestem atenção num detalhe: sistemas "ghest" do Virtualbox ou do VMWare não usam o hardware real da máquina.


7. Re: Após configuração com o nvidia-xconfig,x não sobe mais.

Rafael Lopes Adão
monrah.cold

(usa Debian)

Enviado em 11/08/2011 - 19:58h

O pinduvoz tem razão o hardware é emulado no virtual box.
Instalando na maquina real para ver se rola...


8. Re: Após configuração com o nvidia-xconfig,x não sobe mais.

Rafael Lopes Adão
monrah.cold

(usa Debian)

Enviado em 11/08/2011 - 20:38h

Depois de muito penar finalmente consegui instalar.
Vou criar um procedimento aqui explicando o que cada linha de comando realmente realiza,não adianta só dar as linhas de comandos sem explicar o que ela realmente faz.
Valeu pela Ajuda.


9. Re: Após configuração com o nvidia-xconfig,x não sobe mais.

Perfil removido
removido

(usa Nenhuma)

Enviado em 11/08/2011 - 20:49h

o que você precisa fazer já que é no VirtualBox (e não numa instalação real) é:

# apt-get install linux-headers-`uname -r` build-essential dkms

reiniciar o PC

Depois montar a imagem do VirtualBox Guest Additions como seu driver de CD, usualmente ela fica em /usr/share/virtualbox/VBoxGuestAdditions.iso

Acessar o ponto de montagem do CDROM (no meu caso usando o Knoppix) ela será montada em /media/sr0, acessando-a pelo terminal digite isso:

# sh VBoxLinuxAdditions.sh
ou
# ./VBoxLinuxAdditions.sh

tendo concluído a instalação, adicione seu usuário ao grupo 'vboxsf', assim você conseguirá acessar as pastas compartilhadas.

se tudo der certo 'automagicamente' seu driver de vídeo 'do VirtualBox' será instalado.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts