sources.list no Debian 11 "bullseye" [RESOLVIDO]

1. sources.list no Debian 11 "bullseye" [RESOLVIDO]

rafael
ogro33

(usa Debian)

Enviado em 22/01/2022 - 04:39h

Pessoal,

Estava fuçando aqui no sistema e ao verificar o conteudo do /etc/apt/sources.list me deparei com o seguinte:

# See https://wiki.debian.org/SourcesList for more information.
deb http://deb.debian.org/debian bullseye main contrib non-free
deb-src http://deb.debian.org/debian bullseye main contrib non-free

deb http://deb.debian.org/debian bullseye-updates main contrib non-free
deb-src http://deb.debian.org/debian bullseye-updates main contrib non-free

deb http://security.debian.org/debian-security/ bullseye-security main contrib non-free
deb-src http://security.debian.org/debian-security/ bullseye-security main contrib non-free

deb http://deb.debian.org/debian/ buster main


Lembrando que estou com o Bullseye instalado.

Vi a entrada referente ao repositorio deb http://deb.debian.org/debian/ buster main. E pelo que pesquisei, ela não deveria estar ali, correto?
Não lembro de ter adicionado ela, mas não descarto totalmente essa possibilidade. Então, comentei a linha e após salvar o arquivo, rodei um apt update e depois um apt autoremove e também um apt upgrade e nenhum pacote foi atualizado ou removido.
Fiquei na duvida se agi corretamente e se tem alguma outra coisa que eu deva fazer.

Outra coisa, pesquisei uma forma de descobrir quais pacotes de determinado repositorio estão instalados atualmente no sistema, mas não achei nada a respeito. Alguem sabe como faz isso?

Muito obrigado a todos pelas contribuições!!!


  


2. MELHOR RESPOSTA

Leomar de Oliveira
leoCCB

(usa Slackware)

Enviado em 22/01/2022 - 21:55h


ogro33 escreveu:

Não sei se consegui me expressar direito no primeiro post.
Mas a minha duvida é se ao informar no sources.list um repositorio de uma versão diferente do Debian da qual eu estou usando, o sistema não possa ter instalado pacotes desse repositorio mais antigo? E se caso positivo, qual o caminho para remover esses pacotes e evitar problemas futuros causados pela possivel incompatibilidade de versões entre pacotes de repositorios de diferentes versões do sistema operacional?

Obrigado!


os pacotes mais recentes sempre têm preferência. Às vezes um repositório diferente é adicionado caso nos oficiais da versão não tenha um determinado pacote... então não oferece muito perigo não, mas é bom ficar atento se não vai fazer dowgrade de algum pacote aí...


3. Re: sources.list no Debian 11 "bullseye" [RESOLVIDO]

Fernando T. Da Silva
nandosilva

(usa Lubuntu)

Enviado em 22/01/2022 - 07:58h


Você provavelmente adicionar a linha deb http://deb.debian.org/debian/ buster main e não se lembra mais.
Quanto ao uso da parte apt upgrade que você fez depois de remover a linha citada e não foi listado nenhuma pacote para upgrade, por acaso
antes de você descobrir a linha do buster, você já não tinha rodando um apt upgrade antes, há uns 2 ou mais dias atrás, se sim, é porque
não surgiu ainda pacotes mais recentes pra atualização até a data que você rodou o comando apt upgrade, e como você já tinha rodado ele há 2 ou mais dias, então não há pacotes para ser atualizado no momento no seu computador.




4. Re: sources.list no Debian 11 "bullseye" [RESOLVIDO]

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 22/01/2022 - 08:25h

Passos 1-2-3
https://www.vivaolinux.com.br/dica/Debian-11-Bullseye-para-Inicantes





5. Re: sources.list no Debian 11 "bullseye" [RESOLVIDO]

rafael
ogro33

(usa Debian)

Enviado em 22/01/2022 - 19:25h

Não sei se consegui me expressar direito no primeiro post.
Mas a minha duvida é se ao informar no sources.list um repositorio de uma versão diferente do Debian da qual eu estou usando, o sistema não possa ter instalado pacotes desse repositorio mais antigo? E se caso positivo, qual o caminho para remover esses pacotes e evitar problemas futuros causados pela possivel incompatibilidade de versões entre pacotes de repositorios de diferentes versões do sistema operacional?

Obrigado!


6. Re: sources.list no Debian 11 "bullseye" [RESOLVIDO]

Fernando T. Da Silva
nandosilva

(usa Lubuntu)

Enviado em 22/01/2022 - 20:55h


ogro33 escreveu:

Não sei se consegui me expressar direito no primeiro post.
Mas a minha duvida é se ao informar no sources.list um repositorio de uma versão diferente do Debian da qual eu estou usando, o sistema não possa ter instalado pacotes desse repositorio mais antigo? E se caso positivo, qual o caminho para remover esses pacotes e evitar problemas futuros causados pela possivel incompatibilidade de versões entre pacotes de repositorios de diferentes versões do sistema operacional?

Obrigado!


===================================================
Bom ai depende é só você se puxar para memória, que pacotes você instalou recentemente até descobrir a linha
deb http://deb.debian.org/debian/ buster main no final da source.list ?

Mesmo tendo instalado alguns pacotes do repositório e você não lembra qual é o nome do mesmo, deste que o seu sistema esteja funcionando bem, não é motivo para grande preocupação, já que quando você rodou o apt upregade ele diz que não há atualizações disponíveis pra instalar. Pois muitos pacotes da última versão de atualização para o debian 10 possuir as mesmas versões no Debian 11 caso não houve atualizações nestes pacotes.


7. Re: sources.list no Debian 11 "bullseye" [RESOLVIDO]

rafael
ogro33

(usa Debian)

Enviado em 22/01/2022 - 22:52h


leoCCB escreveu:


ogro33 escreveu:

Não sei se consegui me expressar direito no primeiro post.
Mas a minha duvida é se ao informar no sources.list um repositorio de uma versão diferente do Debian da qual eu estou usando, o sistema não possa ter instalado pacotes desse repositorio mais antigo? E se caso positivo, qual o caminho para remover esses pacotes e evitar problemas futuros causados pela possivel incompatibilidade de versões entre pacotes de repositorios de diferentes versões do sistema operacional?

Obrigado!


os pacotes mais recentes sempre têm preferência. Às vezes um repositório diferente é adicionado caso nos oficiais da versão não tenha um determinado pacote... então não oferece muito perigo não, mas é bom ficar atento se não vai fazer dowgrade de algum pacote aí...


Obrigado pelo esclarecimento.
Aparentemente não foi feito nenhum downgrade. Pelo menos não aparece nenhum pacote marcado como "upgradable" quando rodo o apt.