apt-get não funciona no Debian 9 [RESOLVIDO]

1. apt-get não funciona no Debian 9 [RESOLVIDO]

Bruno Donatelli
brunoredes103

(usa Debian)

Enviado em 16/05/2018 - 19:56h

Boa noite

Instalei o debian 9 e estou tentando usar o apt-get para instalar algumas coisas que preciso (vim e mais algumas coisas), mas ele dá esse erro:
Media change: please insert the disc labeled
'Debian GNU/Linux 9.1.0 _Stretch_ - Official i386 DVD Binary-1 20170722-12:45'
in the drive '/media/cdrom/' and press [Enter]

como eu posso resolver esse erro?



Att.


  


2. MELHOR RESPOSTA

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 16/05/2018 - 21:19h

Edite seus repositórios
https://www.vivaolinux.com.br/dica/Simples-pos-instalacao-do-Debian-9-Strech

3. Re: apt-get não funciona no Debian 9 [RESOLVIDO]

Matheus
pylm

(usa Gentoo)

Enviado em 16/05/2018 - 20:00h

Adiciona (ou tira o comentário) os repositórios online no /etc/apt/sources.list
Aí ele tá procurando só pelo repositório offline que você supostamente manteria num DVD.


4. Re: apt-get não funciona

Bruno Donatelli
brunoredes103

(usa Debian)

Enviado em 16/05/2018 - 20:03h

pylm escreveu:

Adiciona (ou tira o comentário) os repositórios online no /etc/apt/sources.list
Aí ele tá procurando só pelo repositório offline que você supostamente manteria num DVD.


como eu faço isso? Acabei de começar a conhecer o debian kk


Edit1: Isso que ta escrito quando eu digito vi /etc/apt/sources.list

#

# deb cdrom:[Debian GNU/Linux 9.1.0 _Stretch_ - Official i386 DVD Binary-1 20170722-12:45]/ stretch contrib main

deb cdrom:[Debian GNU/Linux 9.1.0 _Stretch_ - Official i386 DVD Binary-1 20170722-12:45]/ stretch contrib main

deb http://security.debian.org/debian-security stretch/updates main contrib
deb-src http://security.debian.org/debian-security stretch/updates main contrib

# stretch-updates, previously known as 'volatile'
# A network mirror was not selected during install. The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.
#
# deb http://deb.debian.org/debian/ stretch-updates main contrib
# deb-src http://deb.debian.org/debian/ stretch-updates main contrib

O que eu removo ou adiciono aí?


5. Re: apt-get não funciona no Debian 9 [RESOLVIDO]

Matheus
pylm

(usa Gentoo)

Enviado em 16/05/2018 - 20:26h


#

# deb cdrom:[Debian GNU/Linux 9.1.0 _Stretch_ - Official i386 DVD Binary-1 20170722-12:45]/ stretch contrib main

# deb cdrom:[Debian GNU/Linux 9.1.0 _Stretch_ - Official i386 DVD Binary-1 20170722-12:45]/ stretch contrib main

deb http://security.debian.org/debian-security stretch/updates main contrib
deb-src http://security.debian.org/debian-security stretch/updates main contrib

# stretch-updates, previously known as 'volatile'
# A network mirror was not selected during install. The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.
#
deb http://deb.debian.org/debian/ stretch-updates main contrib
# deb-src http://deb.debian.org/debian/ stretch-updates main contrib


Deixa ele assim, deve ser suficiente.

E pra atualizar os repositórios:

# apt update



6. Re: apt-get não funciona

Bruno Donatelli
brunoredes103

(usa Debian)

Enviado em 16/05/2018 - 20:49h

pylm escreveu:


#

# deb cdrom:[Debian GNU/Linux 9.1.0 _Stretch_ - Official i386 DVD Binary-1 20170722-12:45]/ stretch contrib main

# deb cdrom:[Debian GNU/Linux 9.1.0 _Stretch_ - Official i386 DVD Binary-1 20170722-12:45]/ stretch contrib main

deb http://security.debian.org/debian-security">http://security.debian.org/debian-security stretch/updates main contrib
deb-src http://security.debian.org/debian-security">http://security.debian.org/debian-security stretch/updates main contrib

# stretch-updates, previously known as 'volatile'
# A network mirror was not selected during install. The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.
#
deb http://deb.debian.org/debian/">http://deb.debian.org/debian/ stretch-updates main contrib
# deb-src http://deb.debian.org/debian/">http://deb.debian.org/debian/ stretch-updates main contrib


Deixa ele assim, deve ser suficiente.

E pra atualizar os repositórios:

# apt update





Agora tô tendo esse problema aqui:

apt-get update
Obter:1 http://security.debian.org/debian-security">http://security.debian.org/debian-security stretch/updates InRelease [94,3 kB]
Ign:2 http://security.debian.org/debian security InRelease
Ign:3 http://security.debian.org/debian security Release
Ign:4 http://security.debian.org/debian security/contrib Sources
Atingido:5 http://deb.debian.org/debian stretch-updates InRelease
Ign:6 http://security.debian.org/debian security/stretch/updates Sources
Ign:7 http://security.debian.org/debian security/main Sources
Ign:4 http://security.debian.org/debian security/contrib Sources
Ign:6 http://security.debian.org/debian security/stretch/updates Sources
Ign:7 http://security.debian.org/debian security/main Sources
Ign:4 http://security.debian.org/debian security/contrib Sources
Ign:6 http://security.debian.org/debian security/stretch/updates Sources
Ign:7 http://security.debian.org/debian security/main Sources
Ign:4 http://security.debian.org/debian security/contrib Sources
Ign:6 http://security.debian.org/debian security/stretch/updates Sources
Ign:7 http://security.debian.org/debian security/main Sources
Ign:4 http://security.debian.org/debian security/contrib Sources
Ign:6 http://security.debian.org/debian security/stretch/updates Sources
Ign:7 http://security.debian.org/debian security/main Sources
Err:4 http://security.debian.org/debian security/contrib Sources
404 Not Found [IP: 151.101.92.204 80]
Ign:6 http://security.debian.org/debian security/stretch/updates Sources
Ign:7 http://security.debian.org/debian security/main Sources
Baixados 94,3 kB em 4s (22,0 kB/s)
Lendo listas de pacotes... Pronto
W: The repository 'http://security.debian.org/debian security Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Falhou ao buscar http://security.debian.org/debian/dists/security/contrib/source/Sources 404 Not Found [IP: 151.101.92.204 80]
E: Falhou o download de alguns ficheiros de índice. Foram ignorados ou os antigos foram usados em seu lugar.



Será que vou ter de reinstalar o debian?


7. Re: apt-get não funciona

Matheus
pylm

(usa Gentoo)

Enviado em 16/05/2018 - 21:09h

Não sei porque mas quando você me quotou o texto foi modificado e foi errado pro teu sources.list, use esse:


# deb cdrom:[Debian GNU/Linux 9.1.0 _Stretch_ - Official i386 DVD Binary-1 20170722-12:45]/ stretch contrib main

# deb cdrom:[Debian GNU/Linux 9.1.0 _Stretch_ - Official i386 DVD Binary-1 20170722-12:45]/ stretch contrib main

deb http://security.debian.org/debian-security stretch/updates main contrib
# deb-src http://security.debian.org/debian-security stretch/updates main contrib

# stretch-updates, previously known as 'volatile'
# A network mirror was not selected during install. The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.
#
deb http://deb.debian.org/debian/ stretch-updates main contrib
# deb-src http://deb.debian.org/debian/ stretch-updates main contrib



8. Re: apt-get não funciona no Debian 9 [RESOLVIDO]

Bruno Donatelli
brunoredes103

(usa Debian)

Enviado em 16/05/2018 - 21:54h

Obrigado, amigos.
Agora meu debian vai fluir muito bem!!! Qualquer outra dúvida eu volto a retornar aqui no fórum. Obrigado por dispor do tempo de vocês






Patrocínio

Site hospedado pelo provedor HostGator.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Viva o Android

Tópicos

Top 10 do mês

Scripts