Problemas ao Atualizar Servidor Debian 10 (apt --fix-broken install não funciona) [RESOLVIDO]

1. Problemas ao Atualizar Servidor Debian 10 (apt --fix-broken install não funciona) [RESOLVIDO]

Nathan
Kumk

(usa Linux Mint)

Enviado em 11/03/2020 - 18:47h

Olá a todos!
Estou com problemas ao atualizar um servidor Debian 10
quando dou o comando apt-get upgrade ele retorna o seguinte erro:

Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Você pode querer executar 'apt --fix-broken install' para corrigí-los.
Os pacotes a seguir têm dependências desencontradas:
php5-gd : Depende: libpng12-0 (>= 1.2.13-4) mas não está instalado
E: Dependências desencontradas. Tente 'apt --fix-broken install' sem nenhum pacote (ou especifique uma solução).

Então executei o comando apt --fix-broken install e exibe:

[email protected]:/home/natcorsi# apt --fix-broken install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Corrigindo dependências... Pronto
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
dbconfig-common javascript-common libjs-jquery libjs-sphinxdoc
libjs-underscore libmcrypt4 libmysqlclient18 libpng12-0 libvpx1
php-php-gettext php-tcpdf php5-gd php5-mcrypt php5-mysql
Utilize 'apt autoremove' para os remover.
The following additional packages will be installed:
libpng12-0
Os NOVOS pacotes a seguir serão instalados:
libpng12-0
0 pacotes atualizados, 1 pacotes novos instalados, 0 a serem removidos e 58 não atualizados.
8 pacotes não totalmente instalados ou removidos.
É preciso baixar 0 B/173 kB de arquivos.
Depois desta operação, 273 kB adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
(Lendo banco de dados ... 70269 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../libpng12-0_1.2.50-2+deb8u3_amd64.deb ...
A descompactar libpng12-0:amd64 (1.2.50-2+deb8u3) ...
dpkg: erro ao processar o arquivo /var/cache/apt/archives/libpng12-0_1.2.50-2+deb8u3_amd64.deb (--unpack):
impossível instalar nova versão de '/usr/lib/x86_64-linux-gnu/libpng12.so.0': Arquivo ou diretório inexistente
Erros foram encontrados durante o processamento de:
/var/cache/apt/archives/libpng12-0_1.2.50-2+deb8u3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Dou o comando apt-get install -f para ele instalar as dependências, mas retorna outro erro:

[email protected]:/home/natcorsi# apt-get install -f
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Corrigindo dependências... Pronto
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
dbconfig-common javascript-common libjs-jquery libjs-sphinxdoc
libjs-underscore libmcrypt4 libmysqlclient18 libpng12-0 libvpx1
php-php-gettext php-tcpdf php5-gd php5-mcrypt php5-mysql
Utilize 'apt autoremove' para os remover.
The following additional packages will be installed:
libpng12-0
Os NOVOS pacotes a seguir serão instalados:
libpng12-0
0 pacotes atualizados, 1 pacotes novos instalados, 0 a serem removidos e 58 não atualizados.
8 pacotes não totalmente instalados ou removidos.
É preciso baixar 0 B/173 kB de arquivos.
Depois desta operação, 273 kB adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
(Lendo banco de dados ... 70269 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../libpng12-0_1.2.50-2+deb8u3_amd64.deb ...
A descompactar libpng12-0:amd64 (1.2.50-2+deb8u3) ...
dpkg: erro ao processar o arquivo /var/cache/apt/archives/libpng12-0_1.2.50-2+deb8u3_amd64.deb (--unpack):
impossível instalar nova versão de '/usr/lib/x86_64-linux-gnu/libpng12.so.0': Arquivo ou diretório inexistente
Erros foram encontrados durante o processamento de:
/var/cache/apt/archives/libpng12-0_1.2.50-2+deb8u3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Tentei instalar este pacote que falta com apt-get install libpng12-0 -f mas também não funcionou, já tentei todos os tutoriais que encontrei, por favor, alguém poderia me ajudar?

Muito Obrigado!


  


2. MELHOR RESPOSTA

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 11/03/2020 - 20:17h

Velho ... o php para o debian 10 é o 7 ... isso é que deve estar dando ruim aí .... vc precisa do 5 ??? senão desinstala e instala o 7 ....

o que vc estava tentando instalar pra esse php 5 ter parado aí ???





------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------



3. Re: Problemas ao Atualizar Servidor Debian 10 (apt --fix-broken install não funciona) [RESOLVIDO]

Nathan
Kumk

(usa Linux Mint)

Enviado em 11/03/2020 - 20:49h


Mauriciodez escreveu:

Velho ... o php para o debian 10 é o 7 ... isso é que deve estar dando ruim aí .... vc precisa do 5 ??? senão desinstala e instala o 7 ....

o que vc estava tentando instalar pra esse php 5 ter parado aí ???


Não sei bem porque esta exibindo esta versão, eu utilizo este pc como um servidor, e no painel do meu wordpress esta dizendo que a versão do php e 7.3.11-1~deb10u1
dei o comando apt-get purge 'php5*' e retornou isto:

Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Note, selecting 'php5-adodb' for glob 'php5*'
Note, selecting 'php5-propro' for glob 'php5*'
Note, selecting 'php5-mapscript' for glob 'php5*'
Note, selecting 'php5-xsl' for glob 'php5*'
Note, selecting 'php5-yac' for glob 'php5*'
Note, selecting 'php5-yaz' for glob 'php5*'
Note, selecting 'php5-ssh2' for glob 'php5*'
Note, selecting 'php5-zmq' for glob 'php5*'
Note, selecting 'php5-stomp' for glob 'php5*'
Note, selecting 'php5-raphf' for glob 'php5*'
Note, selecting 'php5-enchant' for glob 'php5*'
Note, selecting 'php5-amqp' for glob 'php5*'
Note, selecting 'php5-xdebug' for glob 'php5*'
Note, selecting 'php5-gnupg' for glob 'php5*'
Note, selecting 'php5-gd' for glob 'php5*'
Note, selecting 'php5-pecl-http' for glob 'php5*'
Note, selecting 'php5-apcu' for glob 'php5*'
Note, selecting 'php5-igbinary' for glob 'php5*'
Note, selecting 'php5-gdcm' for glob 'php5*'
Note, selecting 'php5-common' for glob 'php5*'
Note, selecting 'php5-geos' for glob 'php5*'
Note, selecting 'php5-memcache' for glob 'php5*'
Note, selecting 'php5-xhprof' for glob 'php5*'
Note, selecting 'php5-interbase' for glob 'php5*'
Note, selecting 'php5-lasso' for glob 'php5*'
Note, selecting 'php5-saprfc' for glob 'php5*'
Note, selecting 'php5-imagick' for glob 'php5*'
Note, selecting 'php5-mhash' for glob 'php5*'
Note, selecting 'php5-mcrypt' for glob 'php5*'
Note, selecting 'php5-raphf-dev' for glob 'php5*'
Note, selecting 'php5.6-json' for glob 'php5*'
Note, selecting 'php5-propro-dev' for glob 'php5*'
Note, selecting 'php5-kadm5' for glob 'php5*'
Note, selecting 'php5-pgsql' for glob 'php5*'
Note, selecting 'php5-mysqli' for glob 'php5*'
Note, selecting 'php5-vtkgdcm' for glob 'php5*'
Note, selecting 'php5.6-common' for glob 'php5*'
Note, selecting 'php5-sybase' for glob 'php5*'
Note, selecting 'php5-libvirt-php' for glob 'php5*'
Note, selecting 'php5-tidy' for glob 'php5*'
Note, selecting 'php5-mssql' for glob 'php5*'
Note, selecting 'php5-cgi' for glob 'php5*'
Note, selecting 'php5-cli' for glob 'php5*'
Note, selecting 'php5-dbg' for glob 'php5*'
Note, selecting 'php5-dev' for glob 'php5*'
Note, selecting 'php5-mongo' for glob 'php5*'
Note, selecting 'php5-geoip' for glob 'php5*'
Note, selecting 'php5-uprofiler' for glob 'php5*'
Note, selecting 'php5-readline' for glob 'php5*'
Note, selecting 'php5-phpdbg' for glob 'php5*'
Note, selecting 'php5-fpm' for glob 'php5*'
Note, selecting 'php5-gmp' for glob 'php5*'
Note, selecting 'php5-json' for glob 'php5*'
Note, selecting 'php5-radius' for glob 'php5*'
Note, selecting 'php5-libpuzzle' for glob 'php5*'
Note, selecting 'php5-sasl' for glob 'php5*'
Note, selecting 'php5-redis' for glob 'php5*'
Note, selecting 'php5-idn' for glob 'php5*'
Note, selecting 'php5-msgpack' for glob 'php5*'
Note, selecting 'php5-suhosin' for glob 'php5*'
Note, selecting 'php5-gearman' for glob 'php5*'
Note, selecting 'php5-curl' for glob 'php5*'
Note, selecting 'php5-ldap' for glob 'php5*'
Note, selecting 'php5-oauth' for glob 'php5*'
Note, selecting 'php5-memcached' for glob 'php5*'
Note, selecting 'php5-lzf' for glob 'php5*'
Note, selecting 'php5-pinba' for glob 'php5*'
Note, selecting 'php5-mysqlnd-ms' for glob 'php5*'
Note, selecting 'php5-xmlrpc' for glob 'php5*'
Note, selecting 'php5-librdf' for glob 'php5*'
Note, selecting 'php5-imap' for glob 'php5*'
Note, selecting 'php5-xcache' for glob 'php5*'
Note, selecting 'php5-mysql' for glob 'php5*'
Note, selecting 'php5-pam' for glob 'php5*'
Note, selecting 'php5-intl' for glob 'php5*'
Note, selecting 'php5-twig' for glob 'php5*'
Note, selecting 'php5-pecl-http-dev' for glob 'php5*'
Note, selecting 'php5-remctl' for glob 'php5*'
Note, selecting 'php5-oci8' for glob 'php5*'
Note, selecting 'php5' for glob 'php5*'
Note, selecting 'php5-tokyo-tyrant' for glob 'php5*'
Note, selecting 'php5-user-cache' for glob 'php5*'
Note, selecting 'php5-odbc' for glob 'php5*'
Note, selecting 'php5-rrd' for glob 'php5*'
Note, selecting 'php5-svn' for glob 'php5*'
Note, selecting 'php5-mysqlnd' for glob 'php5*'
Note, selecting 'php5-php-facedetect' for glob 'php5*'
Note, selecting 'php5-snmp' for glob 'php5*'
Note, selecting 'php5-pspell' for glob 'php5*'
Note, selecting 'php5-opencv' for glob 'php5*'
Note, selecting 'php5-vpopmail' for glob 'php5*'
Note, selecting 'php5-xdiff' for glob 'php5*'
Note, selecting 'php5-solr' for glob 'php5*'
Note, selecting 'php5-sqlite' for glob 'php5*'
Note, selecting 'php5-recode' for glob 'php5*'
Note, selecting 'php5-exactimage' for glob 'php5*'
O pacote 'php5.6-common' não está instalado, por isso não será removido
O pacote 'php5.6-json' não está instalado, por isso não será removido
O pacote 'php5-suhosin' não está instalado, por isso não será removido
O pacote 'php5-vpopmail' não está instalado, por isso não será removido
O pacote 'php5-kadm5' não está instalado, por isso não será removido
O pacote 'php5-saprfc' não está instalado, por isso não será removido
O pacote 'php5-libpuzzle' não está instalado, por isso não será removido
O pacote 'php5-opencv' não está instalado, por isso não será removido
O pacote 'php5-php-facedetect' não está instalado, por isso não será removido
O pacote 'php5-pam' não está instalado, por isso não será removido
O pacote 'php5-lzf' não está instalado, por isso não será removido
O pacote 'php5-oci8' não está instalado, por isso não será removido
Note, a seleccionar 'php5-intl' em vez de 'php5-idn'
O pacote 'php5-xdiff' não está instalado, por isso não será removido
O pacote 'php5-amqp' não está instalado, por isso não será removido
Note, a seleccionar 'php5-common' em vez de 'php5-mhash'
O pacote 'php5-mysqli' não está instalado, por isso não será removido
Note, a seleccionar 'php5-sybase' em vez de 'php5-mssql'
O pacote 'php5-yaz' não está instalado, por isso não será removido
O pacote 'php5-gdcm' não está instalado, por isso não será removido
O pacote 'php5-vtkgdcm' não está instalado, por isso não será removido
O pacote 'php5-geos' não está instalado, por isso não será removido
O pacote 'php5-lasso' não está instalado, por isso não será removido
O pacote 'php5-libvirt-php' não está instalado, por isso não será removido
O pacote 'php5-mapscript' não está instalado, por isso não será removido
O pacote 'php5-adodb' não está instalado, por isso não será removido
O pacote 'php5-apcu' não está instalado, por isso não será removido
O pacote 'php5-gearman' não está instalado, por isso não será removido
O pacote 'php5-geoip' não está instalado, por isso não será removido
O pacote 'php5-gnupg' não está instalado, por isso não será removido
O pacote 'php5-igbinary' não está instalado, por isso não será removido
O pacote 'php5-imagick' não está instalado, por isso não será removido
O pacote 'php5-memcache' não está instalado, por isso não será removido
O pacote 'php5-memcached' não está instalado, por isso não será removido
O pacote 'php5-mongo' não está instalado, por isso não será removido
O pacote 'php5-msgpack' não está instalado, por isso não será removido
O pacote 'php5-mysqlnd-ms' não está instalado, por isso não será removido
O pacote 'php5-oauth' não está instalado, por isso não será removido
O pacote 'php5-pinba' não está instalado, por isso não será removido
O pacote 'php5-propro' não está instalado, por isso não será removido
O pacote 'php5-propro-dev' não está instalado, por isso não será removido
O pacote 'php5-radius' não está instalado, por isso não será removido
O pacote 'php5-raphf' não está instalado, por isso não será removido
O pacote 'php5-raphf-dev' não está instalado, por isso não será removido
O pacote 'php5-redis' não está instalado, por isso não será removido
O pacote 'php5-rrd' não está instalado, por isso não será removido
O pacote 'php5-sasl' não está instalado, por isso não será removido
O pacote 'php5-solr' não está instalado, por isso não será removido
O pacote 'php5-ssh2' não está instalado, por isso não será removido
O pacote 'php5-stomp' não está instalado, por isso não será removido
O pacote 'php5-svn' não está instalado, por isso não será removido
O pacote 'php5-tokyo-tyrant' não está instalado, por isso não será removido
O pacote 'php5-yac' não está instalado, por isso não será removido
O pacote 'php5-zmq' não está instalado, por isso não será removido
O pacote 'php5-librdf' não está instalado, por isso não será removido
O pacote 'php5-remctl' não está instalado, por isso não será removido
O pacote 'php5-twig' não está instalado, por isso não será removido
O pacote 'php5-uprofiler' não está instalado, por isso não será removido
O pacote 'php5-xcache' não está instalado, por isso não será removido
O pacote 'php5-xdebug' não está instalado, por isso não será removido
O pacote 'php5-xhprof' não está instalado, por isso não será removido
O pacote 'php5-exactimage' não está instalado, por isso não será removido
O pacote 'php5-pecl-http' não está instalado, por isso não será removido
O pacote 'php5-pecl-http-dev' não está instalado, por isso não será removido
O pacote 'php5-cgi' não está instalado, por isso não será removido
O pacote 'php5-curl' não está instalado, por isso não será removido
O pacote 'php5-dbg' não está instalado, por isso não será removido
O pacote 'php5-dev' não está instalado, por isso não será removido
O pacote 'php5-enchant' não está instalado, por isso não será removido
O pacote 'php5-fpm' não está instalado, por isso não será removido
O pacote 'php5-gmp' não está instalado, por isso não será removido
O pacote 'php5-imap' não está instalado, por isso não será removido
O pacote 'php5-interbase' não está instalado, por isso não será removido
O pacote 'php5-intl' não está instalado, por isso não será removido
O pacote 'php5-ldap' não está instalado, por isso não será removido
O pacote 'php5-mysqlnd' não está instalado, por isso não será removido
O pacote 'php5-odbc' não está instalado, por isso não será removido
O pacote 'php5-pgsql' não está instalado, por isso não será removido
O pacote 'php5-phpdbg' não está instalado, por isso não será removido
O pacote 'php5-pspell' não está instalado, por isso não será removido
O pacote 'php5-recode' não está instalado, por isso não será removido
O pacote 'php5-snmp' não está instalado, por isso não será removido
O pacote 'php5-sqlite' não está instalado, por isso não será removido
O pacote 'php5-sybase' não está instalado, por isso não será removido
O pacote 'php5-tidy' não está instalado, por isso não será removido
O pacote 'php5-xsl' não está instalado, por isso não será removido
Você pode querer executar 'apt --fix-broken install' para corrigí-los.
Os pacotes a seguir têm dependências desencontradas:
libapache2-mod-php5 : Depende: php5-common (= 5.6.40+dfsg-0+deb8u9) mas não será instalado
Depende: php5-cli mas não será instalado
Depende: php5-json mas não será instalado
E: Dependências desencontradas. Tente 'apt --fix-broken install' sem nenhum pacote (ou especifique uma solução).


Muito obrigado pela atenção, já varri a internet atras de alguma solução, mas não encontrei.


4. Re: Problemas ao Atualizar Servidor Debian 10 (apt --fix-broken install não funciona) [RESOLVIDO]

Stanislaus K
StanislausK

(usa FreeBSD)

Enviado em 12/03/2020 - 10:19h

Ola,

você já viu isso:

Como solucionar o erro de dependência Libpng12-0
https://sempreupdate.com.br/como-solucionar-o-erro-de-dependencia-libpng12-0/


5. Re: Problemas ao Atualizar Servidor Debian 10 (apt --fix-broken install não funciona) [RESOLVIDO]

Nathan
Kumk

(usa Linux Mint)

Enviado em 12/03/2020 - 12:23h




Ola,

você já viu isso:

Como solucionar o erro de dependência Libpng12-0
https://sempreupdate.com.br/como-solucionar-o-erro-de-dependencia-libpng12-0/


Olá! já vi sim
Quando dou o comando:

sudo wget http://ftp.us.debian.org/debian/pool/main/libp/libpng/libpng12-0_1.2.50-2+deb8u3_amd64.deb


Ele até baixa o arquivo deb mas depois quando vou instalar a lib ele da este erro:

[email protected]:/home/natcorsi# dpkg -i libpng12-0_1.2.50-2+deb8u3_amd64.deb
(Lendo banco de dados ... 70269 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar libpng12-0_1.2.50-2+deb8u3_amd64.deb ...
A descompactar libpng12-0:amd64 (1.2.50-2+deb8u3) ...
dpkg: erro ao processar o arquivo libpng12-0_1.2.50-2+deb8u3_amd64.deb (--install):
impossível instalar nova versão de '/usr/lib/x86_64-linux-gnu/libpng12.so.0': Arquivo ou diretório inexistente
Erros foram encontrados durante o processamento de:
libpng12-0_1.2.50-2+deb8u3_amd64.deb


Já tentei diversos tutoriais da internet.
Obrigado pela atenção!




6. Re: Problemas ao Atualizar Servidor Debian 10 (apt --fix-broken install não funciona) [RESOLVIDO]

Patrick
Freud_Tux

(usa Outra)

Enviado em 12/03/2020 - 17:02h


dpkg: erro ao processar o arquivo /var/cache/apt/archives/libpng12-0_1.2.50-2+deb8u3_amd64.deb (--unpack):
impossível instalar nova versão de '/usr/lib/x86_64-linux-gnu/libpng12.so.0': Arquivo ou diretório inexistente

Erros foram encontrados durante o processamento de:
/var/cache/apt/archives/libpng12-0_1.2.50-2+deb8u3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


O dpkg tá reclamando disso aqui:

/usr/lib/x86_64-linux-gnu/libpng12.so.0


Verifica o que tem nesse caminho (/usr/lib/x86_64-linux-gnu) e se te algum arquivo chamado libpng12.so.0

Outra coisa.
Descompacte o pacote deb que você baixou.
Procure o arquivo que mostra as depêndencias dele, ou veja aqui:

https://packages.debian.org/search?keywords=libpng

Dá uma olhada. Só tem para o Jessie e para o Sid. Verifica as dependências de cada um e verá que vai ter um trabalhinho.

Olha as opções para o Buster:

https://packages.debian.org/search?suite=buster&keywords=libpng

Meu conselho.
Tenta primeiro, ver se coloca ai, alguma opção que sirva para o Buster. Instala ela e verifica se o sistema ou outro programa vai chiar. Se não, manda pro espaço o libpng12-0. Você veio deuma atualização de Jessie pra Buster, pelo visto, pois, isso explica muitos dos pacotes ai.
Se não tiver como, vai ter que trabalhar as dependências da versão para o SID, sem quebrar o sistema, e torcer pra funcionar.
Nesse caso, as chances de quebrar o sistema são bem grandes.
Fica esperto com isso, pois dependendo de como fizer, vai dar certo, ou muito errado.
Não me responsabilizo nesse caso.
Pese os prós e contras.

T+


-------------------------------------------------------------------------------------------------------------------------------------------------
Noob: "[...]Sou muito noob ainda usando o terminal, então preciso de ajuda "mastigada", pra operá-lo."
zhushazang: "Sou velho e meus dentes desgastados. Estude linux www.guiafoca.org";

" Ignorance is bliss, for learning is the highest joy. " - High Elf Archer


7. Re: Problemas ao Atualizar Servidor Debian 10 (apt --fix-broken install não funciona) [RESOLVIDO]

Stanislaus K
StanislausK

(usa FreeBSD)

Enviado em 12/03/2020 - 17:44h

Ola,

explique melhor a sua situação... voce esta tentando atualizar para o Debian 10 a partir de qual versão do Debian? O colega acima insinuou que voce está fazendo do Debian 8 para o Debian 10, isso procede?


8. Re: Problemas ao Atualizar Servidor Debian 10 (apt --fix-broken install não funciona) [RESOLVIDO]

Nathan
Kumk

(usa Linux Mint)

Enviado em 02/04/2020 - 19:03h


Freud_Tux escreveu:

O dpkg tá reclamando disso aqui:

/usr/lib/x86_64-linux-gnu/libpng12.so.0


Verifica o que tem nesse caminho (/usr/lib/x86_64-linux-gnu) e se te algum arquivo chamado libpng12.so.0

Outra coisa.
Descompacte o pacote deb que você baixou.
Procure o arquivo que mostra as depêndencias dele, ou veja aqui:

https://packages.debian.org/search?keywords=libpng

Dá uma olhada. Só tem para o Jessie e para o Sid. Verifica as dependências de cada um e verá que vai ter um trabalhinho.

Olha as opções para o Buster:

https://packages.debian.org/search?suite=buster&keywords=libpng

Meu conselho.
Tenta primeiro, ver se coloca ai, alguma opção que sirva para o Buster. Instala ela e verifica se o sistema ou outro programa vai chiar. Se não, manda pro espaço o libpng12-0. Você veio deuma atualização de Jessie pra Buster, pelo visto, pois, isso explica muitos dos pacotes ai.
Se não tiver como, vai ter que trabalhar as dependências da versão para o SID, sem quebrar o sistema, e torcer pra funcionar.
Nesse caso, as chances de quebrar o sistema são bem grandes.
Fica esperto com isso, pois dependendo de como fizer, vai dar certo, ou muito errado.
Não me responsabilizo nesse caso.
Pese os prós e contras.


As unicas versões do lib png que tem no caminho citado são estas:
libpng16.so.16
libpng16.so.16.36.0



9. Re: Problemas ao Atualizar Servidor Debian 10 (apt --fix-broken install não funciona) [RESOLVIDO]

Nathan
Kumk

(usa Linux Mint)

Enviado em 02/04/2020 - 19:07h


StanislausK escreveu:

Ola,

explique melhor a sua situação... voce esta tentando atualizar para o Debian 10 a partir de qual versão do Debian? O colega acima insinuou que voce está fazendo do Debian 8 para o Debian 10, isso procede?


Na verdade já tenho o debian 10
Segue as informações do meu sistema:

[email protected]:~$ neofetch
_,met$$$$$gg. [email protected]
,g$$$$$$$$$$$$$$$P. ------------
,g$$P" """Y$$.". OS: Debian GNU/Linux 10 (buster) x86_64
,$$P' `$$$. Host: Aspire 4739Z V1.05
',$$P ,ggs. `$$b: Kernel: 4.19.0-6-amd64
`d$$' ,$P"' . $$$ Uptime: 54 days, 2 hours, 27 mins
$$P d$' , $$P Packages: 610 (dpkg)
$$: $$. - ,d$$' Shell: bash 5.0.3
$$; Y$b._ _,d$P' Terminal: /dev/pts/0
Y$$. `.`"Y$$$$P"' CPU: Intel Pentium P6200 (2) @ 2.133GHz
`$$b "-.__ GPU: Intel Core Processor
`Y$$ Memory: 682MiB / 3621MiB
`Y$$.
`$$b.
`Y$$b.
`"Y$b._
`"""




10. Re: Problemas ao Atualizar Servidor Debian 10 (apt --fix-broken install não funciona) [RESOLVIDO]

Nathan
Kumk

(usa Linux Mint)

Enviado em 03/04/2020 - 15:32h

Finalmente, depois de quebrar a cabeça consegui resolver.
Pesquisando, vi que este pacote libpng12-0 já estava obsoleto, e meu sistema já tinha versões mais atualizadas deste pacote, então dei o comando apt-get remove php5-gd que era o único pacote que tinha esta dependência (já possuo o php 7), agora consigo atualizar e instalar novos pacotes novamente.

A solução foi simples para tanta dor de cabeça.
Sou grato a todos pela ajuda!



11. Re: Problemas ao Atualizar Servidor Debian 10 (apt --fix-broken install não funciona) [RESOLVIDO]

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 03/04/2020 - 19:09h


Kumk escreveu:

Finalmente, depois de quebrar a cabeça consegui resolver.
Pesquisando, vi que este pacote libpng12-0 já estava obsoleto, e meu sistema já tinha versões mais atualizadas deste pacote, então dei o comando apt-get remove php5-gd que era o único pacote que tinha esta dependência (já possuo o php 7), agora consigo atualizar e instalar novos pacotes novamente.

A solução foi simples para tanta dor de cabeça.
Sou grato a todos pela ajuda!


Te avisei isso dia 11/3 ... vide post #2 .. menos mal que resolveu, antes tarde do que nunca !!!


------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




12. Re: Problemas ao Atualizar Servidor Debian 10 (apt --fix-broken install não funciona) [RESOLVIDO]

Nathan
Kumk

(usa Linux Mint)

Enviado em 04/04/2020 - 19:14h


Mauriciodez escreveu:

Te avisei isso dia 11/3 ... vide post #2 .. menos mal que resolveu, antes tarde do que nunca !!!



Desculpe, havia me esquecido rsrs, fuçando no sistema acabei excluindo.
Muito obrigado pela Ajuda!






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts