Linux não inicia se uma determinada partição não estiver inserida

1. Linux não inicia se uma determinada partição não estiver inserida

Cosmy Da CRuz
Cosmy

(usa Debian)

Enviado em 31/01/2019 - 10:24h

Eu tenho um HD externo e o configurei no FSTAB para ser montado automaticamente toda vez que o Debian é iniciado. Entretanto, toda vez que eu tento iniciar o sistema sem o HD externo, o Debian não liga e às vezes eu preciso iniciar o sistema sem essa partição. Alguém me teria alguma solução? Abaixo segue a configuração feita no FSTAB.

/dev/sda1 /media/HD1 ntfs defaults 0 2


  


2. Re: Linux não inicia se uma determinada partição não estiver inserida

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 31/01/2019 - 11:15h

Não liga mesmo ou vc que não tem paciência de esperar ?!?!?

Pois quando o Debian não acha um dispositivo listado no FSTAB ele abre uma contagem e fica procurando esse dispositivo.

------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




3. Re: Linux não inicia se uma determinada partição não estiver inserida

Cosmy Da CRuz
Cosmy

(usa Debian)

Enviado em 31/01/2019 - 11:24h

Mauriciodez escreveu:

Não liga mesmo ou vc que não tem paciência de esperar ?!?!?

Pois quando o Debian não acha um dispositivo listado no FSTAB ele abre uma contagem e fica procurando esse dispositivo.

------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------



Eu espero sim... Já esperei por mais de dez minutos, iniciando imediatamente somente ao inserir a partição




4. Re: Linux não inicia se uma determinada partição não estiver inserida

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 31/01/2019 - 12:24h

Tive problema parecido ao instalar Debian Stretch após o LinuxMint cuja inicialização ficou muito demorada mesmo num SSD demorou mais 5 minutos
Mas ao instalar LinuxMint após Debian 9 tal problema não aconteceu
Li que tem algo haver com alteração uuid feita pelo Debian




5. Re: Linux não inicia se uma determinada partição não estiver inserida

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 31/01/2019 - 12:42h


Cosmy escreveu:

Eu tenho um HD externo e o configurei no FSTAB para ser montado automaticamente toda vez que o Debian é iniciado. Entretanto, toda vez que eu tento iniciar o sistema sem o HD externo, o Debian não liga e às vezes eu preciso iniciar o sistema sem essa partição. Alguém me teria alguma solução? Abaixo segue a configuração feita no FSTAB.

/dev/sda1 /media/HD1 ntfs defaults 0 2


coloca assim no fstab e v se resolve

/dev/sda1 /media/HD1 auto nosuid,nodev,nofail,x-gvfs-show 0 0 



------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




6. Re: Linux não inicia se uma determinada partição não estiver inserida

Fernando T. Da Silva
nandosilva

(usa Salix)

Enviado em 01/02/2019 - 12:36h

Coloque a opção noauto no fstab para que o sistema não monte automaticamente já que é um hd externo.

Depois para montar é só fazer
Sudo mount /ponto de montagem


Ponde criar um script e criar um atalho no desktop para fazer a montagem rapidamente.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts