Erro no upgrade do Ubuntu 16.04

1. Erro no upgrade do Ubuntu 16.04

Antonio Carlos
carlosprj

(usa Outra)

Enviado em 11/01/2017 - 00:06h

Pessoal, Tudo ceto?
Meu problema é o seguinte.Estou tentando instalar uns programas através do ppa:. Mas a quastão ṕe a seguinte, quando dou o Upgrade ele me dá o seguinte Erro.

Foram encontrados erros enquanto processava:
/var/cache/apt/archives/apport_2.20.1-0ubuntu2.4_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

sudo apt-get upgrade....

(A ler a base de dados ... 310264 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../apport_2.20.1-0ubuntu2.4_all.deb ...
File "/usr/bin/pyclean", line 63
except (IOError, OSError), e:
^
SyntaxError: invalid syntax
dpkg: aviso: subprocesso script pre-removal antigo retornou erro do status de saída 1
dpkg: em vez disso a tentar script do novo pacote ...
File "/usr/bin/pyclean", line 63
except (IOError, OSError), e:
^
SyntaxError: invalid syntax
dpkg: erro ao processar o arquivo /var/cache/apt/archives/apport_2.20.1-0ubuntu2.4_all.deb (--unpack):
subprocesso novo script pre-removal retornou erro do status de saída 1
Traceback (most recent call last):
File "/usr/bin/pycompile", line 35, in <module>
from debpython.version import SUPPORTED, debsorted, vrepr, \
File "/usr/share/python/debpython/version.py", line 24, in <module>
from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: erro ao limpar:
subprocesso script post-installation instalado retornou erro do status de saída 1
Foram encontrados erros enquanto processava:
/var/cache/apt/archives/apport_2.20.1-0ubuntu2.4_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Já tentei bastante opções que encontrei em alguns formuns:

sudo su
dpkg-reconfigure
sudo apt-get purge icedtea-7-plugin
sudo apt-get remove icedtea-7-plugin
sudo apt-get autoremove

apt-get remove --purge icedtea-netx
apt-get remove --purge icedtea-7-plugin
dpkg -r icedtea-netx
dpkg -r icedtea-7-plugin
apt-get -f install
apt-get autoclean
apt-get update
dpkg --configure -a

dpkg -r icedtea-netx
dpkg -r icedtea-7-plugin
apt-get -f install
apt-get autoclean

Nenhum desses resolveu...
Agradeço desde já quem conseguir alguma solução!






  


2. Re: Erro no upgrade do Ubuntu 16.04

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 11/01/2017 - 08:33h

1-vá em programas/atualizações >> outros/programas >> desative todos ppa>>feche aplicativo
2-abra terminal e rode os comandos
sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get -f remove
sudo apt-get autoremove
sudo apt-get update
sudo apt-get upgrade


*******************************************
Meu Blog
http://dicaslinuxmint.blogspot.com.br/


3. Ainda não...

Antonio Carlos
carlosprj

(usa Outra)

Enviado em 11/01/2017 - 13:47h

Tentei todos, a mensagem ainda permance:

Foram encontrados erros enquanto processava:
/var/cache/apt/archives/apport_2.20.1-0ubuntu2.4_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)



4. Re: Erro no upgrade do Ubuntu 16.04

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 11/01/2017 - 13:52h

sudo apt-get remove apport apport-symptoms
sudo apt-get autoremove
sudo apt-get update
sudo apt-get upgrade


*******************************************
Meu Blog
http://dicaslinuxmint.blogspot.com.br/


5. Não resolvido

Antonio Carlos
carlosprj

(usa Outra)

Enviado em 11/01/2017 - 14:41h

Ainda sem solução.


6. Re: Erro no upgrade do Ubuntu 16.04

Paulo Jr
Pebis

(usa Debian)

Enviado em 11/01/2017 - 14:45h

Tenta aí.

sudo apt-get clean
sudo apt-get update
sudo apt-get install --reinstall python-minimal python-lockfile


7. Sem resolução...

Antonio Carlos
carlosprj

(usa Outra)

Enviado em 11/01/2017 - 14:56h

sudo apt-get install --reinstall python-minimal python-lockfile
A ler as listas de pacotes... Pronto
A construir árvore de dependências
A ler a informação de estado... Pronto
The following additional packages will be installed:
apport
Pacotes sugeridos:
apport-gtk | apport-kde python-lockfile-doc
Pacotes recomendados:
apport-symptoms
Serão instalados os seguintes NOVOS pacotes:
python-lockfile
Serão actualizados os seguintes pacotes:
apport
1 pacotes actualizados, 1 pacotes novos instalados, 1 reinstalados, 0 a remover e 5 não actualizados.
3 pacotes não totalmente instalados ou removidos.
É necessário obter 162 kB de arquivos.
Após esta operação, serão utilizados 63,5 kB adicionais de espaço em disco.
Deseja continuar? [S/n] s
Obter:1 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 apport all 2.20.1-0ubuntu2.4 [120 kB]
Obter:2 http://br.archive.ubuntu.com/ubuntu xenial/main amd64 python-minimal amd64 2.7.11-1 [28,2 kB]
Obter:3 http://br.archive.ubuntu.com/ubuntu xenial/main amd64 python-lockfile all 1:0.12.2-1 [14,1 kB]
Obtidos 162 kB em 0s (514 kB/s)
(A ler a base de dados ... 310250 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../apport_2.20.1-0ubuntu2.4_all.deb ...
File "/usr/bin/pyclean", line 63
except (IOError, OSError), e:
^
SyntaxError: invalid syntax
dpkg: aviso: subprocesso script pre-removal antigo retornou erro do status de saída 1
dpkg: em vez disso a tentar script do novo pacote ...
File "/usr/bin/pyclean", line 63
except (IOError, OSError), e:
^
SyntaxError: invalid syntax
dpkg: erro ao processar o arquivo /var/cache/apt/archives/apport_2.20.1-0ubuntu2.4_all.deb (--unpack):
subprocesso novo script pre-removal retornou erro do status de saída 1
Traceback (most recent call last):
File "/usr/bin/pycompile", line 35, in <module>
from debpython.version import SUPPORTED, debsorted, vrepr, \
File "/usr/share/python/debpython/version.py", line 24, in <module>
from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: erro ao limpar:
subprocesso script post-installation instalado retornou erro do status de saída 1
A preparar para desempacotar .../python-minimal_2.7.11-1_amd64.deb ...
A descompactar python-minimal (2.7.11-1) sobre (2.7.11-1) ...
A seleccionar pacote anteriormente não seleccionado python-lockfile.
A preparar para desempacotar .../python-lockfile_1%3a0.12.2-1_all.deb ...
A descompactar python-lockfile (1:0.12.2-1) ...
A processar 'triggers' para man-db (2.7.5-1) ...
Foram encontrados erros enquanto processava:
/var/cache/apt/archives/apport_2.20.1-0ubuntu2.4_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)




8. Re: Erro no upgrade do Ubuntu 16.04

Paulo Jr
Pebis

(usa Debian)

Enviado em 11/01/2017 - 15:34h

Vamos começar do começo:

Qual a PPA que instalou aí?

posta a saída do comando

ls -l /usr/bin/phyton


9. Posta saída do comando

Antonio Carlos
carlosprj

(usa Outra)

Enviado em 11/01/2017 - 18:28h

lrwxrwxrwx 1 root root 9 Dez 10 2015 /usr/bin/python -> python2.7




10. Re: Erro no upgrade do Ubuntu 16.04

Paulo Jr
Pebis

(usa Debian)

Enviado em 11/01/2017 - 19:19h

Pelo que entendi é o seguinte, o apport depende do python3 mas o seu está apontando para o 2.
A solução seria a seguinte, remover o link atual: sudo rm /usr/bin/python e criar um novo apontando para o python3: sudo ln -s /usr/bin/python3.5 /usr/bin/python


Acredito ser isso, mas dê uma pesquisada antes de efetuar o comando rm.


11. Estava apontando para o python 2

Antonio Carlos
carlosprj

(usa Outra)

Enviado em 11/01/2017 - 22:19h

Sim, realmente, estava apontando para o python 2.
Agora está para o pyhon3.5
Mas ainda persiste o erro.

sudo apt-get upgrade
A ler as listas de pacotes... Pronto
A construir árvore de dependências
A ler a informação de estado... Pronto
A calcular a actualização... Pronto
Serão mantidos em suas versões actuais os seguintes pacotes:
gnome-software gnome-software-common snapd ubuntu-core-launcher
ubuntu-software
Serão actualizados os seguintes pacotes:
apport apt apt-transport-https apt-utils libapt-inst2.0 libapt-pkg5.0
libvncclient1
7 pacotes actualizados, 0 pacotes novos instalados, 0 a remover e 5 não actualizados.
5 pacotes não totalmente instalados ou removidos.
É necessário obter 2.081 kB/2.200 kB de arquivos.
Após esta operação, serão utilizados 14,3 kB adicionais de espaço em disco.
Deseja continuar? [S/n] s
Obter:1 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libapt-pkg5.0 amd64 1.2.18 [707 kB]
Obter:2 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libapt-inst2.0 amd64 1.2.18 [55,6 kB]
Obter:3 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 apt amd64 1.2.18 [1.042 kB]
Obter:4 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 apt-utils amd64 1.2.18 [196 kB]
Obter:5 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 apt-transport-https amd64 1.2.18 [26,0 kB]
Obter:6 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libvncclient1 amd64 0.9.10+dfsg-3ubuntu0.16.04.1 [54,3 kB]
Obtidos 2.081 kB em 1s (1.769 kB/s)
(A ler a base de dados ... 310270 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../apport_2.20.1-0ubuntu2.4_all.deb ...
/var/lib/dpkg/info/apport.prerm: 19: /var/lib/dpkg/info/apport.prerm: pyclean: not found
dpkg: aviso: subprocesso script pre-removal antigo retornou erro do status de saída 127
dpkg: em vez disso a tentar script do novo pacote ...
/var/lib/dpkg/tmp.ci/prerm: 19: /var/lib/dpkg/tmp.ci/prerm: pyclean: not found
dpkg: erro ao processar o arquivo /var/cache/apt/archives/apport_2.20.1-0ubuntu2.4_all.deb (--unpack):
subprocesso novo script pre-removal retornou erro do status de saída 127
/var/lib/dpkg/info/apport.postinst: 13: /var/lib/dpkg/info/apport.postinst: pycompile: not found
dpkg: erro ao limpar:
subprocesso script post-installation instalado retornou erro do status de saída 127
A preparar para desempacotar .../libapt-pkg5.0_1.2.18_amd64.deb ...
A descompactar libapt-pkg5.0:amd64 (1.2.18) sobre (1.2.15ubuntu0.2) ...
A processar 'triggers' para libc-bin (2.23-0ubuntu5) ...
Foram encontrados erros enquanto processava:
/var/cache/apt/archives/apport_2.20.1-0ubuntu2.4_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)



12. Re: Erro no upgrade do Ubuntu 16.04

Paulo Jr
Pebis

(usa Debian)

Enviado em 11/01/2017 - 22:45h

roda esse comando:

sudo dpkg --audit







Patrocínio

Site hospedado pelo provedor HostGator.
Linux banner
Linux banner
Linux banner

Artigos

Dicas

Viva o Android

Tópicos

Top 10 do mês

Scripts