Erro atualizando PHP [RESOLVIDO]

1. Erro atualizando PHP [RESOLVIDO]

Daniel
dpitta

(usa Debian)

Enviado em 09/05/2012 - 14:15h

Olá a todos,

Estou atualizando o meu linux para o versão 6 e agora estou atualizando e instalando os programas, quando tento atualizar ou instalar um modulo do PHP esta aparecendo o erro abaixo. O que é isso?

apt-get install php5-curl -f

------------------------------------------


php5 (5.3.3-7+squeeze5) squeeze-security; urgency=high

* The following new directives were added as part of security fixes:
- max_input_vars - specifies how many GET/POST/COOKIE input variables
may be accepted. Default value is set to 1000.
- xsl.security_prefs - define forbidden operations within XSLT
stylesheets. Write operations are now disabled by default.

-- OndÅej Surý <[email protected]> Mon, 23 Jan 2012 12:22:26 +0100

php5 (5.3.3-7+squeeze4) squeeze-security; urgency=low

* Updated blowfish crypt() algorithm fixes the 8-bit character handling
vulnerability (CVE-2011-2483) and adds more self-tests. Unfortunately
this change is incompatible with some old (wrong) generated hashes for
passwords containing 8-bit characters. Therefore the new salt prefix
'$2x$' was introduced which can be used as a replacement for '$2a$'
salt prefix in the password database in case the incompatibility is
found.

-- OndÅej Surý <[email protected]> Mon, 04 Jul 2011 10:31:16 +0200



  


2. Re: Erro atualizando PHP [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 09/05/2012 - 14:17h

Não estou vendo erro algum!

Veja oque está instalado com referencia ao php5, com esse comando:

# dpkg -l | grep php5


3. Re: Erro atualizando PHP [RESOLVIDO]

Daniel
dpitta

(usa Debian)

Enviado em 09/05/2012 - 14:33h

Os pacotes refente a php5 são:

php5 install
php5-cli install
php5-common install
php5-mysql install
php5-suhosin


Tambem não tenho esse aplicativo pkg ele faz parte de qual pacote.


4. Re: Erro atualizando PHP [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 09/05/2012 - 14:46h

DPKG – Debian Package Manager

Ele é nativo do Debian. Você atualizou do debian5 para o debian6. Tá estranho heim!

Não curto esse lance de upgrade de versão. Sempre dá algun probleminha chato! Geralmente faço do zero, a partir de uma imagem do S.O. Raras exceções eu atualizo por upgrade.

# dpkg -l | grep php5

Com esse comando você busca e lista tudo que está instalado com o nome php5.

ex:

nabucodonosor:~# dpkg -l | grep php5
ii libapache2-mod-php5 5.2.6.dfsg.1-1+lenny16 server-side, HTML-embedded scripting language (Apache 2 module)
ii php5 5.2.6.dfsg.1-1+lenny16 server-side, HTML-embedded scripting language (metapackage)
ii php5-adodb 5.04-3 Extension optimising ADOdb database abstraction library
ii php5-cgi 5.2.6.dfsg.1-1+lenny16 server-side, HTML-embedded scripting language (CGI binary)
ii php5-cli 5.2.6.dfsg.1-1+lenny16 command-line interpreter for the php5 scripting language
ii php5-common 5.2.6.dfsg.1-1+lenny16 Common files for packages built from the php5 source
ii php5-curl 5.2.6.dfsg.1-1+lenny16 CURL module for php5
ii php5-dev 5.2.6.dfsg.1-1+lenny16 Files for PHP5 module development
ii php5-gd 5.2.6.dfsg.1-1+lenny16 GD module for php5
ii php5-idn 1.2b-5.3 PHP API for the IDNA library
ii php5-imagick 2.1.1RC1-1 ImageMagick module for php5
ii php5-imap 5.2.6.dfsg.1-1+lenny16 IMAP module for php5
ii php5-ldap 5.2.6.dfsg.1-1+lenny16 LDAP module for php5
ii php5-mcrypt 5.2.6.dfsg.1-1+lenny16 MCrypt module for php5
ii php5-mysql 5.2.6.dfsg.1-1+lenny16 MySQL module for php5
ii php5-odbc 5.2.6.dfsg.1-1+lenny16 ODBC module for php5
ii php5-pgsql 5.2.6.dfsg.1-1+lenny16 PostgreSQL module for php5
ii php5-snmp 5.2.6.dfsg.1-1+lenny16 SNMP module for php5
ii php5-tidy 5.2.6.dfsg.1-1+lenny16 tidy module for php5
ii php5-xmlrpc 5.2.6.dfsg.1-1+lenny16 XML-RPC module for php5


5. Warning

André Canhadas
andrecanhadas

(usa Debian)

Enviado em 09/05/2012 - 15:15h

dpitta escreveu:

Olá a todos,

Estou atualizando o meu linux para o versão 6 e agora estou atualizando e instalando os programas, quando tento atualizar ou instalar um modulo do PHP esta aparecendo o erro abaixo. O que é isso?

apt-get install php5-curl -f

------------------------------------------


php5 (5.3.3-7+squeeze5) squeeze-security; urgency=high

* The following new directives were added as part of security fixes:
- max_input_vars - specifies how many GET/POST/COOKIE input variables
may be accepted. Default value is set to 1000.
- xsl.security_prefs - define forbidden operations within XSLT
stylesheets. Write operations are now disabled by default.

-- OndÅej Surý <[email protected]> Mon, 23 Jan 2012 12:22:26 +0100

php5 (5.3.3-7+squeeze4) squeeze-security; urgency=low

* Updated blowfish crypt() algorithm fixes the 8-bit character handling
vulnerability (CVE-2011-2483) and adds more self-tests. Unfortunately
this change is incompatible with some old (wrong) generated hashes for
passwords containing 8-bit characters. Therefore the new salt prefix
'$2x$' was introduced which can be used as a replacement for '$2a$'
salt prefix in the password database in case the incompatibility is
found.

-- OndÅej Surý <[email protected]> Mon, 04 Jul 2011 10:31:16 +0200

Não é um erro é só um aviso do sistema aperte a tecla "q" quando aparecer que ele continua com a instalação.




6. Re: Erro atualizando PHP [RESOLVIDO]

Daniel
dpitta

(usa Debian)

Enviado em 09/05/2012 - 15:28h


Eu instalei do Zero, é um Servidor Cloud onde no Painel você manda instalar, ele apaga a velha e instala uma nova do Zero.

Veja agora que instalei o DPKG.


ii libapache2-mod-php5 5.3.3-7+squeeze3 server-side, HTML-embedded scripting language (Apache 2 module)
ii php5 5.3.3-7+squeeze3 server-side, HTML-embedded scripting language (metapackage)
ii php5-cli 5.3.3-7+squeeze3 command-line interpreter for the php5 scripting language
ii php5-common 5.3.3-7+squeeze3 Common files for packages built from the php5 source
ii php5-mysql 5.3.3-7+squeeze3 MySQL module for php5
ii php5-suhosin 0.9.32.1-1 advanced protection module for php5



7. DPKG

André Canhadas
andrecanhadas

(usa Debian)

Enviado em 09/05/2012 - 16:01h

dpitta escreveu:


Eu instalei do Zero, é um Servidor Cloud onde no Painel você manda instalar, ele apaga a velha e instala uma nova do Zero.

Veja agora que instalei o DPKG.


ii libapache2-mod-php5 5.3.3-7+squeeze3 server-side, HTML-embedded scripting language (Apache 2 module)
ii php5 5.3.3-7+squeeze3 server-side, HTML-embedded scripting language (metapackage)
ii php5-cli 5.3.3-7+squeeze3 command-line interpreter for the php5 scripting language
ii php5-common 5.3.3-7+squeeze3 Common files for packages built from the php5 source
ii php5-mysql 5.3.3-7+squeeze3 MySQL module for php5
ii php5-suhosin 0.9.32.1-1 advanced protection module for php5


Só uma observação o DPKG já estava instalado vc apenas uso ele para listar o aplicativos instalado cujos nomes contém PHP5 o "dpkg -l " lista todos os pacotes instalados já o |grep php5 filtra essa saida mostrando apenas o que contem php5.

Como falado anteriormente não é um erro e sim um aviso de que esta atualizando o php5 para corrigir uma possivel falha de segurança. basta apertar a tecla "q" que a mensagem se fechara e a atualização do PHP5 sera completada.


8. Re: Erro atualizando PHP [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 09/05/2012 - 16:06h

[email protected]:~# cat /etc/issue
Debian GNU/Linux 6.0 \n \l

[email protected]:~# aptitude install php5 php5-curl
Os NOVOS pacotes a seguir serão instalados:
apache2-mpm-prefork{a} apache2-utils{a} apache2.2-common{a} libapache2-mod-php5{a} libcurl3{a} libonig2{a} libqdbm14{a} libssh2-1{a} php5 php5-cli{a} php5-common{a}
php5-curl php5-suhosin{a}
0 pacotes atualizados, 13 novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso obter 7518 kB de arquivos. Depois do desempacotamento, 20,8 MB serão usados.
Você deseja continuar? [Y/n/?] Y

[email protected]:~# dpkg -l | grep php5
ii libapache2-mod-php5 5.3.3-7+squeeze8 server-side, HTML-embedded scripting language (Apache 2 module)
ii php5 5.3.3-7+squeeze8 server-side, HTML-embedded scripting language (metapackage)
ii php5-cli 5.3.3-7+squeeze8 command-line interpreter for the php5 scripting language
ii php5-common 5.3.3-7+squeeze8 Common files for packages built from the php5 source
ii php5-curl 5.3.3-7+squeeze8 CURL module for php5
ii php5-suhosin 0.9.32.1-1 advanced protection module for php5