Unity3D - dependências desencontradas

1. Unity3D - dependências desencontradas

Chaybe Lucas
Ch4yb3

(usa Debian)

Enviado em 02/12/2016 - 20:01h

Dou apt-get install em algum programa e o terminal me retorna isso


endo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Você deve querer executar 'apt-get -f install' para corrigí-los:
Os pacotes a seguir têm dependências desencontradas:
unity-editor : Depende: lib32gcc1 (>= 1:4.1.1) mas não será instalado
Depende: lib32stdc++6 (>= 4.6) mas não será instalado
Depende: libc6-i386 (>= 2.15) mas não será instalado
Recomenda: java7-jdk mas não é instalável
zsnes:i386 : Depende: libsdl1.2debian:i386 (>= 1.2.11) mas não será instalado
E: Dependências desencontradas. Tente 'apt-get -f install' sem nenhum pacote (ou especifique uma solução).


Eu tento instalar os pacotes, mas sempre dá erro.
# apt-get install lib32gcc1 

Eu tento tudo o que pede, mas realmente não dá certo. Um install leva a outro até chegar a um ponto que o sistema diz que não pode instalar porque não tem candidato para instalação.

Alguém pasou por isso e sabe como resolver?
Obs.: Se eu der
apt-get -f install 
ele vai remover o Unity-Editor do meu pc. Eu teria que instalar novamente o Unity3D. Já fiz isso várias vezes e nunca corrige.

Buscando na internet, vi que isso acontece quando ele não encontra os pacotes para instalar. Alguém sabe onde posso encontrar? Como procurar?

Estou usando Debian 8 x64


  


2. Re: Unity3D - dependências desencontradas

Patrick
Patrick03

(usa Linux Mint)

Enviado em 02/12/2016 - 20:48h

O comando dpkg -i nome do pacote não resolve dependências, creio que esses "erros" aparecem exatamante por isso. Usando apt-get install -f, resolverá. Tente também, se já não tenha tentado, usar o Gdebi que é um instalador gráfico para pacotes .deb.

Caso use o terminal, siga esta sequência de comandos:

dpkg -i nome do pacote
dpkg --configure -a
apt-get install -f


---------------------------------------
Corrija-me quando necessário!
https://bartoi.blogspot.com.br/
---------------------------------------



3. Re: Unity3D - dependências desencontradas

Perfil removido
removido

(usa Nenhuma)

Enviado em 02/12/2016 - 20:57h

Aposto que tem algum PPA fazendo essa caca!

O que instalou ante de começar a apresentar este problema? Tente desativar todos os PPA's e resolva essa dependência antes de reativá-los novamente... identifique qual PPA está conflitando e deixe-o sempre desabilitado.

Sugestão: use o Synaptic.


4. Re: Unity3D - dependências desencontradas

Chaybe Lucas
Ch4yb3

(usa Debian)

Enviado em 03/12/2016 - 18:51h

PauloHAC escreveu:

Aposto que tem algum PPA fazendo essa caca!

O que instalou ante de começar a apresentar este problema? Tente desativar todos os PPA's e resolva essa dependência antes de reativá-los novamente... identifique qual PPA está conflitando e deixe-o sempre desabilitado.

Sugestão: use o Synaptic.


Vou dar uma olhada na sources.list
Tenho o Synaptic, infelizmente ele não corrige os pacotes por completo.. Sempre falta um ou dois. No caso, ele terminou removendo o Unity3D, que é, resumindo, a mesma coisa que dar apt-get -f install


5. Re: Unity3D - dependências desencontradas

Chaybe Lucas
Ch4yb3

(usa Debian)

Enviado em 03/12/2016 - 18:53h

Patrick03 escreveu:

O comando dpkg -i nome do pacote não resolve dependências, creio que esses "erros" aparecem exatamante por isso. Usando apt-get install -f, resolverá. Tente também, se já não tenha tentado, usar o Gdebi que é um instalador gráfico para pacotes .deb.

Caso use o terminal, siga esta sequência de comandos:

dpkg -i nome do pacote
dpkg --configure -a
apt-get install -f


---------------------------------------
Corrija-me quando necessário!
https://bartoi.blogspot.com.br/
---------------------------------------



dpkg: problemas com dependências impedem a configuração de unity-editor:
unity-editor depende de lib32gcc1 (>= 1:4.1.1); porém:
Pacote lib32gcc1 não está instalado.
unity-editor depende de lib32stdc++6 (>= 4.6); porém:
Pacote lib32stdc++6 não está instalado.
unity-editor depende de libc6-i386 (>= 2.15); porém:
Pacote libc6-i386 não está instalado.

dpkg: erro ao processar o pacote unity-editor (--configure):
problemas de dependência - deixando desconfigurado



Já tentei dar apt-get install, não vai.
E apt-get install -f finaliza removendo os programas..


6. Re: Unity3D - dependências desencontradas

Patrick
Patrick03

(usa Linux Mint)

Enviado em 03/12/2016 - 20:09h

Tu adicionou algum repositório ou ppa para instalá-lo?

Copie e cole este comando no terminal e mostre o resultado:
cat -n /etc/apt/sources.list 


Como o amigo ali em cima disse, pode ser a ppa que tu adicionastes que está causando esse problema.

---------------------------------------
Corrija-me quando necessário!
https://bartoi.blogspot.com.br/
---------------------------------------



7. Re: Unity3D - dependências desencontradas

Chaybe Lucas
Ch4yb3

(usa Debian)

Enviado em 21/12/2016 - 21:36h

Patrick03 escreveu:

Tu adicionou algum repositório ou ppa para instalá-lo?

Copie e cole este comando no terminal e mostre o resultado:
cat -n /etc/apt/sources.list 


Como o amigo ali em cima disse, pode ser a ppa que tu adicionastes que está causando esse problema.

---------------------------------------
Corrija-me quando necessário!
https://bartoi.blogspot.com.br/
---------------------------------------


Não cara, não o fiz
Mas pior, o último dpkg acabou por remover praticamente todos os meus programas. Provavelmente fiz besteira (garanto que o sistema não iria encarar tudo como inútil do nada)

Então vou finalizar formatando mesmo. Até meu terminal sumiu dos lançadores







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts