Balanceamento de carga

1. Balanceamento de carga

Cristiano Miguel da Costa
Cristiano_Be

(usa Ubuntu)

Enviado em 17/04/2019 - 17:57h

Tudo bem pessoal,

Estou precisando de uma ajuda para entender um caso que estou implementado. O projeto é montar um load Balance. Dois links de internet.

Segui os passos de alguns foruns que encontrei na net e consegui fazer funcionar. Fiz toda a implementação, criei as tabela e regras de roteamento com o iproute e etc.

Nos teste de navegação tudo tranquilo.

Usei a regra para adcionar dois gateways na tabela de roteamento:

ip route add default nexthop via 10.0.2.15 dev eth0 weight 1 nexthop via 10.0.3.15 dev eth1 weight 1

Tudo tranquilo. Tudo funcionando. O problema está na conexão de entrada. A tabela de roteamento que esta os dois gateway não funciona conexão de entrada. Se eu coloco somente um gateway, funciona a conexão de entrada certinho!

Neste caso, onde existe dois gateway na tabela de roteamento e é necessário a conexão entrante, teria uma solução alternativa para isso? Seria o caso de marcar pacotes com o iptables ou outra solução? As conexões entrante são necessárias neste projeto para o proprio gerenciamento do servidor via SSH e também para o Apache.

Desde já agradeço o apoio! Obrigado amigos!



  


2. Re: Balanceamento de carga

Berghetti
berghetti

(usa Debian)

Enviado em 18/04/2019 - 11:48h

Bom dia,
você pode fazer marcando as conexões.

toda nova conexão entrante na eth X, você marca ela para sair pela eth X
toda nova conexão entrante na eth Y, você marca ela para sair pela eth Y

em iptables fico devendo as regras, copiei de um caso que tenho em produção com mikrotik,
para que você possa traduzir para iptables

no caso estou marcando apenas as conexões entrantes pelo link secundário,
mas você pode marcar de seus dois links.

/ip firewall mangle

add action=mark-connection chain=prerouting comment=IN_ADSL in-interface=pppoe-out1 new-connection-mark=con_in_adsl
passthrough=yes protocol=tcp

add action=mark-routing chain=prerouting comment=IN_REDE-LOCAL_OUT_ADSL connection-mark=con_in_adsl new-routing-mark=com_out_adsl passthrough=no
src-address-list = REDE LOCAL

add action=mark-routing chain=output comment=OUT_ADSL connection-mark=con_in_adsl new-routing-mark=com_out_adsl passthrough=no







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts