Sinal de wireless não aparece no conky [RESOLVIDO]

1. Sinal de wireless não aparece no conky [RESOLVIDO]

Mauricio Paim
mauriciopaim

(usa Debian)

Enviado em 04/09/2016 - 15:48h

Todas as informações da minha wireless aparecem no conky, menos o sinal.
Já procurei muito na internet e não achei nada.
Se alguém tiver alguma ideia, agradeço. Abaixo segue já como contribuição minha screen e meu arquivo conky.

Screen
https://uploaddeimagens.com.br/imagens/captura_de_tela_de_2016-09-04_15-42-20-png

update_interval 0.5
double_buffer yes
own_window yes
own_window_type normal
own_window_transparent yes
use_xft yes
xftfont Droid Sans:size=9
alignment top_right
#maximum_width 310
minimum_size 260 260
gap_x 10
gap_y 40
default_color white
uppercase yes
background yes
own_window_hints undecorated,sticky,skip_taskbar,skip_pager,below


####################################################################
# Os elementos após 'TEXT' serão formatados na tela

TEXT
########## Data e Hora
${alignc}${font Droid Sans:size=18:style=bold}${time %H:%M}${font}${color}
${alignc}${time %A}, ${time %e} de ${time %B} de ${time %G}${font}

############## Sistema
${color blue}Sistema
${hr 2}$color
PC:${alignr}$nodename
Distribuição:${alignr}${exec lsb_release -d | cut -c14-30}
Kernel:${alignr}$kernel
Uptime:${alignr}$uptime
Bateria: ${battery_percent}% ${alignr}${battery_bar 8,60}

############## Temperatura
${color DarkTurquoise}Temperatura
${hr 2}$color
Processador:${alignr}${execi 1 /usr/bin/sensors | grep CPU | cut -c18-24;}
MotherBoard:${alignr}${execi 1 /usr/bin/sensors | grep temp1 | cut -c16-22;}
Disco:${alignr}${execi 10 /usr/sbin/hddtemp -q /dev/sda | cut -c32-38;}

############ CPU
${color red1}CPU
${hr 2}$color
CPU1: ${cpu cpu1}% $freq_g GHz ${alignr}${cpugraph cpu1 10,100 0000ff ff0000 -l}
CPU2: ${cpu cpu2}% $freq_g GHz ${alignr}${cpugraph cpu2 10,100 0000ff ff0000 -l}
CPU3: ${cpu cpu3}% $freq_g GHz ${alignr}${cpugraph cpu3 10,100 0000ff ff0000 -l}
CPU4: ${cpu cpu4}% $freq_g GHz ${alignr}${cpugraph cpu4 10,100 0000ff ff0000 -l}


####### Memoria / Discos
${color green}MEMORY / DISK
${hr 2}$color
RAM: $mem / $memmax - $memperc% ${alignr}${membar 8,60 mem}${color}
SWAP: $swap / $swapmax - $swapperc% ${alignr}${swapbar 8,60 swap}${color}
Raiz: ${fs_used /} / ${fs_free /} ${alignr}${fs_bar 8,60 /}
Home: ${fs_used /home/paim} / ${fs_free /home/paim} ${alignr}${fs_bar 8,60 /home/paim}

######## REDE
${color DeepSkyBlue1}WIFI (wlp18s0)
${hr 2}$color
SSID: ${color SpringGreen3}${wireless_essid wlp18s0}$color
IP local: ${alignr}${addr wlp18s0}
Sinal: ${wireless_link_qual_perc wlp18s0}% ${alignr}${wireless_link_bar 10,100 0000ff ff0000 -l wlp18s0}
Down: ${downspeed wlp18s0} k/s ${alignr} Upload: ${upspeed wlp18s0} k/s
${downspeedgraph wlp18s0 20,120 0000ff 49ff45 5000 -l} ${alignr}${upspeedgraph wlp18s0 20,120 ff0000 ffff00 5000 -l}
${totaldown wlp18s0} ${alignr}${totalup wlp18s0}

############ Processos
${color BlueViolet}Processos
${hr 2}$color
$running_processes Running $processes Sleeping
${color OrangeRed1}Name ${alignr} PID CPU% MEM% $color
${color yellow}${top name 1} ${alignr}${top pid 1} ${top cpu 1} ${top mem 1}
${color}${top name 2} ${alignr}${top pid 2} ${top cpu 2} ${top mem 2}
${top name 3} ${alignr}${top pid 3} ${top cpu 3} ${top mem 3}
${top name 4} ${alignr}${top pid 4} ${top cpu 4} ${top mem 4}


  


2. Re: Sinal de wireless não aparece no conky [RESOLVIDO]

Izaias
izaias

(usa LMDE)

Enviado em 04/09/2016 - 15:54h

Posta o resultado do comando: ifconfig


3. Re: Sinal de wireless não aparece no conky

Mauricio Paim
mauriciopaim

(usa Debian)

Enviado em 04/09/2016 - 15:58h

izaias escreveu:

Posta o resultado do comando: ifconfig


Olá Izaias,

Segue ifconfig, se tu verificar na screen todas as informações da wireless aparecem, menos o sinal.

[email protected]:/proc/net$ ifconfig


enp19s0 Link encap:Ethernet Endereço de HW b8:ac:6f:e6:c3:d9
UP BROADCAST MULTICAST MTU:1500 Métrica:1
pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0
Pacotes TX:0 erros:0 descartados:0 excesso:0 portadora:0
colisões:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Loopback Local
inet end.: 127.0.0.1 Masc:255.0.0.0
endereço inet6: ::1/128 Escopo:Máquina
UP LOOPBACK RUNNING MTU:65536 Métrica:1
pacotes RX:38759 erros:0 descartados:0 excesso:0 quadro:0
Pacotes TX:38759 erros:0 descartados:0 excesso:0 portadora:0
colisões:0 txqueuelen:1
RX bytes:5838326 (5.8 MB) TX bytes:5838326 (5.8 MB)

wlp18s0 Link encap:Ethernet Endereço de HW c4:46:19:95:83:7e
inet end.: 192.168.0.14 Bcast:192.168.0.255 Masc:255.255.255.0
endereço inet6: 2804:14c:87b4:9e7e::6/128 Escopo:Global
endereço inet6: 2804:14c:87b4:9e7e:d205:e8ac:f39a:b00f/64 Escopo:Global
endereço inet6: fe80::f24c:2e64:c61a:2797/64 Escopo:Link
endereço inet6: 2804:14c:87b4:9e7e:4ce6:1918:c20:adc9/64 Escopo:Global
UP BROADCAST RUNNING MULTICAST MTU:1500 Métrica:1
pacotes RX:801535 erros:0 descartados:0 excesso:0 quadro:2345005
Pacotes TX:932623 erros:0 descartados:0 excesso:0 portadora:0
colisões:0 txqueuelen:1000
RX bytes:295337361 (295.3 MB) TX bytes:844867331 (844.8 MB)
IRQ:17


Valeu pela força.




4. Re: Sinal de wireless não aparece no conky

Izaias
izaias

(usa LMDE)

Enviado em 04/09/2016 - 16:15h

Veja acima em negrito, a saída do comando. É identificação de sua rede e este código deve constar em seu conkyrc.

Em todas as linhas, onde tem “wlp18s0”
Substitua por: enp19s0

Depois reinicie o conky: killall conky && conky


5. Re: Sinal de wireless não aparece no conky [RESOLVIDO]

Mauricio Paim
mauriciopaim

(usa Debian)

Enviado em 04/09/2016 - 16:19h

izaias escreveu:

Onde tem “wlp18s0”
Substitua por: enp19s0

Depois reinicie o conky: killall conky && conky


Não funcionou.

enp19s0 é minha placa de rede ethernet a minha wireless é wlp18s0.

Mas mesmo assim troquei e não funcionou.

Não faço ideia do porque tudo funciona menos o sinal.

Valeu.



6. Re: Sinal de wireless não aparece no conky

Izaias
izaias

(usa LMDE)

Enviado em 04/09/2016 - 16:20h

Use o código conforme a rede que estiver usando.
Está no Wi-Fi ou Ethernet?


7. Re: Sinal de wireless não aparece no conky [RESOLVIDO]

Mauricio Paim
mauriciopaim

(usa Debian)

Enviado em 04/09/2016 - 16:31h

izaias escreveu:

Use o código conforme a rede que estiver usando.
Está no Wi-Fi ou Ethernet?



Wifi
Todos estão funcionando.

######## REDE
${color DeepSkyBlue1}WIFI (wlp18s0)
${hr 2}$color
SSID: ${color SpringGreen3}${wireless_essid wlp18s0}$color
IP local: ${alignr}${addr wlp18s0}

Down: ${downspeed wlp18s0} k/s ${alignr} Upload: ${upspeed wlp18s0} k/s
${downspeedgraph wlp18s0 20,120 0000ff 49ff45 5000 -l} ${alignr}${upspeedgraph wlp18s0 20,120 ff0000 ffff00 5000 -l}
${totaldown wlp18s0} ${alignr}${totalup wlp18s0}


Menos esse
Sinal: ${wireless_link_qual_perc wlp18s0}% ${alignr}${wireless_link_bar 10,100 0000ff ff0000 -l wlp18s0}



8. Re: Sinal de wireless não aparece no conky

Izaias
izaias

(usa LMDE)

Enviado em 04/09/2016 - 16:41h

mauriciopaim escreveu:

Menos esse
Sinal: ${wireless_link_qual_perc wlp18s0}% ${alignr}${wireless_link_bar 10,100 0000ff ff0000 -l wlp18s0}


Essas linhas, nunca vi nada parecido:

wireless_link_qual_perc
wireless_link_ba

O erro está aí. Onde pegou o conky, tem imagem do conky funcionado com essas linhas?


9. Re: Sinal de wireless não aparece no conky [RESOLVIDO]

Mauricio Paim
mauriciopaim

(usa Debian)

Enviado em 04/09/2016 - 16:44h

izaias escreveu:

mauriciopaim escreveu:

Menos esse
Sinal: ${wireless_link_qual_perc wlp18s0}% ${alignr}${wireless_link_bar 10,100 0000ff ff0000 -l wlp18s0}


Essas linhas, nunca vi nada parecido:

wireless_link_qual_perc
wireless_link_ba

O erro está aí. Onde pegou o conky, tem imagem do conky funcionado essas linhas?



Sim.

Link de variáveis que podem ser usadas no conky.
http://conky.sourceforge.net/variables.html



10. Re: Sinal de wireless não aparece no conky

Izaias
izaias

(usa LMDE)

Enviado em 04/09/2016 - 16:48h

Conheço o site.
Mas o conky já está em outra versão, não é mesmo? Justamente estas linhas não são reconhecidas.
Se o script do conky não reconhece o formato do comando por ser ultrapassado ou algum erro, não tem como alterar isso.



Não é só com você. Veja: https://ubuntuforums.org/archive/index.php/t-563401.html
Veja a última resposta.


11. Re: Sinal de wireless não aparece no conky [RESOLVIDO]

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 04/09/2016 - 21:48h

Velho ... uso o conk 1.9.0 e os comandos funcionam de boa nele !!! tem muita coisa que não funfa no conky da versão 1.10 pra diante !!!
___________________________________________________________________________________________
" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"


12. Re: Sinal de wireless não aparece no conky [RESOLVIDO]

Mauricio Paim
mauriciopaim

(usa Debian)

Enviado em 04/09/2016 - 21:53h

Mauriciodez escreveu:

Velho ... uso o conk 1.9.0 e os comandos funcionam de boa nele !!! tem muita coisa que não funfa no conky da versão 1.10 pra diante !!!
___________________________________________________________________________________________
" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"


Pois é, a minha versão é a 1.10. Acho que vou ter que esperar...heheheheh... por que não estou achando nada de solução.

Faz parte, enquanto isso vou pesquisando e mexendo, vai que.... Valeu, abraços.

[email protected]:~$ conky -v
conky 1.10.1 compiled Wed Jan 6 17:11:44 UTC 2016 for Linux 3.19.0-43-generic x86_64

Compiled in features:

System config file: /etc/conky/conky.conf
Package library path: /usr/lib/conky


General:
* math
* hddtemp
* portmon
* IPv6
* Curl
* RSS
* Weather (METAR)
* Weather (XOAP)
* wireless
* support for IBM/Lenovo notebooks
* nvidia
* eve-online
* builtin default configuration
* old configuration syntax
* Imlib2
* apcupsd
* iostats
* ncurses
* Internationalization support

Lua bindings:
* Cairo
* Imlib2
* RSVG
X11:
* Xdamage extension
* XDBE (double buffer extension)
* Xft
* ARGB visual
* Own window

Music detection:
* Audacious
* MPD
* MOC
* XMMS2

Default values:
* Netdevice: eth0
* Local configfile: $HOME/.conkyrc
* Localedir: /usr/share/locale
* Maximum netdevices: 64
* Maximum text size: 16384
* Size text buffer: 256






01 02