Conky desconfigurado na inicialização do SO

1. Conky desconfigurado na inicialização do SO

Lucas Bulegon Mello
lbmello

(usa Ubuntu)

Enviado em 23/03/2017 - 14:43h

Boa Tarde!

Ao iniciar meu sistema Ubuntu notei que um Conky utilizado está abrindo desconfigurado, com os marcadores ilegíveis, como se os dados estivessem sobrepostos.
Para seguir utilizando o marcador notei que ao abrir o Conky Manager e desativar e ativar a visualização os dados são exibidos corretamente.
Não sei como resolver o problema, pois sou iniciante em Linux, alguém pode me ajudar?
Obrigado!

# Conky sample configuration


background yes
use_xft yes
xftfont HandelGotD:size=8
xftalpha 0.1
update_interval 0.5
total_run_times 0
own_window yes
own_window_type normal
own_window_transparent yes
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
double_buffer yes
minimum_size 200 5
maximum_width 230
draw_shades yes
draw_outline no
draw_borders no
draw_graph_borders yes
default_color white
default_shade_color black
default_outline_color black
alignment top_right
gap_x 18
gap_y 48
no_buffers yes
uppercase no
cpu_avg_samples 2
net_avg_samples 1
override_utf8_locale no
use_spacer yes


TEXT
Uptime: $alignr$uptime

$sysname $kernel $alignr $machine
Intel Core I5 HT $alignr${freq_g cpu0}Ghz
$alignr
${cpugraph cpu0 16,200 ffffff ffffff}
Total: ${color 00ff00} ${cpu cpu0} % ${cpubar} ${color}
${alignr} FREQ: ${freq}MHz | TEMP: ${alignr} ${acpitemp}°C

CPU:1 ${cpu cpu1}% ${cpubar cpu1}
CPU:2 ${cpu cpu2}% ${cpubar cpu2}
CPU:3 ${cpu cpu3}% ${cpubar cpu3}
CPU:4 ${cpu cpu4}% ${cpubar cpu4}



MEM $alignc $mem / $memmax $alignr $memperc%
$membar
Swap:$swapperc% ${swapbar 8}


Processes
$alignr $running_processes Running
$alignr $processes Sleeping

Top Processes
CPU $alignr CPU% MEM%

${top name 1}$alignr${top cpu 1}${top mem 1}
${top name 2}$alignr${top cpu 2}${top mem 2}
${top name 3}$alignr${top cpu 2}${top mem 3}

MEM $alignr CPU% MEM%

${top_mem name 1}$alignr${top_mem cpu 1}${top_mem mem 1}
${top_mem name 2}$alignr${top_mem cpu 2}${top_mem mem 2}
${top_mem name 3}$alignr${top_mem cpu 3}${top_mem mem 3}

Network - wlan0
Down $alignr Speed-${downspeed wlan0} / Total-${totaldown wlan0}
Up $alignr Speed-${upspeed wlan0} / Total-${totalup wlan0}

HD's
Disco Principal - /home
$alignc F-${fs_free /} / U-${fs_used /} / T-${fs_size /} ${fs_free_perc /}%
${fs_bar /}$alignr

Disco Compartilhado
$alignc F-${fs_free /media/lucas/Compartilhado} / U-${fs_used /media/lucas/Compartilhado} / T-${fs_size /media/lucas/Compartilhado} ${fs_free_perc /media/lucas/Compartilhado}%
${fs_bar /media/lucas/Compartilhado}$alignr



  


2. Re: Conky desconfigurado na inicialização do SO

Izaias
izaias

(usa LMDE)

Enviado em 23/03/2017 - 15:08h

Tira um print da tela e poste em: http://imgur.com/
Depois cole o link aqui.

Estranho, os comentários estão sem: #


*******************************************************
* https://www.linuxcounter.net/cert/620448.png *
*******************************************************


3. Re: Conky desconfigurado na inicialização do SO

Franklin Timóteo
COBY

(usa Debian)

Enviado em 23/03/2017 - 17:57h

izaias escreveu:

Tira um print da tela e poste em: http://imgur.com/
Depois cole o link aqui.

Estranho, os comentários estão sem: #


*******************************************************
* https://www.linuxcounter.net/cert/620448.png *
*******************************************************


Verdade, se for isso mesmo, é melhor criar ou copiar outro arquivo de configuração.




4. Re: Conky desconfigurado na inicialização do SO

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 23/03/2017 - 18:48h

tem muito comando aí fora das chaves {}
_______________________________________________________________
" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"


5. Re: Conky desconfigurado na inicialização do SO

Izaias
izaias

(usa LMDE)

Enviado em 24/03/2017 - 00:38h

Não é necessário outro arquivo. Basta comentar ( #) as explicações de cada função.
Este Conky parece ser bem interessante.



6. Re: Conky desconfigurado na inicialização do SO

Lucas Bulegon Mello
lbmello

(usa Ubuntu)

Enviado em 25/03/2017 - 01:02h

izaias escreveu:

Tira um print da tela e poste em: http://imgur.com/
Depois cole o link aqui.

Estranho, os comentários estão sem: #


*******************************************************
* https://www.linuxcounter.net/cert/620448.png *
*******************************************************


http://imgur.com/a/jZoTZ - Ao iniciar o so
http://imgur.com/a/7HlMh - Depois de reiniciar o Conky

Quais comentários tu menciona que estão sem # ?


7. Re: Conky desconfigurado na inicialização do SO

Lucas Bulegon Mello
lbmello

(usa Ubuntu)

Enviado em 25/03/2017 - 01:28h

Mauriciodez escreveu:

tem muito comando aí fora das chaves {}
_______________________________________________________________
" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"


Realmente, todos os comandos de alinhamento e mais alguns estavam fora das chaves.

Arrumei isso e tirei a aspas simples que tinha em HD's no final e a mesma coisa acontece quando reinicia o pc.

Segue código reparado:

# Conky sample configuration


background yes
use_xft yes
xftfont HandelGotD:size=8
xftalpha 0.1
update_interval 0.5
total_run_times 0
own_window yes
own_window_type normal
own_window_transparent yes
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
double_buffer yes
minimum_size 200 5
maximum_width 230
draw_shades yes
draw_outline no
draw_borders no
draw_graph_borders yes
default_color white
default_shade_color black
default_outline_color black
alignment top_right
gap_x 18
gap_y 48
no_buffers yes
uppercase no
cpu_avg_samples 2
net_avg_samples 1
override_utf8_locale no
use_spacer yes


TEXT
Uptime: ${alignr}${uptime}

$sysname ${kernel} ${alignr} ${machine}
Intel Core I5 HT ${alignr}${freq_g cpu0}Ghz
${alignr}
${cpugraph cpu0 16,200 ffffff ffffff}
Total: ${color 00ff00} ${cpu cpu0} % ${cpubar} ${color}
${alignr} FREQ: ${freq}MHz | TEMP: ${alignr} ${acpitemp}°C

CPU:1 ${cpu cpu1}% ${cpubar cpu1}
CPU:2 ${cpu cpu2}% ${cpubar cpu2}
CPU:3 ${cpu cpu3}% ${cpubar cpu3}
CPU:4 ${cpu cpu4}% ${cpubar cpu4}



MEM ${alignc} ${mem} / ${memmax} ${alignr} ${memperc}%
${membar}
Swap:${swapperc}% ${swapbar 8}


Processes
${alignr} ${running_processes} Running
${alignr} ${processes Sleeping}

Top Processes
CPU ${alignr} CPU% MEM%

${top name 1}${alignr}${top cpu 1}${top mem 1}
${top name 2}${alignr}${top cpu 2}${top mem 2}
${top name 3}${alignr}${top cpu 2}${top mem 3}

MEM ${alignr} CPU% MEM%

${top_mem name 1}${alignr}${top_mem cpu 1}${top_mem mem 1}
${top_mem name 2}${alignr}${top_mem cpu 2}${top_mem mem 2}
${top_mem name 3}${alignr}${top_mem cpu 3}${top_mem mem 3}

Network - wlan0
Down ${alignr} Speed-${downspeed wlan0} / Total-${totaldown wlan0}
Up ${alignr} Speed-${upspeed wlan0} / Total-${totalup wlan0}

HDs
Disco Principal - /home
${alignc} F-${fs_free /} / U-${fs_used /} / T-${fs_size /} ${fs_free_perc /}%
${fs_bar /}${alignr}

Disco Compartilhado
${alignc} F-${fs_free /media/lucas/Compartilhado} / U-${fs_used /media/lucas/Compartilhado} / T-${fs_size /media/lucas/Compartilhado} ${fs_free_perc /media/lucas/Compartilhado}%
${fs_bar /media/lucas/Compartilhado}${alignr}



8. Re: Conky desconfigurado na inicialização do SO

Izaias
izaias

(usa LMDE)

Enviado em 25/03/2017 - 10:19h

A linha: own_window_type normal
Mude para:

own_window_type override 


Veja se dá certo.

Para dar suporte a caracters latinos, mude essa: override_utf8_locale no
Para:

override_utf8_locale yes 


*******************************************************
* https://www.linuxcounter.net/cert/620448.png *
*******************************************************


9. Re: Conky desconfigurado na inicialização do SO

Perfil removido
removido

(usa Nenhuma)

Enviado em 25/03/2017 - 11:28h

Isso pode ser algo relacionado ao compositor da área de trabalho. Adicione um atraso para incialização do conky, para que ele inicie depois que a área de trabalho esteja completamente iniciada.

Obs: O arquivo de configuração parece ok, se o problema fosse nele não ficaria direito depois de reiniciar o conky, como vc mesmo relata. Eu mudaria apenas isso "update_interval 1.0" o seu intervalo está muito curto (0.5), melhor deixar 1 segundo.


10. Resolvido!

Lucas Bulegon Mello
lbmello

(usa Ubuntu)

Enviado em 26/03/2017 - 20:55h

Fiz as alterações sugeridas e o problema seguiu, então vi que a inicialização do conky tava apontado para o Conky Manager e não diretamente para meu arquivo. Isso já causava alguns problema do SO não carregar nenhum conky, nem com erro.
Então criei um comando para execução do meu Conky, com atraso de 90 segundos e setei esse arquivo na inicialização e o problema seguiu.

Rodei manualmente o caminho original para execução no bash e vi que o processo entrava em loop quando a partição "Compartilhado" não estava montada. Reconfigurei o FSTAB para montar automaticamente minha partição NTFS e o problema no Conky não aconteceu novamente.

Muito obrigado pela atenção de vocês!!!







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts