ccsm python-gtk2

1. ccsm python-gtk2

Liam sr
Digital_Master

(usa Debian)

Enviado em 02/03/2008 - 17:04h

Pessoal acabei de instalar o compiz fusion porem meu ccsm nao quer rodar devido a um arquivo chamado python-gtk2 q se encontra em sua versao 2.8.6 e o programa requer o 2.10.0, ja baixei o arquivo mas ele pediu as dependencias e se eu tentar suprir ficarei o resto do ano o fazendo. Para facilitar gostaria de saber se alguem conhece algum repositorio, q contenha o arquivo python-gtk2 em sua versao 2.10.0 ou superior?
Ja tentei varios outros metodos, inclusive alguns aqui do VOL, mas nada, gostaria de saber se alguem pode me ajudar.

ERRO:
Info: No sexy-python package found, don't worry it's optional.
PyGtk 2.10.0 or later required

este e o erro q apresenta, bom fica grato deis de ja.


  


2. Re: ccsm python-gtk2

Perfil removido
removido

(usa Nenhuma)

Enviado em 02/03/2008 - 19:49h

Como o proprio ccsm do compiz te avisou, PyGtk 2.10.0 or later é necessário para rodar a aplicação. Consequentemente ao atualizar o PyGtk também será nescessário atualizar as dependências do mesmo, portanto o melhor caminho é deixar a atualização ser realizada.

Se quiser instalar somente o python-gtk2 e ver se rola sem as atualizações, pegue a versão 2.12.1 aqui:

http://mirrors.kernel.org/ubuntu/pool/main/p/pygtk/python-gtk2_2.12.1-0ubuntu1_i386.deb

Espero ter ajudado


3. uso Arch Linux

Perfil removido
removido

(usa Nenhuma)

Enviado em 02/03/2008 - 20:04h

Dê uma olhada nisso:

Instalando o CCSM (menu do Compiz)
O CCSM é uma peça fundamental para o Compiz, é com ela que se pode fazer alterações na configuração do Compiz. Vá ao Synaptic e instale o CCSM (CompizConfig Settings Manager).

Agora rode o comando no terminal:

$ ccsm

Vai retornar com uma mensagem de erro dizendo:

Info: No sexy-python package found, don't worry it's optional.
PyGtk 2.10.0 or later required

Isso por que o Debian Etch não vem com o PyGtk 2.10.0 por padrão, precisa ser instalado manualmente.

Quando você for instalá-lo, ele irá pedir mais dois pacotes e esses irão pedir várias dependências. Depois de tudo isso instalado continuará dando erros no arquivo ccm que não encontrei nenhuma forma de acertar.

Por isso vamos mudar do PyGtk 2.10 para PyGtk 2.8, que vem por default no Debian Etch. No terminal:

# gedit /usr/bin/ccsm

Na linha 33 e 34, onde estiver PyGtk 2.10 mude para 2.8, feche e salve.

Agora, no terminal:

$ cd /usr/lib/python2.4/site-packages
$ cd ccm
# gedit Settings.py

Comente a linha 97:

#label.props.wrap_mode = gtk.WRAP_WORD

# gedit Utils.py

Comente a linha 144:

#self.props.wrap_mode = gtk.WRAP_WORD

# gedit Pages.py

Comente da linha 82 até 85:

#keyRenderer = gtk.CellRendererAccel()
#keyRenderer.connect('accel-edited', self.KeyEdited)
#keyRenderer.connect('accel-cleared', self.KeyCleared)
#self.TreeView.insert_column_with_attributes(-1, _("Key"), keyRenderer, accel_key=1, accel_mods=2, editable=8, visible=6, sensitive=8)

Pronto, reinicie o micro e rode o comando ccsm, no terminal.

é parte do meu artigo, segue que vc roda....

se quiser ver o artigo, tá aqui:

http://www.vivaolinux.com.br/artigos/verArtigo.php?codigo=7649


4. Re: ccsm python-gtk2

Liam sr
Digital_Master

(usa Debian)

Enviado em 04/03/2008 - 07:49h

Sim eu tentei fazer tudo q esta neste artigo, fiz tudo perfeitamente mas o problema persiste, olha so como esta meu arquivo:

if gtk.pygtk_version < (2,8,0):
print "PyGtk 2.8 or later required"
raise SystemExit

ate ja o deixei assim tambem:

if gtk.pygtk_version < (2,8,0):
print "PyGtk 2.8.0 or later required"
raise SystemExit

Mais nenhuma das duas formas estao funcionando continua apresentando o mesmo erro, alterei todos os arquivos q vc pediu a proposito eles ja estavao alterados por padrao, mesmo assim nada.


5. Re: ccsm python-gtk2

Liam sr
Digital_Master

(usa Debian)

Enviado em 05/03/2008 - 21:21h

Please galera me deem uma forca ai, ja tentei de tudo e nada alguem nao sabe me dizer alguma nova tecnica sei la rs.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts