Não inicia o X depois de seguir tutorial do VOL

1. Não inicia o X depois de seguir tutorial do VOL

Wéner Assis
Player Of Dark

(usa Debian)

Enviado em 26/06/2008 - 21:15h

To com um problema aqui galera, uso o Debian etch com gnome e fui tentar seguir esse tutorial http://www.vivaolinux.com.br/artigos/verArtigo.php?codigo=6886
para instalar o compiz, mas quando fui chegou a hora do compiz-manager dava como não existe, e quando dei reboot na maquina deu uma mensagem de erro no servidor X GDM esta sendo interrompido e ai caio no modo texto. Tentei usar o xorg.conf antigo pensando ser algum erro na configuração mas não adianta, não inicia de modo algum, a tela fica preta, quando aperto alguma tecla cai na tela de erro e ai já era, alguem faz ideia de como resolver isso ?


Grato.


  


2. Re: Não inicia o X depois de seguir tutorial do VOL

Hugo Alvarez
hugoalvarez

(usa Debian)

Enviado em 27/06/2008 - 00:03h

Recentemente saiu uma atualização dos pacotes do Compiz pro debian que rodam amravilha, não necessitam nenhum configuração no seu gnome como antigamente tinhamos que colocar em sessions na inicialização compiz --replace, isso jah tornou-se desnecessário, basta remover o que houver instalado do compiz em sua máquina e realizar os seguintes procedimentos:

1° - Baixe a gpg do mirror que estão os pacotes que vc vai precisar.

wget http://download.tuxfamily.org/shames/A42A6CF5.gpg -O- | apt-key add -

2° - Adicione o repositorio do compiz em seu /etc/apt/sources.list


deb http://download.tuxfamily.org/shames/debian-etch/desktopfx/stable/ ./

3° - Atualize o DB do APT

aptitude update

4° - Instale os pacotes do compiz

aptitude install compiz-fusion-all

5° - Atualize seu xorg.conf

edite o /etc/X11/xorg.conf e insira as linhas:

Option "XAANoOffscreenPixmaps" "true"

A linha acima vai ficar uma linha logo acima do Endsection da seção "Device"

entre a seção InputDevice e Device vc vai adicionar a seção:

Section "Extensions"
Option "Composite" "enable"
EndSection

Para mexer em todas as opções do compiz vc vai acahr os gerenciadores dentro de Desktop -> Preferences -> CompizConfig Settings Manager

Só isso, espero ter ajudado, até mais.



3. Re: Não inicia o X depois de seguir tutorial do VOL

Hugo Alvarez
hugoalvarez

(usa Debian)

Enviado em 27/06/2008 - 00:06h

No segundo passo o site colocou a url no link que informei automaticamente e ficou ruim para ser visualizado, o correto é o endereço que está na url seguido de um espaço " " e ponto-barra

vai ficar assim o final:

/shames/debian-etch/desktopfx/stable/ ./

Flws.



4. Re: Não inicia o X depois de seguir tutorial do VOL

marco chaves
marcola2122

(usa Debian)

Enviado em 27/06/2008 - 08:33h

tem que verificar se a placa de video esta configurada corretamente:

Para testar se está utilizando o recurso 3D execute o comando

# glxinfo | grep rendering

O Resultado

direct renrering: Yes





5. Re: Não inicia o X depois de seguir tutorial do VOL

Francisco Emmanuel Silvério
femars

(usa Slackware)

Enviado em 27/06/2008 - 08:47h

pra ver se a aceleração está ativada tb da pra usar glxgears!


6. Re: Não inicia o X depois de seguir tutorial do VOL

Wéner Assis
Player Of Dark

(usa Debian)

Enviado em 27/06/2008 - 09:44h

vou tentar o glxgears assim que chegar em casa, glxinfo só retornava uma mensagem de comando não reconhecido.

Eu segui todos os passos da instalação do drive da nvidia, dava a tela com o simbolo dela e tudo, agora é que ná hora de aparecer a tela com com a bandeira da nvidia e carregar a tela de login é que não acontece nada.



7. Re: Não inicia o X depois de seguir tutorial do VOL

Perfil removido
removido

(usa Nenhuma)

Enviado em 27/06/2008 - 10:04h

ao instalar a placa, vc carregou os modulos do kernel?


8. Re: Não inicia o X depois de seguir tutorial do VOL

Wéner Assis
Player Of Dark

(usa Debian)

Enviado em 27/06/2008 - 13:06h

Cara, eu so segui os posts, usei os comando e coloquei as linhas que falava pra por no xorg.conf.

Seguindo dica de um amigo que trabalha com linux, eu fiz os passos deste tutorial depois e mesmo assim nao resolveuo erro do anterior..
http://www.vivaolinux.com.br/artigos/verArtigo.php?codigo=7649

Se tinha mais alguma coisa que não estava nos tutoriais não fiz não.


9. Re: Não inicia o X depois de seguir tutorial do VOL

Wéner Assis
Player Of Dark

(usa Debian)

Enviado em 28/06/2008 - 16:40h

Reinstalei o sistema, segui o tutorial do hugoalvez ai foi so por /usr/bin/compiz-manager no inicializador de sessões que deu certo o compiz, mas ai sumiu a barra de miniminizar, maximinizar e fechar, vi na net que isso acontece as vezes mas as vezes conseguem resolver com um replace ou um reinstalar metacity, mas aqui nada disso funcionou. Como eu tinha reinstalado o Debian havia algumas atualizaçãoes a serem feitas, quando terminou e reiniciou a maquina (pediu pra reiniciar a maquina, nao apenas o X) o compiz sumiu, fui no terminar chama-lo e deu isso :

playerofdark@HAL9000:~$ compiz --replace & [5] 3300
playerofdark@HAL9000:~$ Fatal: Failed test: texture_from_pixmap support
Checks indicate that it's impossible to start compiz on your system.

[5]+ Exit 1 compiz --replace
playerofdark@HAL9000:~$


E agora pessoal, o que fazer ?

Ps: ALT+TAB parou de funcionar agora...


10. Re: Não inicia o X depois de seguir tutorial do VOL

Wéner Assis
Player Of Dark

(usa Debian)

Enviado em 28/06/2008 - 17:05h

resolvi ja o do compiz nao inicializar...
quando deixei atualizar o drive de video foi pro espaço...

mas o problema com a barra de redimensionar continua e tambem os temas do emerald nao funcionam...


Como resolver pessoal ???


11. Re: Não inicia o X depois de seguir tutorial do VOL

Perfil removido
removido

(usa Nenhuma)

Enviado em 28/06/2008 - 17:32h

vê se isso te ajuda :

http://www.vivaolinux.com.br/artigos/verArtigo.php?codigo=7649&pagina=3


12. Re: Não inicia o X depois de seguir tutorial do VOL

Wéner Assis
Player Of Dark

(usa Debian)

Enviado em 28/06/2008 - 17:54h

eu!noel valew, mas adiantou não, continuo sem a lateral e as partes de cima e de baixo das janelas...



01 02