Não encontro a biblioteca bcop

1. Não encontro a biblioteca bcop

Adriano Gonçalves
Adriano_Gon

(usa Slackware)

Enviado em 28/04/2013 - 14:06h

Estou tentando instalar o compiz no Slackware 14 seguindo esta ordem:
1. compiz-bcop
2. protobuf (optional but recommended)
3. libcompizconfig
4. compizconfig-python
5. compizconfig-backend-kconfig4 (optional)
6. ccsm
7. compiz-plugins-main
8. compiz-plugins-extra (optional)
9. compiz-plugins-unsupported (optional)
10. emerald (optional)
11. emerald-themes (optional)
12. fusion-icon (optional)

Mas quando vou instalar o 7º intem (compiz-plugins-main) aparece o seguinte erro:

checking for BCOP... no
configure: error: Package requirements (bcop >= 0.7.3) were not met:

No package 'bcop' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BCOP_CFLAGS
and BCOP_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Mas eu não encontro esse bcop em lugar algum. Alguém tem idéia onde posso encontrar e instalar.
Estou usando o ambiente Xfce.


  


2. Re: Não encontro a biblioteca bcop

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 28/04/2013 - 14:29h

não sou usuario de slackware, mas pelo que eu saiba, tem no slackbuilds:

http://slackbuilds.org/repository/12.1/desktop/ccsm/

mas se não achar, vc pode baixar o original fonte no site compiz e compilar.


3. Re: Não encontro a biblioteca bcop

Adriano Gonçalves
Adriano_Gon

(usa Slackware)

Enviado em 28/04/2013 - 19:14h

albfneto escreveu:

não sou usuario de slackware, mas pelo que eu saiba, tem no slackbuilds:

http://slackbuilds.org/repository/12.1/desktop/ccsm/

mas se não achar, vc pode baixar o original fonte no site compiz e compilar.


Obrigado pela ajuda.
Então eu já fiz a instalação do pacote compiz-bcop-0.8.8. mas não está fucionando.
Mas fui novamente fazer a instalação do compiz-bcop-0.8.8 e percebi que algo está errado eu acredito que essa biblioteca não está sendo instalada. Olha só.

bash-4.2# make
make all-recursive
make[1]: Entrando no diretório `/root/Downloads/compiz-bcop-0.8.8'
Making all in src
make[2]: Entrando no diretório `/root/Downloads/compiz-bcop-0.8.8/src'
make[2]: Nada a ser feito para `all'.
make[2]: Saindo do diretório `/root/Downloads/compiz-bcop-0.8.8/src'
make[2]: Entrando no diretório `/root/Downloads/compiz-bcop-0.8.8'
make[2]: Saindo do diretório `/root/Downloads/compiz-bcop-0.8.8'
make[1]: Saindo do diretório `/root/Downloads/compiz-bcop-0.8.8

Será que pode ser isso?