curl -s ou --sillent não funcionando. [RESOLVIDO]

1. curl -s ou --sillent não funcionando. [RESOLVIDO]

Filipe Torres
peuzenhu

(usa Red Hat)

Enviado em 15/10/2021 - 15:49h

Eu estou executando um script que pega uma variável usando o as linhas do comando abaixo com o curl, porém quando roda ele está trazendo um mundarel de informção na tela,
mesmo usando o -s no comando.
tem algo errado aí?

kinit -kt /etc/krb5.keytab NODE$ 1&> /dev/null 2&> /dev/null
JWTVIN=$(curl -v --negotiate -s -v -u: https://krb2jwt.localhost.net/krb2jwt/v1/jwt | awk -F \" '{print $4}')
AUTH=$(curl -X GET -s -H "x-jwt-assertion:$JWTVIN" "https://secrets-sms-api.localhost.net/v1/secrets?role=RECIPIENT" -H "Content-Type: application/json"| awk -F \"\:\" '{print $6}' | awk -F \" '{print $1}')




  


2. MELHOR RESPOSTA

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 15/10/2021 - 16:36h

peuzenhu escreveu:
JWTVIN=$(curl -v --negotiate -s -v -u: https://krb2jwt.localhost.net/krb2jwt/v1/jwt | awk -F \" '{print $4}')


repare que aqui vc coloca dois parâmetros conflitantes, o verbose ( -v ) e o silent (-s ), o comando só executou o que viu primeiro ... que foi o verbose !!!

------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------



3. Re: curl -s ou --sillent não funcionando. [RESOLVIDO]

Filipe Torres
peuzenhu

(usa Red Hat)

Enviado em 15/10/2021 - 18:05h


Mauriciodez escreveu:

repare que aqui vc coloca dois parâmetros conflitantes, o verbose ( -v ) e o silent (-s ), o comando só executou o que viu primeiro ... que foi o verbose !!!


Nossa, cara eu li no curl -h e nem reparei nisso.

Ja resolveu o problema, Muito obrigado!!!!

(eu cliquei no joinha pra baixo sem querer)



4. Re: curl -s ou --sillent não funcionando. [RESOLVIDO]

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 15/10/2021 - 18:31h


peuzenhu escreveu:
Ja resolveu o problema, Muito obrigado!!!!

(eu cliquei no joinha pra baixo sem querer)


Bom que resolveu fácil ... relaxa nessa parada de joinha pra baixo mas marque a "melhor resposta"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------








Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts