Não consigo dar apt upgrade por causa de um pacote :( [RESOLVIDO]

1. Não consigo dar apt upgrade por causa de um pacote :( [RESOLVIDO]

Felipe Machado
LipeMachado

(usa Ubuntu)

Enviado em 31/03/2020 - 19:38h

Hello!
Preciso de ajuda, estou tentando dar apt upgrade mas não consigo, aparece isso:

Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
E: O pacote metasploit precisa ser reinstalado, mas não foi possível encontrar um arquivo para o mesmo.


Alguém me ajuda por favor :(


  


2. Re: Não consigo dar apt upgrade por causa de um pacote :( [RESOLVIDO]

Diego Mendes Rodrigues
diegomrodrigues

(usa Ubuntu)

Enviado em 31/03/2020 - 21:10h

Qual distribuição você utiliza?

Abraço,
Diego M. Rodrigues


3. Re: Não consigo dar apt upgrade por causa de um pacote :( [RESOLVIDO]

Felipe Machado
LipeMachado

(usa Ubuntu)

Enviado em 31/03/2020 - 21:38h

Ubuntu


4. Re: Não consigo dar apt upgrade por causa de um pacote :( [RESOLVIDO]

Paulo Jr
Pebis

(usa Debian)

Enviado em 31/03/2020 - 21:57h


Vamos lá... qual a caca geral? Adicionou qual repositório?


5. Re: Não consigo dar apt upgrade por causa de um pacote :( [RESOLVIDO]

Felipe Machado
LipeMachado

(usa Ubuntu)

Enviado em 31/03/2020 - 22:09h

Fui tentar instalar o metasploit, mas deu um erro na instalação, entao desistir e sair, mas agora no topo da tela aparece uma bola vermelha com um traço branco falando que deu erro na instalação e quando dou apt upgrade aparece isso que coloquei la em cima, ja tentei dar apt remove metasploit mas não está funcionando



6. Re: Não consigo dar apt upgrade por causa de um pacote :(

João Cláudio de Alcântara
aguamole

(usa Lubuntu)

Enviado em 31/03/2020 - 22:12h

$ sudo dpkg -r metasploit
$ sudo apt-get install -f

O APT é um gerenciador de pacote de alto nível (gerenciador inteligente) o gerenciador de baixo nível (DPKG) deve conseguir remover.

CPU i5-8400 GTX 750 SofRaid 4xSSD 16GB DDR4 mesmo assim uso Lubuntu.


7. Re: Não consigo dar apt upgrade por causa de um pacote :( [RESOLVIDO]

Paulo Jr
Pebis

(usa Debian)

Enviado em 31/03/2020 - 22:48h


LipeMachado escreveu:

Fui tentar instalar o metasploit, mas deu um erro na instalação, entao desistir e sair, mas agora no topo da tela aparece uma bola vermelha com um traço branco falando que deu erro na instalação e quando dou apt upgrade aparece isso que coloquei la em cima, ja tentei dar apt remove metasploit mas não está funcionando


E esse metasploit está no repositório do Sistema?


8. Re: Não consigo dar apt upgrade por causa de um pacote :(

João Cláudio de Alcântara
aguamole

(usa Lubuntu)

Enviado em 01/04/2020 - 02:55h

Pebis escreveu:

E esse metasploit está no repositório do Sistema?

Não esta nos repositório do Ubuntu.
Eu também queria saber como ele instalo mais ai eu acredito que era melhor abrir outro tópico já que esse já foi resolvido.

CPU i5-8400 GTX 750 SofRaid 4xSSD 16GB DDR4 mesmo assim uso Lubuntu.


9. Re: Não consigo dar apt upgrade por causa de um pacote :( [RESOLVIDO]

Felipe Machado
LipeMachado

(usa Ubuntu)

Enviado em 01/04/2020 - 13:45h

aguamole escreveu:

$ sudo dpkg -r metasploit
$ sudo apt-get install -f

O APT é um gerenciador de pacote de alto nível (gerenciador inteligente) o gerenciador de baixo nível (DPKG) deve conseguir remover.

CPU i5-8400 GTX 750 SofRaid 4xSSD 16GB DDR4 mesmo assim uso Lubuntu.




Não funcionou:

[email protected]:~$ sudo dpkg -r metasploit
[sudo] senha para lipe:
dpkg: erro ao processar o pacote metasploit (--remove):
O pacote está num estado de inconsistência muito mau; deve
reinstalá-lo antes de tentar a remoção.
Erros foram encontrados durante o processamento de:
metasploit
[email protected]:~$ sudo apt-get install -f
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
E: O pacote metasploit precisa ser reinstalado, mas não foi possível encontrar um arquivo para o mesmo.



10. Re: Não consigo dar apt upgrade por causa de um pacote :( [RESOLVIDO]

Matheus
pylm

(usa Gentoo)

Enviado em 01/04/2020 - 14:03h

Você adicionou um repositório pra instalar o metasploit
Instalou o metasploit
Removeu o repositório
Agora o apt não acha mais o metasploit porque o repositório desapareceu

Adiciona de novo o repositório do metasploit.


11. Re: Não consigo dar apt upgrade por causa de um pacote :( [RESOLVIDO]

Felipe Machado
LipeMachado

(usa Ubuntu)

Enviado em 01/04/2020 - 15:13h

pylm escreveu:

Você adicionou um repositório pra instalar o metasploit
Instalou o metasploit
Removeu o repositório
Agora o apt não acha mais o metasploit porque o repositório desapareceu

Adiciona de novo o repositório do metasploit.


Teria como tu me falar como? porque eu sou + ou - novo no linux





12. Re: Não consigo dar apt upgrade por causa de um pacote :(

João Cláudio de Alcântara
aguamole

(usa Lubuntu)

Enviado em 01/04/2020 - 15:40h

sudo dpkg -r --force-all metasploit
Leia o manual dos comando esse passo você poderia ter pulado se tivesse lido o manual:
$ dpkg --force-help
$ dpkg --help
$ man dpkg

CPU i5-8400 GTX 750 SofRaid 4xSSD 16GB DDR4 mesmo assim uso Lubuntu.



01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts