Erro usando o cron

1. Erro usando o cron

Alcelyo R Mariz
alcelyo

(usa Suse)

Enviado em 05/07/2016 - 11:58h

Beleza pessoal,

Estou tentando usar o Linodecli , instalei no meu servidor centos 7, rodo o comando no console
linode start meu seridor
, tudo ok. Ele me retorna um string "Servidor iniciando".
Agora se colocar para rodar pelo cron da erro, .. informa comando não encontrado.
não sei se é por causa do retorno da string, será que tem haver ?
Rodando no terminal
# /opt/linode_cli/sh/iniciar.sh - Da certo
Quando adiciono no cron
* 06 * * * /opt/linode_cli/sh/iniciar.sh
Retorna que o comando não foi encontrado
Ajudas ???
Valeu galera


  


2. Olá...

Tiago Martimiano de Siqueira Uruba
tiagodebian

(usa Debian)

Enviado em 05/07/2016 - 12:12h

Deixo só entender você quer rodar as 6 horas ?

se for tenta * 6 * * * root /opt/linode_cli/sh/iniciar.sh


3. Re: Erro usando o cron

Alcelyo R Mariz
alcelyo

(usa Suse)

Enviado em 05/07/2016 - 12:26h

Em questão da hora está certo, executa o comando. Só que ao executar pelo agendamento dar o erro.
No logo ... /mail/root
/opt/linode_cli/sh/iniciar.sh: line 2: linode: comando não encontrado


4. Re: Erro usando o cron

Matth
MattF

(usa Slackware)

Enviado em 05/07/2016 - 12:49h

alcelyo escreveu:

Em questão da hora está certo, executa o comando. Só que ao executar pelo agendamento dar o erro.
No logo ... /mail/root
/opt/linode_cli/sh/iniciar.sh: line 2: linode: comando não encontrado


Estranho. tente fazer assim:

* 6 * * * sh /opt/linode_cli/sh/iniciar.sh







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts