" Error: Unable to update package cache. Please try "apt-get update"" instalando Pi-Hole

1. " Error: Unable to update package cache. Please try "apt-get update"" instalando Pi-Hole

Lucas
lucasdr98

(usa Debian)

Enviado em 13/01/2020 - 21:16h

Estou tentando instalar o Pi-Hole em uma placa C.H.I.P, que executa o debian 8, mas sempre encontro esse erro durante a instalação. Eu tentei várias coisas, mas nada aparentemente funcionou, abaixo está o meu sources.list:
deb http://ftp.us.debian.org/debian/ jessie main contrib non-free

deb-src http://ftp.us.debian.org/debian/ jessie main contrib non-free


deb http://security.debian.org/ jessie/updates main contrib non-free

deb-src http://security.debian.org/ jessie/updates main contrib non-free


deb http://http.debian.net/debian jessie-backports main contrib non-free

deb-src http://http.debian.net/debian jessie-backports main contrib non-free


deb http://opensource.nextthing.co/chip/debian/repo jessie main


deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free rpi

Algumas imagens:
https://preview.redd.it/y6pyxoxwwma41.png?width=1600&format=png&auto=webp&s=00750927377f...

https://preview.redd.it/ftvpoqp4xma41.png?width=1600&format=png&auto=webp&s=8eca48865f71...

https://preview.redd.it/0ojdqwc7xma41.png?width=1600&format=png&auto=webp&s=c27b590e40ab...


  


2. Re:

Andre (pinduvoz)
pinduvoz

(usa Debian)

Enviado em 13/01/2020 - 21:41h

Tentou assim:

a) instale git e net-tools:

$ sudo apt-get install git net-tools

b) Use o git para clonar o pi-hole:

$ git clone --depth 1 https://github.com/pi-hole/pi-hole.git pi-hole

c) execute o script de instalação:

$ sudo bash pi-hole/automated\ install/basic-install.sh

para abrir o instalador do pi-hole.

Fonte: https://blog.sleeplessbeastie.eu/2018/01/11/how-to-install-and-configure-pi-hole/



3. Re: " Error: Unable to update package cache. Please try "apt-get update"" instalando Pi-Hole

Andre (pinduvoz)
pinduvoz

(usa Debian)

Enviado em 13/01/2020 - 21:46h

Veja que o pacote "pi-hole" não está nos repositórios do Debian, ao menos não nos do meu "testing".



4. Re: " Error: Unable to update package cache. Please try "apt-get update"" instalando Pi-Hole

Lucas
lucasdr98

(usa Debian)

Enviado em 13/01/2020 - 21:46h

Eu fiz exatamente isso, mas da esse erro:
https://preview.redd.it/ftvpoqp4xma41.png?width=1600&format=png&auto=webp&s=8eca48865f71...

pinduvoz escreveu:

Tentou assim:

a) instale git e net-tools:

$ sudo apt-get install git net-tools

b) Use o git para clonar o pi-hole:

$ git clone --depth 1 https://github.com/pi-hole/pi-hole.git pi-hole

c) execute o script de instalação:

$ sudo bash pi-hole/automated\ install/basic-install.sh

para abrir o instalador do pi-hole.

Fonte: https://blog.sleeplessbeastie.eu/2018/01/11/how-to-install-and-configure-pi-hole/





5. Re:

Andre (pinduvoz)
pinduvoz

(usa Debian)

Enviado em 14/01/2020 - 01:28h

Atualize tudo antes de rodar o script de instalação do pi-hole, assim:

sudo apt-get update && sudo apt-get upgrade 


Depois rode o instalador para ver se ele para de reclamar de não poder atualizar a lista de pacotes.



6. Re: " Error: Unable to update package cache. Please try "apt-get update"" instalando Pi-Hole

Andre (pinduvoz)
pinduvoz

(usa Debian)

Enviado em 14/01/2020 - 01:38h

Outro detalhe: Debian 8 é EOL. O 9 agora é o old-stable, isso ao que eu saiba.

Talvez não dê mesmo para atualizar a lista de fontes sem mexer no arquivo da lista de fontes.

Veja:

https://www.edivaldobrito.com.br/suporte-de-seguranca-do-debian-8-jessie-acaba/






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts