Problemas com o YUM UPDATE. [RESOLVIDO]

1. Problemas com o YUM UPDATE. [RESOLVIDO]

Arthur Neto
---Anonymous---

(usa Debian)

Enviado em 27/12/2009 - 10:57h

Olá pessoal, etnão estou eu aqui mais uma vez com uma dificuldade.
Quando eu dou o comando YUM UPDATE para verificar novas atualizações, esta me aparecendo isso.

[[email protected] yum.repos.d]# yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* addons: mirror.centos-br.org
* base: mirror.centos-br.org
* centosplus: mirror.centos-br.org
* contrib: mirror.centos-br.org
* extras: mirror.centos-br.org
* jpackage-generic: mirrors.dotsrc.org
* rpmforge: fr2.rpmfind.net
* updates: mirror.centos-br.org
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package antlr.noarch 0:2.7.7-1jpp set to be updated
---> Package bsf.noarch 0:2.4.0-1jpp set to be updated
--> Processing Dependency: jdom >= 1.0 for package: bsf
--> Processing Dependency: jakarta-commons-logging >= 1.0.4 for package: bsf
--> Processing Dependency: log4j >= 1.2.12 for package: bsf
--> Processing Dependency: velocity >= 1.4 for package: bsf
--> Processing Dependency: jakarta-commons-collections >= 3.1 for package: bsf
---> Package bsh.noarch 0:1.3.0-11jpp set to be updated
---> Package cadaver.i386 0:0.22.5-1.el5.rf set to be updated
---> Package dnsmasq.i386 0:2.51-1.el5.rf set to be updated
---> Package iso-codes.noarch 0:1.0a-1.fc6.rf set to be updated
---> Package jpackage-utils.noarch 0:1.7.5-1jpp set to be updated
---> Package lftp.i386 0:4.0.5-1.el5.rf set to be updated
---> Package libwpd.i386 0:0.8.14-1.el5.rf set to be updated
---> Package mtr.i386 2:0.75-1.el5.rf set to be updated
---> Package nmap.i386 2:5.00-1.el5.rf set to be updated
---> Package perl-HTML-Parser.i386 0:3.62-1.el5.rf set to be updated
---> Package perl-HTML-Tagset.noarch 0:3.20-1.el5.rf set to be updated
---> Package perl-IO-Compress.noarch 0:2.021-1.el5.rf set to be updated
--> Processing Dependency: perl(Compress::Raw::Bzip2) >= 2.021 for package: perl-IO-Compress
--> Processing Dependency: perl(Compress::Raw::Zlib) >= 2.021 for package: perl-IO-Compress
---> Package rsync.i386 0:3.0.6-1.el5.rf set to be updated
---> Package syslinux.i386 0:3.84-1.el5.rf set to be updated
--> Processing Dependency: perl(Crypt::PasswdMD5) for package: syslinux
--> Processing Dependency: perl(Digest::SHA1) for package: syslinux
---> Package tomcat5-jsp-2.0-api.noarch 0:5.5.25-1jpp set to be updated
---> Package tomcat5-servlet-2.4-api.noarch 0:5.5.25-1jpp set to be updated
---> Package udftools.i386 0:1.0.0b3-3.el5.rf set to be updated
---> Package xalan-j2.noarch 0:2.7.0-7jpp set to be updated
---> Package xdelta.i386 0:1.1.4-1.el5.rf set to be updated
---> Package xerces-j2.noarch 0:2.9.0-2jpp set to be updated
--> Processing Dependency: xml-commons-jaxp-1.3-apis >= 1.3 for package: xerces-j2
--> Processing Dependency: xml-commons = 1.3.02-0.b2.7jpp.10 for package: xml-commons-apis
---> Package xml-commons.noarch 0:1.3.03-11jpp set to be updated
---> Package xml-commons-resolver10.noarch 0:1.3.03-11jpp set to be updated
---> Package xml-commons-resolver11.noarch 0:1.3.03-11jpp set to be updated
---> Package xml-commons-resolver12.noarch 0:1.3.03-11jpp set to be updated
--> Running transaction check
---> Package jakarta-commons-collections.noarch 0:3.2-2jpp set to be updated
---> Package jakarta-commons-logging.noarch 0:1.1-4jpp set to be updated
---> Package jdom.noarch 0:1.0-5jpp set to be updated
--> Processing Dependency: jaxen for package: jdom
---> Package log4j.noarch 0:1.2.14-3jpp set to be updated
---> Package perl-Compress-Raw-Bzip2.i386 0:2.021-1.el5.rf set to be updated
---> Package perl-Compress-Raw-Zlib.i386 0:2.023-1.el5.rf set to be updated
---> Package perl-Crypt-PasswdMD5.noarch 0:1.3-1.2.fc6.rf set to be updated
---> Package perl-Digest-SHA1.i386 0:2.12-1.el5.rf set to be updated
---> Package velocity.noarch 0:1.5-2jpp set to be updated
--> Processing Dependency: jakarta-commons-lang for package: velocity
--> Processing Dependency: servletapi4 for package: velocity
--> Processing Dependency: werken-xpath for package: velocity
--> Processing Dependency: excalibur-avalon-logkit for package: velocity
--> Processing Dependency: jakarta-oro for package: velocity
--> Processing Dependency: xml-commons = 1.3.02-0.b2.7jpp.10 for package: xml-commons-apis
---> Package xml-commons-jaxp-1.3-apis.noarch 0:1.3.03-11jpp set to be updated
--> Running transaction check
---> Package excalibur-avalon-logkit.noarch 1:2.2.1-0.r508111.3jpp set to be updated
--> Processing Dependency: excalibur = 1:1.0-0.r508111.3jpp for package: excalibur-avalon-logkit
--> Processing Dependency: javamail for package: excalibur-avalon-logkit
--> Processing Dependency: geronimo-jms-1.1-api for package: excalibur-avalon-logkit
---> Package jakarta-commons-lang.noarch 0:2.3-1jpp set to be updated
---> Package jakarta-oro.noarch 0:2.0.8-3jpp set to be updated
---> Package jaxen.noarch 0:1.1-4jpp set to be updated
--> Processing Dependency: dom4j >= 1.6.1 for package: jaxen
--> Processing Dependency: xom for package: jaxen
---> Package servletapi4.noarch 0:4.0.4-4jpp set to be updated
---> Package werken-xpath.noarch 0:0.9.4-0.beta.13jpp set to be updated
--> Processing Dependency: xml-commons = 1.3.02-0.b2.7jpp.10 for package: xml-commons-apis
--> Running transaction check
---> Package dom4j.noarch 0:1.6.1-4jpp set to be updated
--> Processing Dependency: isorelax for package: dom4j
--> Processing Dependency: bea-stax-api for package: dom4j
--> Processing Dependency: xpp2 for package: dom4j
--> Processing Dependency: bea-stax for package: dom4j
--> Processing Dependency: xpp3 for package: dom4j
--> Processing Dependency: relaxngDatatype for package: dom4j
--> Processing Dependency: msv-xsdlib for package: dom4j
--> Processing Dependency: ws-jaxme for package: dom4j
--> Processing Dependency: msv-msv for package: dom4j
---> Package excalibur.noarch 1:1.0-0.r508111.3jpp set to be updated
---> Package geronimo-jms-1.1-api.noarch 0:1.1-4jpp set to be updated
--> Processing Dependency: geronimo-specs-poms = 1.1-4jpp for package: geronimo-jms-1.1-api
---> Package sun-mail.noarch 0:1.4-3jpp set to be updated
--> Processing Dependency: sun-jaf for package: sun-mail
--> Processing Dependency: gnu-crypto-sasl-jdk1.4 for package: sun-mail
--> Processing Dependency: xml-commons = 1.3.02-0.b2.7jpp.10 for package: xml-commons-apis
---> Package xom.noarch 0:1.0-6jpp set to be updated
--> Processing Dependency: icu4j for package: xom
--> Running transaction check
---> Package bea-stax.noarch 0:1.2.0-0.rc1.2jpp set to be updated
---> Package bea-stax-api.noarch 0:1.2.0-0.rc1.2jpp set to be updated
---> Package geronimo-specs-poms.noarch 0:1.1-4jpp set to be updated
---> Package gnu-crypto-sasl-jdk1.4.noarch 0:2.1.0-2jpp set to be updated
---> Package icu4j.noarch 0:3.4.5-1jpp set to be updated
---> Package isorelax.noarch 0:0.1-0.20041111.2jpp set to be updated
---> Package msv-msv.noarch 0:1.2-0.20050722.3jpp set to be updated
---> Package msv-xsdlib.noarch 0:1.2-0.20050722.3jpp set to be updated
---> Package relaxngDatatype.noarch 0:1.0-3jpp set to be updated
---> Package sun-jaf.noarch 0:1.1-3jpp set to be updated
---> Package ws-jaxme.noarch 0:0.5.2-1jpp set to be updated
--> Processing Dependency: xmldb-api for package: ws-jaxme
--> Processing Dependency: ant for package: ws-jaxme
--> Processing Dependency: xml-commons = 1.3.02-0.b2.7jpp.10 for package: xml-commons-apis
---> Package xpp2.noarch 0:2.1.10-6jpp set to be updated
---> Package xpp3.noarch 0:1.1.3.8-1jpp set to be updated
--> Running transaction check
---> Package ant.noarch 0:1.6.5-4jpp set to be updated
--> Processing Dependency: java-devel for package: ant
--> Processing Dependency: xml-commons = 1.3.02-0.b2.7jpp.10 for package: xml-commons-apis
---> Package xmldb-api.noarch 0:0.1-0.20041010.3jpp set to be updated
--> Running transaction check
---> Package java-1.6.0-openjdk-devel.i386 1:1.6.0.0-1.7.b09.el5 set to be updated
--> Processing Dependency: xml-commons = 1.3.02-0.b2.7jpp.10 for package: xml-commons-apis
--> Processing Dependency: /usr/bin/rebuild-security-providers for package: java-1.4.2-gcj-compat
--> Processing Dependency: /usr/bin/rebuild-security-providers for package: java-1.4.2-gcj-compat
--> Processing Dependency: /usr/bin/rebuild-security-providers for package: java-1.4.2-gcj-compat
--> Finished Dependency Resolution
xml-commons-apis-1.3.02-0.b2.7jpp.10.i386 from installed has depsolving problems
--> Missing Dependency: xml-commons = 1.3.02-0.b2.7jpp.10 is needed by package xml-commons-apis-1.3.02-0.b2.7jpp.10.i386 (installed)
java-1.4.2-gcj-compat-1.4.2.0-40jpp.115.i386 from installed has depsolving problems
--> Missing Dependency: /usr/bin/rebuild-security-providers is needed by package java-1.4.2-gcj-compat-1.4.2.0-40jpp.115.i386 (installed)
Error: Missing Dependency: xml-commons = 1.3.02-0.b2.7jpp.10 is needed by package xml-commons-apis-1.3.02-0.b2.7jpp.10.i386 (installed)
Error: Missing Dependency: /usr/bin/rebuild-security-providers is needed by package java-1.4.2-gcj-compat-1.4.2.0-40jpp.115.i386 (installed)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.


Sera que é alguma dependencia???

O que pode ser??


  


2. Re: Problemas com o YUM UPDATE. [RESOLVIDO]

Arthur Neto
---Anonymous---

(usa Debian)

Enviado em 27/12/2009 - 11:58h

EI galera, na hora de atualizar, ele diz que o problema esta aqui:

Missing Dependency: xml-commons = 1.3.02-0.b2.7jpp.10 is needed by package xml-commons-apis-1.3.02-0.b2.7jpp.10.i386 (installed)
Missing Dependency: /usr/bin/rebuild-security-providers is needed by package java-1.4.2-gcj-compat-1.4.2.0-40jpp.115.i386 (installed)

Por que será???


3. Re: Problemas com o YUM UPDATE. [RESOLVIDO]

Ricardo Cardoso
Ricardo Cardoso

(usa Debian)

Enviado em 27/12/2009 - 14:43h

Essa mensagem refere-se a dependências perdidas, faz tempo que não atualizo meu CentOS, mas esta me parecendo que os repositórios de onde ele esta tentando baixar já estão obsoletos e vc precisaria checar por novos repositórios contendo esses pacotes.


4. Problemas com o YUM UPDATE.

Luciana Pinna
duduenico

(usa CentOS)

Enviado em 05/08/2010 - 12:15h

Prezados,
estou tendo o mesmo problema que o colega relatou.

Não consigo efetuar atualizações pois aparece exatamente o que foi descrito.

Alguém pode me ajudar a sanar o problema.

Estou entrando no mundo do software livre agora. Preciso muito da ajuda de vocês.

Abs


5. Re: Problemas com o YUM UPDATE. [RESOLVIDO]

Rodrigo Chaves
stilldre

(usa Funtoo)

Enviado em 05/08/2010 - 12:18h

You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest

???


6. Re: Problemas com o YUM UPDATE. [RESOLVIDO]

Elder Marco
eldermarco

(usa Fedora)

Enviado em 05/08/2010 - 13:13h

Pois é, como o colega citou acima, pode-se fazer:

# yum update --skip-broken

E isso poderá resvolver o problema. A questão é que um pacote está dependendo de outro que ainda não está no repositório.


7. Mesmo problema

Jacson
jacsonfh

(usa CentOS)

Enviado em 06/12/2012 - 14:05h

E nenhum dos comandos citados na resposta do erro está resolvendo...


8. Re: Problemas com o YUM UPDATE. [RESOLVIDO]

Adriano de Oliveira
Fronimos

(usa Arch Linux)

Enviado em 31/10/2013 - 10:50h

Experimente apagar o cache dos repositórios com o comando

yum clean all

e depois

yum repolist

pra depois tentar novamente

yum update






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts