Urgente! Recuperação de SR perdida acidentalmente. [RESOLVIDO]

1. Urgente! Recuperação de SR perdida acidentalmente. [RESOLVIDO]

Ádison Belo
adsuporte

(usa Debian)

Enviado em 21/12/2017 - 12:44h

Boa tarde Pessoal!!

Estou com um problema, seguinte:

Tenho um servidor rodando o Xenserver 6.2 rodando 3 máquinas virtuais a muito tempo, certo dia precisei trocar os HD's do servidor para aumentar a capacidade de armazenamento e coloquei o servidor em um pool de servidores para fazer a cópia das vms, até ai tudo bem!!!

o problema é que esses dias eu precisei de tirar o servidor do pool para deligar o servidor Pool Master e não prestei atenção na mensagem que dizia que se eu tirasse o servidor do pool o xenserver voltaria no estado zero de instalação, ou seja, perdi os Storage Repository das VMs!

minha pergunta é, teria a possibilidade de recuperar esses SR?

se não, teria como recuperar os dados desse HD?

Obrigado por enquanto!



  


2. Re: Urgente! Recuperação de SR perdida acidentalmente. [RESOLVIDO]

Matheus
pylm

(usa Gentoo)

Enviado em 21/12/2017 - 13:08h

Quanto aos dados, você consegue recuperar com o testdisk.

https://www.cgsecurity.org/wiki/TestDisk_Download


3. Re: Urgente! Recuperação de SR perdida acidentalmente. [RESOLVIDO]

Ivanildo
maiacpd

(usa Ubuntu)

Enviado em 29/01/2018 - 09:59h

adsuporte escreveu:

Boa tarde Pessoal!!

Estou com um problema, seguinte:

Tenho um servidor rodando o Xenserver 6.2 rodando 3 máquinas virtuais a muito tempo, certo dia precisei trocar os HD's do servidor para aumentar a capacidade de armazenamento e coloquei o servidor em um pool de servidores para fazer a cópia das vms, até ai tudo bem!!!

o problema é que esses dias eu precisei de tirar o servidor do pool para deligar o servidor Pool Master e não prestei atenção na mensagem que dizia que se eu tirasse o servidor do pool o xenserver voltaria no estado zero de instalação, ou seja, perdi os Storage Repository das VMs!

minha pergunta é, teria a possibilidade de recuperar esses SR?

se não, teria como recuperar os dados desse HD?

Obrigado por enquanto!


Alguma novidade? Estou acompanhando...


4. Re: Urgente! Recuperação de SR perdida acidentalmente. [RESOLVIDO]

Fausto Silva Alves
linuxhh

(usa Outra)

Enviado em 28/02/2018 - 16:01h

Deixe eu entender melhor, você tinha um host em um pool, no qual, ele era o Master, correto?
No Pool , só tinha um host, ou mais hosts?
Nas configurações da Storage, você fez através do Pool ou fez apenas no host?



5. Re: Urgente! Recuperação de SR perdida acidentalmente. [RESOLVIDO]

Ádison Belo
adsuporte

(usa Debian)

Enviado em 28/02/2018 - 16:11h

maiacpd escreveu:

adsuporte escreveu:

Boa tarde Pessoal!!

Estou com um problema, seguinte:

Tenho um servidor rodando o Xenserver 6.2 rodando 3 máquinas virtuais a muito tempo, certo dia precisei trocar os HD's do servidor para aumentar a capacidade de armazenamento e coloquei o servidor em um pool de servidores para fazer a cópia das vms, até ai tudo bem!!!

o problema é que esses dias eu precisei de tirar o servidor do pool para deligar o servidor Pool Master e não prestei atenção na mensagem que dizia que se eu tirasse o servidor do pool o xenserver voltaria no estado zero de instalação, ou seja, perdi os Storage Repository das VMs!

minha pergunta é, teria a possibilidade de recuperar esses SR?

se não, teria como recuperar os dados desse HD?

Obrigado por enquanto!


Alguma novidade? Estou acompanhando...


Resolvido o problema, vou postar os links das resoluções que me ajudaram a resolver o problema!




6. Problema resolvido !!!!

Ádison Belo
adsuporte

(usa Debian)

Enviado em 28/02/2018 - 16:19h

Consegui resolver o problema seguindo os passos desses links:
https://www.ibm.com/developerworks/mydeveloperworks/blogs/752a690f-8e93-4948-b7a3-c060117e8665/entry...

https://www.ibm.com/developerworks/community/blogs/752a690f-8e93-4948-b7a3-c060117e8665/entry/recupe...

Na verdade o problema é que removi um servidor do pool de servidores de Xenserver e quando isso é feito o servidor excluído volta a estaca zero de configuração, com isso as partições LVM foram perdidas mais os dados continuaram lá!!!

Na verdade o começo da solução foi nesses links de postei, naveguei por diversos fóruns (a maioria em inglês) para ai sim conseguir a resolução final!

consegui recuperar todas as partições LVM e todas as VMs perdidas!!!!

Agradeço quem tentou me ajudar e espero que essa solução ajude outros técnicos!

Abraço a todos!!!






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts