Processo umount travado no centos e consumindo 100% de cpu

1. Processo umount travado no centos e consumindo 100% de cpu

Teste Infra
testeinfra

(usa CentOS)

Enviado em 12/04/2018 - 14:11h

Boa tarde pessoal.

Estou tendo problema ao tentar desmontar uma partição no CentOS.
Tenho um disco iscsi montado no meu servidor centos. Ele é utilizado apenas como área de backup de alguns arquivos. Entretanto recentemente ele me retornou um erro falando que o sistema de arquivos estava como somente leitura. Fui desmontar a partição para executar um fsck nela. Só que o processo do umount ficou travado e a partição não desmontou. Ele está consumindo muita cpu do servidor. Tentei de todas as formas com o kill e ele não morre.

Estamos programando para reiniciá-lo. Mas queria tentar encerrar o processo sem precisar fazer o reboot do servidor.
Alguém que já passou por isso poderia me ajudar???


  


2. Re: Processo umount travado no centos e consumindo 100% de cpu

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 12/04/2018 - 15:54h

testeinfra escreveu:

Boa tarde pessoal.

Estou tendo problema ao tentar desmontar uma partição no CentOS.
Tenho um disco iscsi montado no meu servidor centos. Ele é utilizado apenas como área de backup de alguns arquivos. Entretanto recentemente ele me retornou um erro falando que o sistema de arquivos estava como somente leitura. Fui desmontar a partição para executar um fsck nela. Só que o processo do umount ficou travado e a partição não desmontou. Ele está consumindo muita cpu do servidor. Tentei de todas as formas com o kill e ele não morre.

Estamos programando para reiniciá-lo. Mas queria tentar encerrar o processo sem precisar fazer o reboot do servidor.
Alguém que já passou por isso poderia me ajudar???


velho .. tirando "pkill", "kill" e "killall" não vejo outra maneira de vc parar isso não a não ser um restart.

tem um tal de "fuser" mas nunca usei e nem sei se funciona >>> https://www.cyberciti.biz/tips/how-do-i-forcefully-unmount-a-disk-partition.html

------------------------------------------| Linux User #621728 |-----------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------| Linux User #621728 |-----------------------------------------



3. Re: Processo umount travado no centos e consumindo 100% de cpu

Teste Infra
testeinfra

(usa CentOS)

Enviado em 13/04/2018 - 11:17h

Já tentei de várias formas com o kill e seus similares, mas não adianta.
Vamos fazer um restart pra ver se resolve


4. Re: Processo umount travado no centos e consumindo 100% de cpu

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 13/04/2018 - 21:56h

consegue instalar pacote fuser nele e tentar com comando fuser?
ou tá parado, travado no umount?

https://www.vivaolinux.com.br/dica/O-comando-fuser
http://www.planetaunix.com.br/2016/03/comando-fuser-descobrir-processos-que.html
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.


5. Re: Processo umount travado no centos e consumindo 100% de cpu

Teste Infra
testeinfra

(usa CentOS)

Enviado em 16/04/2018 - 08:21h

Valeu pela ajuda.
Reiniciamos o servidor mesmo.


6. Re: Processo umount travado no centos e consumindo 100% de cpu

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 17/04/2018 - 20:22h

bom, pode marcar o tópico como Resolvido.
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.






Patrocínio

Site hospedado pelo provedor HostGator.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Viva o Android

Tópicos

Top 10 do mês

Scripts