CUPS não encontra impressora... Mas ele não é o problema aparentemente

1. CUPS não encontra impressora... Mas ele não é o problema aparentemente

Wilker Azevedo
cytron

(usa Slackware)

Enviado em 30/06/2020 - 20:28h

Uso uma Samsung ML-2010, que nunca tinha problema em ser detectada. Era plugar, rodar CUPS e usar. Mas num belo dia resolvi testar uma outra ML-2010, que também está 100%. Mas ela não foi detectada e pra piorar, quando voltei a minha... também não foi detectada. Acho que tinha espírito maligno na impressora que fui testar e acabou fazendo algo estranho no meu Linux kkkkkkk.

Como não mexi nas configurações, então não tem como eu ter feito algo errado. Só troquei de impressora e tentei imprimir, como não imprimiu, apaguei a instalada e tentei detectar. Só isso.

Já atualizei o kernel do 4 para 5 e nada...

Então vamos lá:

Slackware Current
Kernel 5.4.49
Cups 2.3.3
Cups-filters 1.27.5
pycups 2.0.1
Também tenho Foomatic para uma HP CP1215

O CUPS detecta HP normalmente... só Samsung que não.

Mas minha desconfiança está ao plugar a impressora na porta USB, veja o resultado do dmesg:


Jun 30 20:11:21 slackdev kernel: [177695.537230] usb 2-4: new full-speed USB device number 24 using xhci_hcd
Jun 30 20:11:21 slackdev kernel: [177695.666285] usb 2-4: New USB device found, idVendor=04e8, idProduct=326c, bcdDevice= 1.00
Jun 30 20:11:21 slackdev kernel: [177695.666288] usb 2-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jun 30 20:11:21 slackdev kernel: [177695.666290] usb 2-4: Product: Samsung ML-2010
Jun 30 20:11:21 slackdev kernel: [177695.666292] usb 2-4: Manufacturer: Samsung
Jun 30 20:11:21 slackdev kernel: [177695.666293] usb 2-4: SerialNumber: 3A99BKEPB16209W.
Jun 30 20:11:21 slackdev mtp-probe: checking bus 2, device 24: "/sys/devices/pci0000:00/0000:00:14.0/usb2/2-4"
Jun 30 20:11:21 slackdev mtp-probe: bus: 2, device: 24 was not an MTP device


Apesar da última linha dizer que não é um MTP, sei lá, o kernel vê o dispositivo sendo plugado, mas para o restante do sistema pode "não ser uma impressora".
Mas no lsusb está aparentemente normal, então nem mesmo o que eu desconfio faz sentido kkkk:

Bus 002 Device 024: ID 04e8:326c Samsung Electronics Co., Ltd ML-2010P Mono Laser Printer 


Mas para o CUPS é como se não tivesse nada conectado.

Não sei o que é mais confuso, o kernel ver a impressora normalmente mas o CUPS não.... ou procurar um drive da SAMSUNG e encontrar ele no site da HP kkkkkkk.

HELP !!!!


  


2. Re: CUPS não encontra impressora... Mas ele não é o problema aparentemente

Lucio M. Salles
LckLinux

(usa Arch Linux)

Enviado em 30/06/2020 - 21:15h

cytron escreveu:

Uso uma Samsung ML-2010, que nunca tinha problema em ser detectada. Era plugar, rodar CUPS e usar. Mas num belo dia resolvi testar uma outra ML-2010, que também está 100%. Mas ela não foi detectada e pra piorar, quando voltei a minha... também não foi detectada. Acho que tinha espírito maligno na impressora que fui testar e acabou fazendo algo estranho no meu Linux kkkkkkk.

Como não mexi nas configurações, então não tem como eu ter feito algo errado. Só troquei de impressora e tentei imprimir, como não imprimiu, apaguei a instalada e tentei detectar. Só isso.

Já atualizei o kernel do 4 para 5 e nada...

Então vamos lá:

Slackware Current
Kernel 5.4.49
Cups 2.3.3
Cups-filters 1.27.5
pycups 2.0.1
Também tenho Foomatic para uma HP CP1215

O CUPS detecta HP normalmente... só Samsung que não.

Mas minha desconfiança está ao plugar a impressora na porta USB, veja o resultado do dmesg:


Jun 30 20:11:21 slackdev kernel: [177695.537230] usb 2-4: new full-speed USB device number 24 using xhci_hcd
Jun 30 20:11:21 slackdev kernel: [177695.666285] usb 2-4: New USB device found, idVendor=04e8, idProduct=326c, bcdDevice= 1.00
Jun 30 20:11:21 slackdev kernel: [177695.666288] usb 2-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jun 30 20:11:21 slackdev kernel: [177695.666290] usb 2-4: Product: Samsung ML-2010
Jun 30 20:11:21 slackdev kernel: [177695.666292] usb 2-4: Manufacturer: Samsung
Jun 30 20:11:21 slackdev kernel: [177695.666293] usb 2-4: SerialNumber: 3A99BKEPB16209W.
Jun 30 20:11:21 slackdev mtp-probe: checking bus 2, device 24: "/sys/devices/pci0000:00/0000:00:14.0/usb2/2-4"
Jun 30 20:11:21 slackdev mtp-probe: bus: 2, device: 24 was not an MTP device


Apesar da última linha dizer que não é um MTP, sei lá, o kernel vê o dispositivo sendo plugado, mas para o restante do sistema pode "não ser uma impressora".
Mas no lsusb está aparentemente normal, então nem mesmo o que eu desconfio faz sentido kkkk:

Bus 002 Device 024: ID 04e8:326c Samsung Electronics Co., Ltd ML-2010P Mono Laser Printer 


Mas para o CUPS é como se não tivesse nada conectado.

Não sei o que é mais confuso, o kernel ver a impressora normalmente mas o CUPS não.... ou procurar um drive da SAMSUNG e encontrar ele no site da HP kkkkkkk.

HELP !!!!


Boa noite, camarada.
Estou aqui pensando na tua causa (uso um current também), pois passei por algo muito parecido, mas com uma HP Laser P 1100/ (tomei vários ippon's nesse episódio, que durou dois dias para eu resolver). Vou pensar aqui e se tiver uma ideia boa eu dou, ainda hoje.
(A minha HP Laser eu lembro que solucionei depois de muitas tentativas de instalar, desinstalar/atualizar um plugin)







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts