Não aparece nada quando compilo em c/c++ [RESOLVIDO]

1. Não aparece nada quando compilo em c/c++ [RESOLVIDO]

Marco André Santos Machado
Marco André

(usa Fedora)

Enviado em 08/02/2009 - 19:04h

Quando eu compilo um arquivo .c ou .cpp não aparece nada. Estou fazendo assim: gcc -o meu teste.c (ou teste.cpp). No terminal não aparece nenhum erro de compilação, mas tb não aparece o arquivo .o. Se eu utilizar uma IDE o arquivo .o até aparece, mas quando tento executá-lo aparece a mensagem "bash: ./teste.o: Permissão negada". Alguém pode me dizer o que está acontecendo?? Uso ubuntu 8.04


  


2. Re: Não aparece nada quando compilo em c/c++ [RESOLVIDO]

Carlos Eduardo Junges
carlosjunges

(usa Slackware)

Enviado em 08/02/2009 - 19:17h

Para poder executar o arquivo mude a permisão para: chmod a+x arquivo.c


3. Re: Não aparece nada quando compilo em c/c++ [RESOLVIDO]

Eduardo
edphp

(usa Debian)

Enviado em 08/02/2009 - 20:10h

Não sei se você digitou certo, tente digitar: "gcc teste.c -o teste", com isso irá ser criado um arquivo chamado teste com o código compilado, para executar ./teste, mas verifique antes se tem permição de execução com um "ls -la"


4. Re: Não aparece nada quando compilo em c/c++ [RESOLVIDO]

Marco André Santos Machado
Marco André

(usa Fedora)

Enviado em 08/02/2009 - 20:59h

Tentei usar aki, mas não funcionou nao. Pela linha de comando, o arquivo .o continua sem aparecer.


5. Re: Não aparece nada quando compilo em c/c++ [RESOLVIDO]

Gilmar Mesquita Soares
gms81

(usa Ubuntu)

Enviado em 08/02/2009 - 23:44h

gcc -o teste teste.c

nesse caso ele cria um exe com o nome teste.
entendeu?


6. Re: Não aparece nada quando compilo em c/c++ [RESOLVIDO]

Marco André Santos Machado
Marco André

(usa Fedora)

Enviado em 10/02/2009 - 15:53h

Consegui!!!
Vlw pela ajuda de todos!


7. OPA!

Gilmar Mesquita Soares
gms81

(usa Ubuntu)

Enviado em 10/02/2009 - 16:30h

Parabens,
só uma coisa,
Coloque a resolução aqui..
Assim ajuda outros usuarios
que buscam resolver o mesmo problema!!!

Obrigado, abraço!



8. OPA!

Gilmar Mesquita Soares
gms81

(usa Ubuntu)

Enviado em 10/02/2009 - 16:31h

Parabens,
só uma coisa,
Coloque a resolução aqui..
Assim ajuda outros usuarios
que buscam resolver o mesmo problema!!!

Obrigado, abraço!







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts