HELP! Não consigo instalar o bbtokentool-1.1.1-4 [RESOLVIDO]

1. HELP! Não consigo instalar o bbtokentool-1.1.1-4 [RESOLVIDO]

Thomas Weverton dos Santos Moura
twsm

(usa Ubuntu)

Enviado em 20/05/2015 - 15:08h

Boa tarde, estou tentando instalar o bbtookentool-1.1.1-4 no Ubuntu...
já descompactei o arquivo tar.gz, e os principais arquivos q tem dentro são o install e o README.

Pelo o que eu havia lido o README ele fornece informações da instalação... mas não consegui executar ("meu inglês não é bom")..

README:

================= How to Install ================
* You need login as root *
* Make sure that 'dkms', 'gcc', 'binutils', 'make' and the linux kernel headers for your running kernel are installed on your machine.
These packages are available on your distribution's installation CD/DVD.
Also, you can install them through the internet, eg:
run "yum install kernel-devel" (Fedora) or "apt-get install linux-headers-`uname -r`"(Ubuntu) COMMAND to install the kernel headers *
* To run the BBTokenTool,JRE >= 1.6.0 is required *

1. Run "install" in TERMINAL to install BB Token Admin Tool
eg: # bash /<path>/install

2. If you had installed it in your system before, you will get a prompt: "The BB Token Tool is exist,do you want to overwrite it? (yes/no)[yes]:", enter "yes" to overwrites or "no" to exit installation.

3. Finish installing

================ How to Run ================
* From shortcut in desktop(only root user is available).

* From applications start menu.Usually,the location is "Applications"->"Other"->"BBTokenTool".

* Run "watchsafe_bbtoken" in TERMINAL.
eg: # watchsafe_bbtoken

=============== How to Uninstall =================
* From applications start menu.Usually,the location is "Applications"->"Other"->"UninstallBBTokenTool".
* Run "/usr/lib/watchdata/bbtoken/tools/UninstallBBtoken" in TERMINAL.


  


2. MELHOR RESPOSTA

Gabriel Bassani Ribieiro
gbassanir

(usa Debian)

Enviado em 20/05/2015 - 20:00h

Boa noite,

OBS:
1- "#" --> significa usuário root, então você tem que acessar ele. Tipo: $ su -
2- Isso daqui é para atualizar sua versão do kernel e dependendo da sua distro você vai usar um desses comandos: #yum install kernel-devel --> (Fedora) ou #apt-get install linux-headers-`uname -r` --> Ubuntu
3- Ele requer o Java Runtime Environment maior ou igual à 1.6.0

Tente seguir esse tutorial...
http://www.talesam.org/blog/instalando-token-do-banco-do-brasil-em-kernel-3-15-ou-superior/

Att,

3. Tradução

Felipe
felipefv

(usa Debian)

Enviado em 20/05/2015 - 20:29h

Traduzindo (resumidamente):

1 - Você precisa se logar como root.
2 - Tenha certeza de que os pacotes dkms, gcc, binutils, make e o linux-kernel-headers do seu kernel ativo estão instalados e disponíveis. Caso você não os tenha, baixe-os via APT (apt-get install nome-do-pacote). Você também pode procurar pela central de aplicativos do Ubuntu.
3 - Instale o Java mais recente.
4 - Vá à pasta onde está o install do BB Token Admin Tool e execute-o.
5 - Se você já o tiver instalado, o procedimento de instalação irá pausar e perguntar se você deseja sobrescrever o anterior. Diga que sim.

Para rodar o aplicativo (terminal):
watchsafe_bbtoken



4. Re: HELP! Não consigo instalar o bbtokentool-1.1.1-4 [RESOLVIDO]

Thomas Weverton dos Santos Moura
twsm

(usa Ubuntu)

Enviado em 20/05/2015 - 21:40h


Consegui efetuar a instalação, o watchsafe_bbtoken executa, mas ainda continua com o "Erro ao preparar leitora: Nenhum cartão/token encontrado" na página do B.B.


5. ....

Gabriel Bassani Ribieiro
gbassanir

(usa Debian)

Enviado em 21/05/2015 - 01:08h

Boa noite,

Qual é a versão do seu kernel?

Verifica se executando o mesmo procedimento desse site você obtêm êxito.

http://www.talesam.org/blog/instalando-token-do-banco-do-brasil-em-kernel-3-15-ou-superior/

Att,


6. Re: HELP! Não consigo instalar o bbtokentool-1.1.1-4

Thomas Weverton dos Santos Moura
twsm

(usa Ubuntu)

Enviado em 21/05/2015 - 01:15h

gbassanir escreveu:

Boa noite,

Qual é a versão do seu kernel?

Verifica se executando o mesmo procedimento desse site você obtêm êxito.

http://www.talesam.org/blog/instalando-token-do-banco-do-brasil-em-kernel-3-15-ou-superior/

Att,




3.16.0-38-generic

Eu tentei fazer por esse modo ai mas não deu certo... prq essa versão do arquivo .deb é inferior a que eu instalei do arquivo tar.gz que vem no meu token. Eu consigo executar em root o watchsafe_bbtoken ai se o dispositivo está conectado ele aparece todas as minhas informações que já foram cadastradas... então creio que o dispositivo esteja funcionando... não será algum problema no mozila?


7. ....

Gabriel Bassani Ribieiro
gbassanir

(usa Debian)

Enviado em 21/05/2015 - 10:29h

Bom dia,

Testa em outro navegador... Verifique a versão do seu Java... Caso esteja utilizando o Google Chrome, leia toda essa página.

--> https://www.java.com/pt_BR/download/faq/chrome.xml#npapichrome

Att,


8. Re: HELP! Não consigo instalar o bbtokentool-1.1.1-4 [RESOLVIDO]

Thomas Weverton dos Santos Moura
twsm

(usa Ubuntu)

Enviado em 23/05/2015 - 18:57h


Então estou usando o mozila... Testei outros navegadores e eles tbm não carregam... o Java está funcionando normalmente... não sei o que faço... preciso do token prq vou viajar e meu note uso o ubuntu... não quero voltar pro windowns :S


9. ....

Gabriel Bassani Ribieiro
gbassanir

(usa Debian)

Enviado em 25/05/2015 - 09:49h

Bom dia,

Fica difícil dizer o que é, acreditando que tenha seguido a instrução de instalação corretamente.

Att,


10. Re: HELP! Não consigo instalar o bbtokentool-1.1.1-4 [RESOLVIDO]

Thomas Weverton dos Santos Moura
twsm

(usa Ubuntu)

Enviado em 25/05/2015 - 14:32h

Resolvi o problema... instalei uma maquina virtual do windows que incrivelmente só funciona pelo internet explorer... pelo mozilla, opera e google aparecem o mesmo problema.


11. ....

Gabriel Bassani Ribieiro
gbassanir

(usa Debian)

Enviado em 25/05/2015 - 18:28h

Estranho, muito estranho...

Se quiser colocar o post como resolvido, para caso alguém enfrente o mesmo problema que o seu... Mas não acho uma solução ter que instalar outro SO para utilizar somente um Token, vou continuar pesquisando.

Att,


12. tmpfs noexec

Renato
renato16

(usa Ubuntu)

Enviado em 05/09/2016 - 15:08h

Pessoal, gostaria de contribuir um pouco. No meu caso o que resolveu foi tirar o noexec do fstab no caso do tmp na RAM (tmpfs). Foi sem querer. Estava pra atualizar de 14.04 pra 16.04 e ao remontar o TMP sem noexec tudo funcionou. Espero que ajude. Abraços.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts