Desconexão dos ATAS [RESOLVIDO]

1. Desconexão dos ATAS [RESOLVIDO]

Caio Bussacarini
bussaca

(usa Debian)

Enviado em 08/03/2012 - 14:04h

Estou enfrentando um problema e se possível, gostaria de contar com a experiência, conhecimento e ajuda da comunidade.

Consultei alguns foruns e listas sobre asterisk, mas ninguém soube me orientar.

Atualmente tenho um servidor asterisk com:

- 2 interfaces de rede (eth1:rede interna - 192.168.13.0/24 e eth0:rede externa com acesso a internet junto a uma operadora VOIP)
- 1 placa GSM com 4 chips de celular (local)
- 1 placa de sincronismo para sinalização E1 (linha local da telefônica).

Para a eth1 eu utilizo aparelhos ATAs SP8000 da Linksys que autenticam os ramais dos funcionários pela faixa 192.168.13.0/24.

- chamadas interubanas eu utilizo a linha VOIP pela operadora
- chamadas locais e 0800 a linha E1 da telefônica
- chamadas para celulares a placa GSM

Problema enfrentado:
- Quando há queda do link junto a operadora VOIP, todos os meus atas se desconectam do asterisk (Peer 'XXXX' is now UNREACHABLE!) após dar o tempo de "Register Expires" configurado nos ATAS.

Testes realizados:
- se eu removo o gateway (route del default) do meu IP externo eth0 (apenas para perder a rota de saída da linha VOIP - simulando uma queda do link), os serviços locais (E1 e GSM) permanecem funcionais e os ATAS não desconectam independente do tempo que for.

- porém, se eu só retirar o cabo de rede da interface externa eth0, após 3 minutos, todos os ATAS se desconectam do meu servidor, sendo que os atas estão em outra interface...na eth1.

- e ainda...depois desses 3 minutos, estou sem o cabo de rede na interface eth0, e removo o gateway com o "route del default" do IP externo, os atas voltam a se comunicar com o servidor asterisk imediatamente, e, consequentemente acessam os serviços E1 e GSM.


Não consigo identificar o porquê, mas acredito que tenha a ver com rotas ip no linux, não?

Será que alguém teria uma sugestão pra mim, diante desta situação?
Desde já, agradeço a colaboração.


  


2. Re: Desconexão dos ATAS [RESOLVIDO]

Joao Israel Costa Viana
wakeup

(usa Debian)

Enviado em 21/03/2012 - 15:37h

Boa tarde,

Qual versão ou BOX com o Asterisk voce está utilizando e porque? Voce possui regras de IPTABLES? Roteamento via Kernel está ativado no net filter?


3. Re: Desconexão dos ATAS [RESOLVIDO]

Caio Bussacarini
bussaca

(usa Debian)

Enviado em 21/03/2012 - 16:31h

Boa tarde.

Colega, agradeço e muito o seu interesse em me ajudar.

Consegui solucionar o meu problema instalando o bind no meu servidor asterisk.

Nos atas eu configurei o DNS PRIMÁRIO com o endereço IP LOCAL do meu servidor asterisk e eles não se desconectaram mais.

Honestamente não entendi até agora a lógica de os atas se desconectarem...porque estão conectados na interface local do meu server...

Mas o importante é que deu certo.

Muito obrigado.


4. Desconexão dos ATAS [RESOLVIDO]

magnopeem_rj
magnopeem_rj

(usa Ubuntu)

Enviado em 21/05/2012 - 23:03h

Prezados colaboradores boa noite

desculpe relatar neste topico sei que esta como resolvido , mais tive esse problema tambem com um cliente mais fui consultar um colega de trabalho que e especializado em rede e ele me disse:

caro colega quando o coracao para de bombear sangue o corpo para .

eu nao entendi a filosofia dele , ate pensei que ele tava meio chapado sei la kkkk , mais depois que eu apanhei de gato morto kkk eu acho que entendi a filosofia dele :D

eu ativei o dhcp no servidor asterisk e o problema meramente sumil quando desconectava o link na eth0 (link voip externo)

meus atas e o restante continuava a funcionar ou seja tava faltando quem manda-se os ips para arede interna mais fica a e sei se vai servir como dica mais ta na mao :D






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts