Erro na autentificação no compartilhamento samba 4.8.3 com Centos7

1. Erro na autentificação no compartilhamento samba 4.8.3 com Centos7

Alexandre Coser Rodrigues
coserx

(usa CentOS)

Enviado em 31/07/2019 - 11:05h

Bom dia. Tenho um servidor Centos7 com samba 4.8.3, na qual o smb.conf esta configurado com 3 compartilhamento, sendo que uma pasta publica(ok) e duas com senha. não consigo acessar as pastas com as senhas cadastradas. Gostaria que me ajudassem a resolver essa questão e me informar algo que eu não esteja lembrando ou fazendo errado.
Segue conteúdo do arquivo smb.conf :

1 [global]
2 workgroup=continentalnet
3 server string=Centos
4 netbios name=vmcentos
5 security = user
6 map to guest = bad user
7 #dns proxy = no
8
9 [home]
10 comment = Home Directories
11 browseable = yes
12 create mask = 0700
13 directory mask = 0700
14 valid users = %S
15 writable = yes
16
17
18 [publica]
19 comment = Pasta Publica
20 path = /home/publica
21 writable = yes
22 browseable = yes
23 create mode = 0777
24 directory mode = 0777
25 public = yes
26
27 [suporte]
28 comment = Pasta Compras
29 path = /home/suporte
30 writable = yes
31 browseable = yes
32 create mode = 0770
33 directory mode = 0770
34 valid users = @admsuporte
35 public = no
36 valid users = @admlog
37 read list = suporte
38 write list = suporte
39 admin users = suporte
40
41
42 [log]
43 comment = Pasta Estoque
44 path = /home/log1
45 writable = yes
46 browseable = yes
47 create mode = 0770
48 directory mode = 0770
49 valid users = @admlog
50 read list = log1
51 write list = log1
52 admin users = log1
53 valid users = log1
54 public = no
55



  


2. Re: Erro na autentificação no compartilhamento samba 4.8.3 com Centos7

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 31/07/2019 - 11:26h

comece tirando os "valid users" duplicados ... coloque todos os usuários e grupos validos somente em 1 parametro "valid users" por compartilhamento




------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




3. Re: Erro na autentificação no compartilhamento samba 4.8.3 com Centos7

Alexandre Coser Rodrigues
coserx

(usa CentOS)

Enviado em 31/07/2019 - 11:38h

Fiz as alterações abaixo nos compartilhamentos e ainda não consegui passar.
30 [suporte]
31 comment = Pasta Compras
32 path = /home/suporte
33 writable = yes
34 browseable = yes
35 create mode = 0770
36 directory mode = 0770
37 valid users = @admsuporte
38 public = no
39
40
41 [log]
42 comment = Pasta Estoque
43 path = /home/log1
44 writable = yes
45 browseable = yes
46 create mode = 0770
47 directory mode = 0770
48 valid users = @admlog
49 public = no
50

Meu windows esta logado como domínio, faria alguma diferença .




4. Re: Erro na autentificação no compartilhamento samba 4.8.3 com Centos7

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 31/07/2019 - 11:48h

coserx escreveu:
Meu windows esta logado como domínio, faria alguma diferença .


o compartilhamento simples é por workgroup, se vc quiser usar domínio tem que configurar o samba para controlador de domínio.

faz o simples e v se funciona, tira o windows do domínio e põe no wokgroup setado no samba.

------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




5. Re: Erro na autentificação no compartilhamento samba 4.8.3 com Centos7

Alexandre Coser Rodrigues
coserx

(usa CentOS)

Enviado em 31/07/2019 - 15:05h

Boa tarde, coloquei minha maquina win7 local, fora do dominio e setei no samba o workgroup, mas ainda não consegui logar.

Foi criado o usuário no linux e também adicionado ao samba.
segue abaixo minha configuração atual.

1 [global]
2 workgroup=WORKGROUP
3 server string=Centos
4 netbios name=vmcentos
5 security = user
6 map to guest = bad user
7 passdb backend = smbpasswd
8 encrypt passwords = true
9 smb passwd file =/etc/samba/smbpasswd
10 dns proxy = no
11
12 [home]
13 comment = Home Directories
14 browseable = yes
15 create mask = 0700
16 directory mask = 0700
17 valid users = %S
18 writable = yes
19
20
21 [publica]
22 comment = Pasta Publica
23 path = /home/publica
24 writable = yes
25 browseable = yes
26 create mode = 0777
27 directory mode = 0777
28 public = yes
29
30 [suporte]
31 comment = Pasta Compras
32 path = /home/suporte
33 writable = yes
34 browseable = yes
35 create mode = 0770
36 directory mode = 0770
37 valid users = @admsuporte
38 public = no
39
40
41 [log]
42 comment = Pasta Estoque
43 path = /home/log1
44 writable = yes
45 browseable = yes
46 create mode = 0770
47 directory mode = 0770
48 valid users = @admlog
49 public = no
50
~







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts