Xorg: Monitor não detectado [RESOLVIDO]

1. Xorg: Monitor não detectado [RESOLVIDO]

Marcos Ramos
marcos.ramos

(usa Ubuntu)

Enviado em 09/12/2008 - 18:50h

Acabei de instalar o arch no meu pc novo, o chipset de vídeo é um daqueles intel GMA945. Rodei um hwd -xa e ele diz ok, mas mando um startx e ele não acha o monitor. Rodei um hwd -x e ele diz ok tbm, mudei o xorg.conf para o que use o driver vesa mas o startx continua com problema -.-

o driver que eu instalei foi o xf86-video-intel, segundo a especificação do hwd -e (driver i810)

já havia instalado o arch sem problemas num celerdão 2.5 com 256 ram, até instalei kde 4.1 nele, era uma placa S3 ProSavage 32MB

por acaso alguém poderia me ajudar?


  


2. Re: Xorg: Monitor não detectado [RESOLVIDO]

Vinicus S Moraes
vsmoraes

(usa Arch Linux)

Enviado em 09/12/2008 - 19:29h

Tem que desabilitar o evdev para que funcione, o novo Xorg ignora algumas coisas do xorg.conf.
Dê uma lida em: http://wiki.archlinux.org/index.php/Xorg_input_hotplugging


3. Re: Xorg: Monitor não detectado [RESOLVIDO]

Marcos Ramos
marcos.ramos

(usa Ubuntu)

Enviado em 09/12/2008 - 19:48h

o que eu vi aqui é que um comando p/ ver se o evdev tá ativado, mas nada pra desativá-lo. No caso eu teria que editar meu xorg.conf? e como ficaria pra desativar isso aí?


4. Re: Xorg: Monitor não detectado [RESOLVIDO]

Avena
avena

(usa Debian)

Enviado em 09/12/2008 - 20:37h

veja se você colocou o i810 na parte de Devices certo do xorg.conf

para desligar o que colega falou...coloca no xorg.conf


Section "ServerFlags"
Option "AutoAddDevices" "False"
EndSection



5. Re: Xorg: Monitor não detectado [RESOLVIDO]

Jaime Ribeiro Junior
jaimejr1987

(usa Debian)

Enviado em 10/12/2008 - 02:24h

voce já verificou se o modulo do monitor esta ativo.


6. Re: Xorg: Monitor não detectado [RESOLVIDO]

Marcos Ramos
marcos.ramos

(usa Ubuntu)

Enviado em 10/12/2008 - 08:02h

os drivers estão certos, i810 mesmo, e o monitor tbm, tudo adicionado certinho.

só uma dúvida: desativando o evdev, eu não estaria desativando dispositivos de entrada? e o monitor não é uma saída?

ps: mudei a frequencia do meu monitor. com o driver vesa o X funciona, com o i810 não...

-.-

ps: Option "AutoAddDevices" "False" << o hwd já tinha configurado desse jeito


7. Re: Xorg: Monitor não detectado [RESOLVIDO]

Marcos Ramos
marcos.ramos

(usa Ubuntu)

Enviado em 10/12/2008 - 18:27h

resolvido:

com o novo xorg, tive que mudar o driver de i810 para intel ;)