Placa de vídeo "nvidia geforce fx5200" no Arch Linux ? [RESOLVIDO]

1. Placa de vídeo "nvidia geforce fx5200" no Arch Linux ? [RESOLVIDO]

Glauber GF
mcnd2

(usa Debian)

Enviado em 07/09/2010 - 12:08h

Bom dia.

Vou logo ao assunto pois já não estou conseguindo raciocinar direito pois tá f... de resolver.

Bem instalai o Arch Linux (2009.08) numa partição que tenho em um HD de teste em meu PC. Até ai tudo bem. Logo veio o problema de fazer a devida atualização do sistema, como tenho internet via rádio e preciso logar no servidor com usuário e senha tive que executar essa atualização rodando um live cd e montando a partição do arch como raiz com o comando "chroot". Atualização rodou perfeitamente. Próximo passo que fiz vou de instalar o navegador em modo texto o "lynx" para poder me autenticar no servidor de minha internet quando estiver rodando o Arch diretamente.

Quando iniciado o Arch, executei o lynx e me autentiquei. Pronto conexão estabelecida. Instalei o "xorg" e o "gnome" mais não funfou. Tenho uma placa da nvidia (geforce fx5200) que tentei instalar com o comando "pacman -S nvidia nvidia-utils", mais nada de subir a parte gráfica. Então notei que para minha placa de vídeo o driver é "nvidia-173xxx" e "nvidia-utils-173xxx" mais quando executo ele me retornar o error:

# pacman -S nvidia-173xxx
error: 'nvidia-173xxx': could not find or read package
#

Então não sei mais o que devo fazer.

Vou deixar o arquivo do "/var/log/Xorg.0.log" abaixo para devida ajuda.

-----------------------------------------------------------------------

[ 474.330]
This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage">http://wiki.x.org/wiki/GitPage for git access instructions.
[ 474.333]
X.Org X Server 1.8.1.902 (1.8.2 RC 2)
Release Date: 2010-06-21
[ 474.334] X Protocol Version 11, Revision 0
[ 474.334] Build Operating System: Linux 2.6.34-ARCH i686
[ 474.335] Current Operating System: Linux arch 2.6.35-ARCH #1 SMP PREEMPT Fri Aug 27 16:22:18 UTC 2010 i686
[ 474.335] Kernel command line: root=/dev/disk/by-uuid/54ad3999-f880-44f9-8138-13ab71ca6d2e ro
[ 474.336] Build Date: 21 June 2010 11:54:27AM
[ 474.336]
[ 474.352] Current version of pixman: 0.18.4
[ 474.352] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 474.353] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 474.355] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Sep 7 11:36:53 2010
[ 474.355] (II) Loader magic: 0x81e9d00
[ 474.355] (II) Module ABI versions:
[ 474.355] X.Org ANSI C Emulation: 0.4
[ 474.355] X.Org Video Driver: 7.0
[ 474.355] X.Org XInput driver : 9.0
[ 474.355] X.Org Server Extension : 3.0
[ 474.375] (--) PCI:*(0:1:0:0) 10de:0322:1682:203c nVidia Corporation NV34 [GeForce FX 5200] rev 161, Mem @ 0xfb000000/16777216, 0xe0000000/268435456, BIOS @ 0x????????/131072
[ 474.388] List of video drivers:
[ 474.388] nvidia
[ 474.389] vesa
[ 474.389] (II) LoadModule: "nvidia"
[ 474.397] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[ 474.451] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 474.451] compiled for 4.0.2, module version = 1.0.0
[ 474.451] Module class: X.Org Video Driver
[ 474.501] (EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
[ 474.502] (EE) NVIDIA: system's kernel log for additional error messages.
[ 474.502] (II) UnloadModule: "nvidia"
[ 474.502] (II) Unloading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[ 474.502] (EE) Failed to load module "nvidia" (module-specific error, 0)
[ 474.503] (II) LoadModule: "vesa"
[ 474.503] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[ 474.503] (II) Module vesa: vendor="X.Org Foundation"
[ 474.503] compiled for 1.8.0, module version = 2.3.0
[ 474.503] Module class: X.Org Video Driver
[ 474.503] ABI class: X.Org Video Driver, version 7.0
[ 474.503] (II) Primary Device is: PCI 01@00:00:0
[ 474.503] (II) VESA: driver for VESA chipsets: vesa
[ 474.514] (++) Using config file: "/root/xorg.conf.new"
[ 474.515] (==) Using config directory: "/etc/X11/xorg.conf.d"
[ 474.526] (==) ServerLayout "X.org Configured"
[ 474.526] (**) |-->Screen "Screen0" (0)
[ 474.526] (**) | |-->Monitor "Monitor0"
[ 474.526] (**) | |-->Device "Card0"
[ 474.526] (**) |-->Input Device "Mouse0"
[ 474.526] (**) |-->Input Device "Keyboard0"
[ 474.526] (==) Automatically adding devices
[ 474.526] (==) Automatically enabling devices
[ 474.526] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[ 474.526] Entry deleted from font path.
[ 474.526] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[ 474.526] Entry deleted from font path.
[ 474.526] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[ 474.526] Entry deleted from font path.
[ 474.526] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[ 474.526] Entry deleted from font path.
[ 474.526] (**) FontPath set to:
/usr/share/fonts/misc/,
/usr/share/fonts/TTF/,
/usr/share/fonts/100dpi/,
/usr/share/fonts/75dpi/,
/usr/share/fonts/misc/,
/usr/share/fonts/TTF/,
/usr/share/fonts/100dpi/,
/usr/share/fonts/75dpi/
[ 474.526] (**) ModulePath set to "/usr/lib/xorg/modules"
[ 474.526] (WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[ 474.526] (WW) Disabling Mouse0
[ 474.526] (WW) Disabling Keyboard0
[ 474.530]
[ 474.530]
Xorg detected your mouse at device /dev/input/mice.
Please check your config if the mouse is still not
operational, as by default Xorg tries to autodetect
the protocol.
[ 474.533]
Your xorg.conf file is /root/xorg.conf.new

[ 474.534] To test the server, run 'X -config /root/xorg.conf.new'

-------------------------------------------------------------------------

Desde já agradeço pela atenção.


  


2. MELHOR RESPOSTA

Perfil removido
removido

(usa Nenhuma)

Enviado em 07/09/2010 - 17:49h

isso é muito simples:

se você tem uma outra distro instalada e já instalou o driver com:

# pacman -S nvidia-173xx nvidia-173xx-utils

Basta copiar o xorg.conf dessa distro e substituir o do Arch (eu uso o mesmo no Debian e no Arch).

O outro modo é:

# nvidia-xconfig -A

# nvidia-xconfig --add-argb-glx-visuals \
--allow-glx-with-composite --composite \
--no-logo --nvagp=1 --render-accel \
-o /etc/X11/xorg.conf

e na seção 'Screen' inserir os modos que sua placa/monitor suportam, exemplo:

Section "Screen"
Identifier "Screen 0"
Monitor "Monitor 0"
DefaultColorDepth 24
Option "CursorShadow" "1"
Option "CursorShadowAlpha" "63"
Option "CursorShadowYOffset" "2"
Option "CursorShadowXOffset" "4"
Option "FlatPanelProperties" "Scaling = native"
Option "NoLogo" "True"
Option "UseEDID" "True"
Option "RenderAccel" "True"
Option "AllowGLXWithComposite" "True"
Option "AddARGBGLXVisuals" "True"
Option "NvAGP" "1"
SubSection "Display"
Depth 8
Modes "1440x900" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1440x900" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1440x900" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1440x900" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

* a resolução recomendável para o meu monitor é 1440x900, para minha placa de vídeo, uma Geforce 9400GT nem sei.

Na dúvida rode o comando abaixo para saber a resolução máxima pro seu monitor:

$ xrandr

3. Re: Placa de vídeo "nvidia geforce fx5200" no Arch Linux ? [RESOLVIDO]

Phillipe Smith
Smithux

(usa Arch Linux)

Enviado em 07/09/2010 - 12:13h

Meu brother... seguinte.
Toda vez que tu for instalar um pacote no Arch e não der certo ou se você não souber ao certo qual o nome do pacote, faça o comando: pacman -Ss nome_do_pacote

Quase você acertou... O nome certo do pacote é nvidia-173xx e nvidia-173xx-utils.


4. smithux...

Glauber GF
mcnd2

(usa Debian)

Enviado em 07/09/2010 - 13:52h

Deu certo.

O erro era um "x" a mais, rsrsrs... falta de atenção.

Mais valeu por me abrir os olhos.

Agora vou pra configuração em deixar o "X" iniciar automaticamente.

Obrigado pela ajuda.


5. Placa de vídeo "nvidia geforce fx5200" no Arch Linux ?

Edwal F. Paiva Filho
nicolo

(usa Ubuntu)

Enviado em 07/09/2010 - 14:28h

A primeira alternativa é desinstalar o driver velho e instalar o driver novo do fabricante:
http://www.nvidia.com.br/object/linux_display_ia32_185.18.36.html

Precisa ter o xorg instalado .

No Ubuntu tem funcionado sempre a última versão mas a minha placa é 6100 (nvidia).
Seria prudente instalar o xorg estável e não a versão experimental.
Espero ter ajudado





6. nicolo...

Glauber GF
mcnd2

(usa Debian)

Enviado em 07/09/2010 - 17:25h

Já esta resolvido a questão da placa de video.

No momento desta estou no ambiente gnome mas o grande problema que eu estou encontrando agora é em deixar a resolução de video em 1024x768, pois a atual esta em 640x480.

Estou fazendo certas configurações mais até agora nada.


7. edps...

Glauber GF
mcnd2

(usa Debian)

Enviado em 07/09/2010 - 19:11h

Obrigado pela dica.

Eu até já fiz isso mais como estou acabando de baixar um programa, não dar para rebootar.

Mais já retorno com o resultado.

EDIT ------------------------------------------

Depois de copiado o "xor.conf" do Debian Lenny 5.0.6 funfano numa boa com a placa de video da nvidia geforce fx5200 e o compiz-fusion instalados, iniciei o Arch e pela surpresa tudo ocorreu numa boa.

Porque não tinha pensado nisso antes, kkkkk...

Obrigado mais uma vez aos amigos que me ajudaram.

Quem não mexe não aprende.

Assim ficou o "xorg.conf" do Arch:

---------------------------------------------
Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "abnt2"
Option "XkbLayout" "br"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 51.0
VertRefresh 43.0 - 60.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
Option "Coolbits" "1"
Option "AddARGBGLXVisuals" "true"
Option "TripleBuffer" "false"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection


Section "Extensions"
Option "Composite" "enable"
# Option "RENDER" "disable"
EndSection

---------------------------------------------






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts