Não consigo atualizar meu Arch

1. Não consigo atualizar meu Arch

Sandro Souza
novatterra

(usa Arch Linux)

Enviado em 22/01/2020 - 16:16h

sempre que tento rodar pacman -Syu recebo esse erro, alguem sabe me dizer como rezolvo isso, por favor?

https://imgur.com/7gs9V8e 


obrigado desde ja a quem me der alguma dica


  


2. Re: Não consigo atualizar meu Arch

niquelnausea
niquelnausea

(usa Arch Linux)

Enviado em 22/01/2020 - 17:36h

primeiramente, você precisa realmente de todos esses repositórios não oficiais? se sim, sabe se eles são mantidos ativamente, qual o conteúdo de cada um?

desinstala os aplicativos problemáticos e reinstala depois, infelizmente como esta usando pacotes e repositórios externos, terá que também resolver ou ajustar as dependências manualmente. comece pelos pacotes ffmpeg2.8 e xorgproto, lembre-se que com certeza esses pacotes terão mais dependências que podem ter mais dependências (talvez ate cíclicas) que você precisara remover antes de atualizar tudo.
uma opção para ver os problemas é usar a opção somente download (pacman -Syuw) e analisar os pacotes, ou esperar alguns dias para que os proprietários destes repositórios ajustem os pacotes problemáticos com as dependências e versões dos repositórios oficiais.
não use a opção de forçar a atualização (-d ou -dd).


3. Re: Não consigo atualizar meu Arch

Izaias
izaias

(usa LMDE)

Enviado em 22/01/2020 - 17:38h

novatterra escreveu:

sempre que tento rodar pacman -Syu recebo esse erro, alguem sabe me dizer como rezolvo isso, por favor?

https://imgur.com/7gs9V8e 


obrigado desde ja a quem me der alguma dica


Remova o pacote ffmpeg2.8 e atualize, veja se o erro persiste.


4. Re: Não consigo atualizar meu Arch

Sandro Souza
novatterra

(usa Arch Linux)

Enviado em 27/01/2020 - 14:47h

oi pessoal, eu de novo
(rsrsrs)

removi alguns repositorios mas o prblema persiste e eu nao sei o que fazer
to quase formatando tudo e recomeçando do zero :-(

https://imgur.com/zx3uGWS 


obrigado pela paciencia
faz tempo q nao instalo o arch entao as vezes me esqueço algumas tecnicas de concertar problemas sem precisar reinstalar tudo do zero



==================================================
Inteligência é a habilidade de evitar fazer o trabalho, e mesmo assim conseguir ter o trabalho realizado. (Linus Torvalds)


5. Re: Não consigo atualizar meu Arch

Perfil removido
removido

(usa Nenhuma)

Enviado em 27/01/2020 - 16:59h

Retire aqueles repositório do archlinux.fir do yaourt pq ele não é mais bom..
Também, a não ser que vc tenha uma demanda muito especial, não é bom deixar o multilib habilitado.

Quando vc está fazendo a atualização, ele pergunta 3 vezes se deseja substituir pacotes. Você deve responder SIM.

O Compton está sem manutenção então surgiu um fork dele agora chamado de Picom e só esse que tem nos repos oficiais mesmo.



6. Re: Não consigo atualizar meu Arch

Sandro Souza
novatterra

(usa Arch Linux)

Enviado em 27/01/2020 - 18:04h


fiz o que vc sugeriu mano, mas ele continua travado ,sem atualizar

https://imgur.com/dW3m16O 


poxa, não quero recomeçar tudo do zero!
==================================================
Inteligência é a habilidade de evitar fazer o trabalho, e mesmo assim conseguir ter o trabalho realizado. (Linus Torvalds)


7. Re: Não consigo atualizar meu Arch

Perfil removido
removido

(usa Nenhuma)

Enviado em 27/01/2020 - 18:15h

Remova esse mmpeg2.8 e depois, se der a atualização e você precisar dele, instale novamente.

$ sudo pacman -Rns ffmpeg2.8 

Se der algum aviso e vc não conseguir desinstalá-lo, avisa ae e manda a mensagem de saída..

-Rns remove todas as deps que não são utilizadas por outros pacotes.

Muito estranho, pq o pacote que tem nos repos oficiais não é ffmpeg2.8, é somente 'ffmpeg':
extra/ffmpeg 1:4.2.2-1

Esse pacote vc deve ter instalado com algum daqueles outros repos que estavam ativados, ou do AUR..

Mas não é bom usar pacotes do AUR..



8. Re: Não consigo atualizar meu Arch

Sandro Souza
novatterra

(usa Arch Linux)

Enviado em 27/01/2020 - 18:50h


eu tentei mas deu essa saida:

[email protected] /m/pendrive> sudo pacman -Rns ffmpeg2.8 
[sudo] senha para sandro:
verificando dependências...
erro: falha ao preparar a transação (não foi possível satisfazer as dependências)
:: a remoção de ffmpeg2.8 quebra a dependência "ffmpeg2.8" necessária por 4kslideshowmaker
[email protected] /m/pendrive>

==================================================
Inteligência é a habilidade de evitar fazer o trabalho, e mesmo assim conseguir ter o trabalho realizado. (Linus Torvalds)


9. Re: Não consigo atualizar meu Arch

Perfil removido
removido

(usa Nenhuma)

Enviado em 27/01/2020 - 18:58h

Eu pensei que isso poderia ocorrer sim...

Bom, aqui você tem duas alternativas.

Primeira, remover o '4kslideshowmaker', e depois da atualização, se vc quiser pegar ele do AUR de novo, OK.

$ sudo pacman -Rns ffmpeg2.8 4kslideshowmaker 


Na verdade, tem uma outra alternativa mas é arriscada por que você vai incorrer em um update parcial temporariamente..

Somente se você for a fundo para ver quando foi a última vez que tu sincronizou o sistema inteiro da última vez, (fazer o download do pacote 'ffmpeg' do Arch Linux Archieve da mesma data da sua ultima sincronização), poderia instalar o 'ffgmpeg', e nessa ocasião o pacman iria perguntar se deseja substituir 'ffmpeg2.8' por 'ffmpeg', e você diria que sim.. E isso *supondo* que na época da sua última atualização havia o pacote 'ffmpeg' nos repos oficiais do Arch e que isso não tenha sido há mais de +-1 ano (pq os snapshots mais antigos do ALA vão sendo excluídos..) ou não tenha um pacote ffmpeg em cache localmente..

Se você simplesmente tentar instalar o 'ffmpeg' do servidor espelho atualizado, pode ser que o pacman não consiga instalar o 'ffmpeg'.

Portanto, remover '4kslideshowmaker' é a melhor opção.


10. Re: Não consigo atualizar meu Arch

Sandro Souza
novatterra

(usa Arch Linux)

Enviado em 29/01/2020 - 15:33h

oi mano, boa tARDE,

Então cara

eu removi o dito cujo, mas o que tá me tirando o sono são aquelas perguntinhas de substituição, as 3 primeiras tá ok, eu respondo sim e ele segue, mas nas ultimas, sendo sim ou sendo não ele sempre empaca, queria saber quais pacotes tirar ou acrescentar pra rezolver esses conflitos

da uma zoiada:

 Deseja remover estes pacotes? [S/n] s
:: Processando alterações do pacote...
(1/6) removendo 4kslideshowmaker [####################################################] 100%
(2/6) removendo qt5-quickcontrols [####################################################] 100%
(3/6) removendo libjpeg9 [####################################################] 100%
(4/6) removendo ffmpeg2.8 [####################################################] 100%
(5/6) removendo schroedinger [####################################################] 100%
(6/6) removendo dcadec [####################################################] 100%
:: Executando hooks pós-transação...
(1/2) Arming ConditionNeedsUpdate...
(2/2) Updating the desktop file MIME type cache...
[email protected] ~> sudo pacman -Syu
:: Sincronizando a base de dados de pacotes...
core 133,3 KiB 438 KiB/s 00:00 [####################################################] 100%
extra 1643,0 KiB 3,49 MiB/s 00:00 [####################################################] 100%
community 4,8 MiB 2,92 MiB/s 00:02 [####################################################] 100%
:: Iniciando atualização completa do sistema...
:: Substituir compton por community/picom? [S/n] s
:: Substituir pygobject2-devel por extra/python2-gobject2? [S/n] s
:: Substituir totem-plparser por extra/totem-pl-parser? [S/n] s
resolvendo dependências...
procurando pacotes conflitantes...
:: python2-pyqt5 e pyqt5-common estão em conflito. Remover pyqt5-common? [s/N] s
:: python2-pyqtwebengine e pyqtwebengine-common estão em conflito. Remover pyqtwebengine-common? [s/N] s
erro: falha ao preparar a transação (não foi possível satisfazer as dependências)
:: a instalação de xorgproto (2019.2-2) quebra a dependência "dmxproto" necessária por libdmx
:: a instalação de xorgproto (2019.2-2) quebra a dependência "xf86dgaproto" necessária por libxxf86dga
[email protected] ~>


é aí que o bixo pega, to penaando em refazer tudo do zero mesmo, mas só de pensar na trabalheira ue levei pra chegar ate aqui.....

==================================================
Inteligência é a habilidade de evitar fazer o trabalho, e mesmo assim conseguir ter o trabalho realizado. (Linus Torvalds)


11. Re: Não consigo atualizar meu Arch

Perfil removido
removido

(usa Nenhuma)

Enviado em 29/01/2020 - 18:06h

Isso aí pelo que vc está passando se chama o 'inferno das dependências -- dependency hell..

Eu estou olhando aqui, e tudo isso está ocorrendo pq vc instalou um monte de pacotes do AUR. E vc devia saber que pacotes do AUR são muito problemáticos.

Neste caso, você deve primeiro desinstalar os pacotes que estão com problemas de deps que fala lá.

# pacman -Rns libdmx libxxf86dga

E vai removendo o que mais ele for falando que está conflitante até a atualização prosseguir..

Quando foi a última vez que tu atualizou?






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts