pacotes conflitantes na instalação de ferramentas.

1. pacotes conflitantes na instalação de ferramentas.

matheus teixeira
Morphine

(usa Outra)

Enviado em 19/01/2017 - 14:48h

Olá vem pedir ajuda de vocês pois estou com um problemas ao instalar uma ferramenta no archlinux que mesmo com as dependências dessa instaladas a ferramenta reporta que a dependência não esta instalada.

print: http://imgur.com/a/HGqNC

erro:
[[email protected] ~]$ sudo pacman -S metasploit
[sudo] senha para morphine:
resolvendo dependências...
atenção: não é possível resolver "ruby<2.4", uma dependência de "metasploit"
:: O seguinte pacote não pode ser atualizado devido a dependências não resolvidas:
metasploit

:: Deseja ignorar o pacote acima para esta atualização? [s/N] n
erro: falha ao preparar a transação (não foi possível satisfazer as dependências)
:: metasploit: requer ruby<2.4
[[email protected] ~]$

está dando esse erro mesmo com o ruby2.4 já instalado.

agradecido por qualquer ajuda.





  


2. Re: pacotes conflitantes na instalação de ferramentas.

Lui
drizze

(usa Linux Mint)

Enviado em 19/01/2017 - 15:18h

Ele não espera ruby menor que 2.4?
ruby<2.4 



3. Re: pacotes conflitantes na instalação de ferramentas.

matheus teixeira
Morphine

(usa Outra)

Enviado em 19/01/2017 - 15:41h

drizze escreveu:

Ele não espera ruby menor que 2.4?
ruby<2.4 



Desinstalei o 2.4 e instalei versões mais antigas e continua pedindo o ruby 2.4.







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts