Estou com erro com o Pulseaudio [RESOLVIDO]

1. Estou com erro com o Pulseaudio [RESOLVIDO]

Ghoost User
ghoostuser

(usa Arch Linux)

Enviado em 13/10/2015 - 04:10h

Gente, seguinte...eu ja instalei, reinstalei o pulseaudio e o mesmo esta dando problema de reconhecimento no Arch Linux. Tipo, o Skype usa pulseaudio, e não esta funcionando, não aparece no Skype para selecionar o pulseaudio, antes aparecia.
Quando executo o comando para o pulseaudio tornar-se um daemon, olha o que aparece

[gabriel@archlinux ~]$ pulseaudio -D
E: [pulseaudio] main.c: Falha na partida do daemon.
[gabriel@archlinux ~]$


Instalei e reinstalei os seguintes pacotes:

# pacman -S pulseaudio pulseaudio-alsa


Instalei todos os pacotes do Gstreamer. O meu audio pega de boa, funciona o som, porem preciso do pulse audio para usar em video com Skype. Ja reiniciei a maquina mais nada.

Olha meus modulos:

[gabriel@archlinux ~]$ lsmod | grep '^snd'
snd_pcm_oss 45056 0
snd_mixer_oss 24576 1 snd_pcm_oss
snd_hda_codec_hdmi 49152 1
snd_hda_codec_conexant 24576 1
snd_hda_codec_generic 69632 1 snd_hda_codec_conexant
snd_hda_intel 32768 1
snd_hda_codec 106496 4 snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_hda_codec_generic,snd_hda_intel
snd_hda_core 49152 5 snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
snd_hwdep 16384 1 snd_hda_codec
snd_pcm 86016 5 snd_pcm_oss,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_core
snd_seq_dummy 16384 0
snd_seq_oss 36864 0
snd_seq_midi_event 16384 1 snd_seq_oss
snd_seq 61440 5 snd_seq_midi_event,snd_seq_oss,snd_seq_dummy
snd_seq_device 16384 2 snd_seq,snd_seq_oss
snd_timer 28672 2 snd_pcm,snd_seq
snd 65536 15 snd_pcm_oss,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_pcm,snd_seq,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,snd_seq_oss,snd_seq_device,snd_mixer_oss
[gabriel@archlinux ~]$


Instalei tambem o "pavucontrol" e quando fui abrir o programa "Controle de volume do Pulseaudio" o programa fica com a seguinte mensagem (e não sai dela): Establishing connection to PulseAudio. Please wait....

Outro teste que fiz tambem foi tentar executar uma arquivo de som com o pulseaudio, mais deu erro tambem:


pacmd play-sample test.mp3
Nenhum daemon do PulseAudio em execução ou não está em execução como daemon de sessão.


Alguem pode me ajudar?

Grato :/


  


2. Re: Estou com erro com o Pulseaudio

Eric
Grinder

(usa Slackware)

Enviado em 13/10/2015 - 04:40h

Quando o som funciona e no Skype não, geralmente são problemas devido de não ter o pacote pulseaudio e dependências em 32bits.


3. Re: Estou com erro com o Pulseaudio

Ghoost User
ghoostuser

(usa Arch Linux)

Enviado em 13/10/2015 - 07:10h

Grinder escreveu:

Quando o som funciona e no Skype não, geralmente são problemas devido de não ter o pacote pulseaudio e dependências em 32bits.


Oi, bom dia.
humm, será que é isso? eu instalei o pulseaudio em x86_64 porque o arch linux é 64 bits.
mas eu ja tinha instalado o pulseaudio no arch linux 64 bits e não tinha esse problema.
agora instalei o Arch novamente e esta dando esse problema. :/


4. Re: Estou com erro com o Pulseaudio

Eris Ribeiro Junior
erisrjr

(usa Arch Linux)

Enviado em 13/10/2015 - 19:51h

gabrielscorpion escreveu:

Grinder escreveu:

Quando o som funciona e no Skype não, geralmente são problemas devido de não ter o pacote pulseaudio e dependências em 32bits.


Oi, bom dia.
humm, será que é isso? eu instalei o pulseaudio em x86_64 porque o arch linux é 64 bits.
mas eu ja tinha instalado o pulseaudio no arch linux 64 bits e não tinha esse problema.
agora instalei o Arch novamente e esta dando esse problema. :/


Precisa habilitar o multilib (Ele é 32bits), de uma olhada nas dependências:



pacman -Qi skype
Nome : skype
Versão : 4.3.0.37-3
Descrição : P2P software for high-quality voice communication
Arquitetura : x86_64
URL : http://www.skype.com/
Licenças : custom
Grupos : Nenhum
Provê : Nenhum
Depende de : xdg-utils hicolor-icon-theme lib32-libpulse lib32-qt4 lib32-libxss lib32-libxv lib32-libxcursor lib32-v4l-utils

Depend. opcionais : pulseaudio: audio support/voice chatting
lib32-libcanberra: XDG sound support




*Também pode usar o apulse, caso tenha algo contra o pulseaudio.

https://wiki.archlinux.org/index.php/Skype#Skype_sound

https://wiki.archlinux.org/index.php/Multilib

------------------------------------------------------
KISS principle, RTFM and STFW = 42


5. Re: Estou com erro com o Pulseaudio [RESOLVIDO]

Ghoost User
ghoostuser

(usa Arch Linux)

Enviado em 14/10/2015 - 00:14h

Consegui resolver. (O repo multilib ja tava habilitado, não era o problema).
Engraçado, era problema no usuario. criei outro usuario e iniciei o skype e o problema foi resolvido.
Ai fiz uma "faxina" no .config, do usuario que estava com problema, mais o problema persistiu, só consegui resolver mesmo deletando o usuario e criando ele de novo. estranho.
Obrigado a todos por responder.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts