Downgrade para Xorg 1.17

1. Downgrade para Xorg 1.17

Patrick Costa da Silva
patrickpcs

(usa Nenhuma)

Enviado em 25/06/2016 - 12:09h

Em referência ao tópico https://www.vivaolinux.com.br/topico/Off-Code-Cafe/arch-linux-3
Consegui o básico. Muito obrigado pelo apoio Spylinux.


Meu sistema funcionou legal...
Mesa...intel....Xorg1.18....gdm... Gnome....
Loguei, pintei e bordei no gnome-shell...maravilha :)


Meu problema agora está sendo com os drivers da NVIDIA e o Xorg 1.18...

Entretanto até na wiki está falando que o driver proprietário não funciona corretamente com o xorg 1.18.
https://wiki.archlinux.org/index.php/NVIDIA#Configuration
Eu segui as recomendações, a princípio seria apenas instalar com o pacman -S nvidia nvidia-libgl conforme diz a wiki que deve funcionar na maioria dos casos, mas no meu não funcionou. Tentei configurar com o nvidia-xconfig, ele até cria o xorg.conf, mas não funciona também. Fiz as configurações manualmente também até me deparar com o aviso na wiki que o xorg 1.18 não funciona corretamente.

Achei em vários fóruns que muitos realizaram o downgrade para o xorg1.17 e deu certo, mas ninguém fala como fazer esse downgrade.

Tenho pouco ou nenhuma experiência com o Pacman ... alguém sabe como posso realizar esse downgrade?
Achei alguns vídeos, mas diziam ser especificamente para os drivers da AMD/ATI... então nem testei.

Meu notebook é híbrido ...Intel + NVIDIA .

http://goo.gl/g6NiFp


  


2. Também

Jean Carlos
j.c.o.s

(usa Linux Mint)

Enviado em 11/08/2016 - 18:07h

estou pesquisando a respeito amigo, pois estou no linux mint 18 e o xorg 1.18 não aceita meu driver AMD...to querendo fazer essa downgrade...


3. Re: Downgrade para Xorg 1.17

Ricardo Fabiano Silva
madrugada

(usa Gentoo)

Enviado em 11/08/2016 - 18:30h

Neste caso você pode testar o driver beta:
http://support.amd.com/en-us/kb-articles/Pages/AMD-Radeon-GPU-PRO-Linux-Beta-Driver–Release-Notes.as...

Mas faça por sua própria conta e risco, pois como o nome diz, está em estágio BETA!


4. AMD Driver

Jean Carlos
j.c.o.s

(usa Linux Mint)

Enviado em 11/08/2016 - 18:38h

Obrigado amigo irei testar, pois uso muito o lInux para jogar e como tenho uma boa placa de video para ficar parada, prefiro sair testando, sei que no ubuntu 15.04 ela funcionava de boas, se no linux mint ficar nesse problema, irei fazer é downgrade de S.O...Obrigado


5. Re: Downgrade para Xorg 1.17

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 11/08/2016 - 18:57h

Madrugada, não e é uma ATI ou AMD ATI é uma NVIDIA.
sei fazer o downgrade do xorg, mas no sabayon e no gentoo. No Arch, não.
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.


6. Re: Downgrade para Xorg 1.17

Ricardo Fabiano Silva
madrugada

(usa Gentoo)

Enviado em 11/08/2016 - 20:56h

albfneto escreveu:

Madrugada, não e é uma ATI ou AMD ATI é uma NVIDIA.
sei fazer o downgrade do xorg, mas no sabayon e no gentoo. No Arch, não.
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.


KKK
Sim @albfneto, a placa do solicitante é NVídia, a do @j.c.o.s é que é uma AMD/ATI
Como eu vi o comentário dele, e tinha visto a página da AMD esses dias, fiz o comentário para ajudar :-)


7. Obrigado

Jean Carlos
j.c.o.s

(usa Linux Mint)

Enviado em 11/08/2016 - 21:09h

madrugada escreveu:

albfneto escreveu:

Madrugada, não e é uma ATI ou AMD ATI é uma NVIDIA.
sei fazer o downgrade do xorg, mas no sabayon e no gentoo. No Arch, não.
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.


KKK
Sim @albfneto, a placa do solicitante é NVídia, a do @j.c.o.s é que é uma AMD/ATI
Como eu vi o comentário dele, e tinha visto a página da AMD esses dias, fiz o comentário para ajudar :-)


Amigo obrigado, eu baixei e tentei instalar, mas ele disse que precisava de algumas dependências...tipo amdgpu e algumas coisas relacionadas, não irei desisti facil....mesmo assim fico grato pela sua ajuda...




8. Re: Downgrade para Xorg 1.17

Ricardo Fabiano Silva
madrugada

(usa Gentoo)

Enviado em 12/08/2016 - 14:48h

j.c.o.s escreveu:

madrugada escreveu:

albfneto escreveu:

Madrugada, não e é uma ATI ou AMD ATI é uma NVIDIA.
sei fazer o downgrade do xorg, mas no sabayon e no gentoo. No Arch, não.
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.


KKK
Sim @albfneto, a placa do solicitante é NVídia, a do @j.c.o.s é que é uma AMD/ATI
Como eu vi o comentário dele, e tinha visto a página da AMD esses dias, fiz o comentário para ajudar :-)


Amigo obrigado, eu baixei e tentei instalar, mas ele disse que precisava de algumas dependências...tipo amdgpu e algumas coisas relacionadas, não irei desisti facil....mesmo assim fico grato pela sua ajuda...



Tenta aí:
modprobe amdgpu 
Se o módulo estiver disponível, ele será carregado.


9. irei

Jean Carlos
j.c.o.s

(usa Linux Mint)

Enviado em 12/08/2016 - 21:18h

madrugada escreveu:

j.c.o.s escreveu:

madrugada escreveu:

albfneto escreveu:

Madrugada, não e é uma ATI ou AMD ATI é uma NVIDIA.
sei fazer o downgrade do xorg, mas no sabayon e no gentoo. No Arch, não.
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.


KKK
Sim @albfneto, a placa do solicitante é NVídia, a do @j.c.o.s é que é uma AMD/ATI
Como eu vi o comentário dele, e tinha visto a página da AMD esses dias, fiz o comentário para ajudar :-)


Amigo obrigado, eu baixei e tentei instalar, mas ele disse que precisava de algumas dependências...tipo amdgpu e algumas coisas relacionadas, não irei desisti facil....mesmo assim fico grato pela sua ajuda...



Tenta aí:
modprobe amdgpu 
Se o módulo estiver disponível, ele será carregado.


irei testar novamente, pois eu desinstalei os drivers, pois estava dando problemas no pacote de update, e mesmo com apt-get -f install não estava resolvendo...


10. modprobe amdgpu

Jean Carlos
j.c.o.s

(usa Linux Mint)

Enviado em 12/08/2016 - 22:57h

ola amigo infelizmente o comando deixa a tela preta e de la não sair rsrsrsrs...
durante a instalação eu me deparo com esse erro....
Erros foram encontrados durante o processamento de:
/var/opt/amdgpu-pro/./amdgpu-pro-clinfo_16.30.3-315407_amd64.deb
/var/opt/amdgpu-pro/./amdgpu-pro-opencl-icd_16.30.3-315407_amd64.deb
/var/opt/amdgpu-pro/./amdgpu-pro-opencl-icd_16.30.3-315407_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
deve ser isso o problema...






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts