Arch Linux não dá boot, após instalação [RESOLVIDO]

1. Arch Linux não dá boot, após instalação [RESOLVIDO]

Iranildo Alves
Lord Gremory

(usa Arch Linux)

Enviado em 24/08/2017 - 20:04h

Hoje fui instalar o arch linux, e busquei a documentação e alguns tutoriais como referência.
Segui todos os passo até ai tudo bem, porém apos terminar tudo e dar reboot a unica coisa que acontece é a seguinte mensagem:

Non-system disk or disk error
replace and strike any key when ready


Já repeti duas vezes o processo de instalação e nada.


  


2. Re: Arch Linux não dá boot, após instalação [RESOLVIDO]

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 24/08/2017 - 22:57h

vc está sem boot, ou está sem grub ou sua partição Raiz não é bootável.

Seu micro tem UEFI, Boot Seguro ou GPT? Não sei se Arch tem suporte para UEFI,
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.


3. Re: Arch Linux não dá boot, após instalação [RESOLVIDO]

Paulo Jr
Pebis

(usa Debian)

Enviado em 24/08/2017 - 23:02h



Mexeu nos cabos??? Pode ser isso.


4. Re: Arch Linux não dá boot, após instalação [RESOLVIDO]

anderson josé de souza inácio
AndersonInacio

(usa Debian)

Enviado em 24/08/2017 - 23:25h

Pode ter ocorrido algum erro durante a instalação do grub, você pode fazer chroot novamente e durante a instalação do grub acrescentar --force no comando, veja como fica:

grub-install --target=i386-pc --recheck /dev/sda --force


5. Re: Arch Linux não dá boot, após instalação [RESOLVIDO]

Iranildo Alves
Lord Gremory

(usa Arch Linux)

Enviado em 24/08/2017 - 23:45h

Pebis escreveu:



Mexeu nos cabos??? Pode ser isso.


E um netbook, o HD ta ok


6. Re: Arch Linux não dá boot, após instalação [RESOLVIDO]

Iranildo Alves
Lord Gremory

(usa Arch Linux)

Enviado em 24/08/2017 - 23:48h

albfneto escreveu:

vc está sem boot, ou está sem grub ou sua partição Raiz não é bootável.

Seu micro tem UEFI, Boot Seguro ou GPT? Não sei se Arch tem suporte para UEFI,
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.


|Ele da boot nos Windows de boas, e eu acho que ta no modo GPT eu tentei trocar pra EFI pra ver se funciona
Será que o lugar que o grub esta sendo instalado ta errado? tenho uma partição de backup ntfs, será que isso interfere? pq tem uma HD maior (sda) e tem as sub partições (sda1,sda2..) isso pode interferir em algo?


7. Re: Arch Linux não dá boot, após instalação [RESOLVIDO]

Iranildo Alves
Lord Gremory

(usa Arch Linux)

Enviado em 24/08/2017 - 23:54h

AndersonInacio escreveu:

Pode ter ocorrido algum erro durante a instalação do grub, você pode fazer chroot novamente e durante a instalação do grub acrescentar --force no comando, veja como fica:

grub-install --target=i386-pc --recheck /dev/sda --force


Não foi reportado nenhum erro na instalação do grub, inclusive quando rodei o comando acima




8. Re: Arch Linux não dá boot, após instalação [RESOLVIDO]

Iranildo Alves
Lord Gremory

(usa Arch Linux)

Enviado em 24/08/2017 - 23:59h

Eu percebi que durante a instalação apareceu a seguinte menssagem durante o comando
mkinitcpio -p linux 


==> WARNING: Possibly missing firmiware for module: aic94xx
==> WARNING: Possibly missing firmiware for module: wd719x


será que isso interferiu em algo? em alguns tutoriais que eu vi aparecia esse warning tbm, porém lá tudo deu certo.


9. Re: Arch Linux não dá boot, após instalação [RESOLVIDO]

anderson josé de souza inácio
AndersonInacio

(usa Debian)

Enviado em 25/08/2017 - 00:08h

Não quero ser rude, mas você pode nos informar quais os passos que você utilizou após instalar o arch, ex tirei o cd/pendrive; alterei no bios; consegui boot do hd pela mídia de instalação, etc.


10. Re: Arch Linux não dá boot, após instalação

Iranildo Alves
Lord Gremory

(usa Arch Linux)

Enviado em 25/08/2017 - 00:21h

AndersonInacio escreveu:

Não quero ser rude, mas você pode nos informar quais os passos que você utilizou após instalar o arch, ex tirei o cd/pendrive; alterei no bios; consegui boot do hd pela mídia de instalação, etc.


Sem problemas, eu dei boot pelo pen-drive, usei o dd pra copiar a imagem do arch,, apos isso bootei o pendrive, e eentrei no modo, boot arch linux (x86_64), todos os passos que segui são os deste tutorial ==> https://www.vivaolinux.com.br/artigo/Arch-Linux-Instalacao-sem-complicacao/?pagina=1.

meu netboot um HP mini (que não sei por que raios tem uma bios bloqueada pela hp, inrresetável, talvez só reprogramável por porta serial), então não consigo mexer nada da bios. porém eu consigo dar boot nas outras distro linux e no windows normalmente.

o HD, (sda) tem 3 subdiretorios : sda1(boot), sda2(swap), sda3(backup), sda4(systemfiles)

quando o grub foi instalado ele foi instalado no sda geral.

não houve nenhum erro durante a instalação exceto a parte de desmontar pra dar reboot
ele dizia:
umount /mnt : bussy 


dai eu dei o reboot, mesmo assim.

e então eu esperei o sistema desligar e entra na bios, dai removi o pendrive



11. Re: Arch Linux não dá boot, após instalação [RESOLVIDO]

Iranildo Alves
Lord Gremory

(usa Arch Linux)

Enviado em 26/08/2017 - 01:54h

ontem eu passei o dia tentando resolver o problema, porém o erro persiste, então eu percebi que partição boot aparentemente não esta com flag de inicio (*tem uma flag de inicio no pendrive), porém eu não consigo alterar isso no cfdisk, fdisk, ou gdisk, não me aparece a opção de selecionar a partição como primaria, lógica nem com alterar e adicionar essas flags, será que foi o modo que eu instalei criei o pendrive de boot do Arch, através do dd que fez isso?
Preciso muito instalar essa distro!



12. Re: Arch Linux não dá boot, após instalação [RESOLVIDO]

Iranildo Alves
Lord Gremory

(usa Arch Linux)

Enviado em 27/08/2017 - 23:11h

Resolvi o problema após assistir um tutorial em inglês.
Faltou um comando na linha de instalação do GRUB.

Na maioria dos tutoriais em PT era escrito a seguinte linha de comando:

pacman -S grub 


Porém no meu caso só funcionou com esse comando extra:

pacman -S grub os-prober 


que foi justamente o que faltou, pra poder inicializar o sistema.