firefox não abre páginas php

1. firefox não abre páginas php

Everaldo Maroneze de Andrade
emarone

(usa Debian)

Enviado em 03/10/2008 - 10:26h

Instalei o apache2 e o php, todas as configurações estão corretas, eu acho, mas o firefox só abre a página se eu digitar por exemplo localhost/index.php, se eu digitar somente localhost o firefox pede para fazer download do arquivo.
Detalhe, na rede da minha empresa os computadores com Internet explorer abrem sem problemas, só o mozilla não abre. Alguém poderia me ajudar?


  


2. Re: firefox não abre páginas php

Vinicus S Moraes
vsmoraes

(usa Arch Linux)

Enviado em 03/10/2008 - 10:33h

Adicione/Modifique isso ao seu http.conf


<IfModule dir_module>
DirectoryIndex index.php
</IfModule>

AddType application/x-httpd-php .php



3. Re: firefox não abre páginas php

Everaldo Maroneze de Andrade
emarone

(usa Debian)

Enviado em 03/10/2008 - 10:51h

Já fiz essa configuração, mas só o internet explorer abre sem precisar digitar index.php, o mozilla continua pedindo para fazer download


4. Re: firefox não abre páginas php

Vinicus S Moraes
vsmoraes

(usa Arch Linux)

Enviado em 03/10/2008 - 11:20h

Faça o seguinte:

Limpe o cache do Firefox;
Abra o site com o IE;
Abra o site com o Firefox;
Poste aqui o conteudo de: tail -n200 /var/log/httpd/access.log


5. Re: firefox não abre páginas php

Everaldo Maroneze de Andrade
emarone

(usa Debian)

Enviado em 03/10/2008 - 11:54h

Vou te passar os logs:

10.26.76.50 - - [03/Oct/2008:11:56:30 +0000] "GET /www/templates/aha_success/images/logo.png HTTP/1.1" 304 - "http://10.26.76.99/www/" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; snprtz|S28971500000224; .NET CLR 2.0.50727)"
10.26.76.50 - - [03/Oct/2008:11:56:30 +0000] "GET /www/templates/aha_success/images/breadleft.png HTTP/1.1" 304 - "http://10.26.76.99/www/" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; snprtz|S28971500000224; .NET CLR 2.0.50727)"
10.26.76.50 - - [03/Oct/2008:11:56:30 +0000] "GET /www/templates/aha_success/images/hornav.png HTTP/1.1" 304 - "http://10.26.76.99/www/" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; snprtz|S28971500000224; .NET CLR 2.0.50727)"
10.26.76.50 - - [03/Oct/2008:11:56:30 +0000] "GET /www/templates/aha_success/images/breadright.png HTTP/1.1" 404 367 "http://10.26.76.99/www/" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; snprtz|S28971500000224; .NET CLR 2.0.50727)"
10.26.76.50 - - [03/Oct/2008:11:56:30 +0000] "GET /www/templates/aha_success/images/modul_head.png HTTP/1.1" 304 - "http://10.26.76.99/www/" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; snprtz|S28971500000224; .NET CLR 2.0.50727)"
10.26.76.50 - - [03/Oct/2008:11:56:30 +0000] "GET /www/templates/aha_success/images/ver_nav.png HTTP/1.1" 304 - "http://10.26.76.99/www/" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; snprtz|S28971500000224; .NET CLR 2.0.50727)"
10.26.76.50 - - [03/Oct/2008:11:56:30 +0000] "GET /www/templates/aha_success/images/footer_right.png HTTP/1.1" 404 369 "http://10.26.76.99/www/" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; snprtz|S28971500000224; .NET CLR 2.0.50727)"
10.26.76.50 - - [03/Oct/2008:11:56:30 +0000] "GET /www/templates/aha_success/images/footer_left.png HTTP/1.1" 304 - "http://10.26.76.99/www/" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; snprtz|S28971500000224; .NET CLR 2.0.50727)"
10.26.76.18 - - [03/Oct/2008:11:56:49 +0000] "GET /www HTTP/1.0" 301 353 "-" "Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.8.1.16) Gecko/20080702 Iceweasel/2.0.0.16 (Debian-2.0.0.16-0etch1)"



6. Re: firefox não abre páginas php

Anderson Nunes
anderson-vol

(usa Ubuntu)

Enviado em 03/04/2016 - 10:49h

Show .... fiz essa configuração e funcionou!!!!

Valeu!






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts