Servidor web [RESOLVIDO]

1. Servidor web [RESOLVIDO]

Eduardo Treska
eduardotreska

(usa Ubuntu)

Enviado em 11/05/2011 - 11:57h

Galera,

Atualmente eu e uns amigos temos um forum vbulletin rodando em um servidor dedicado.
Essa maquina não é uma das tops, mas até esses dias estava dando conta do recado.
Temos um Quad Core com 512 mb de momória e 16 gb de disco.

Temos um banco de dados com mais ou menos 1 gb myqsl.

O que tem rolado é que tivemos um problema é o usuario 1 do vbulletin foi removido e isso começou a deixar a leitura do banco de dados bem lenta.

Em seguida tivemos uma invasão devido a um erro no debian 4 que permitiu ser rodado um exploid.

A maioria dos problemas foram resolvidos, porem o que mais esta me incomodando é que o Load Average esta sempre algo e o forum esta sempre lento. O apache esta consumindo bastante mais o mysql é que esta complicado.

Queria quem sabe trocar o apache por outro ferramenta e gostaria de saber o que vocês sugerem.

Com essas configurações seria melhor Nginx, Apache ou Lighttpd?

Vlw a todos


  


2. Re: Servidor web [RESOLVIDO]

euteste da silva
foxbit3r

(usa Solaris)

Enviado em 11/05/2011 - 13:42h

Instale algo mais novo nessa máquina.


3. Re: Servidor web [RESOLVIDO]

Eduardo Treska
eduardotreska

(usa Ubuntu)

Enviado em 11/05/2011 - 14:05h

foxbit3r

O que sugere de instalação?

A maquina foi formatada, só o banco de dados foi migrado, o sistema que estamos usando é o debian 6.
Segurança foi reforçada. Apenas o load average esta horrivel, algo como 3.66 quando acredito que acima de 1,2 já estaria bem ruim para os recursos desse servidor.


4. Re: Servidor web [RESOLVIDO]

Joao
stack_of

(usa Slackware)

Enviado em 12/05/2011 - 07:55h

Já observou o que acontece no comando top?


5. Re: Servidor web [RESOLVIDO]

Eduardo Treska
eduardotreska

(usa Ubuntu)

Enviado em 12/05/2011 - 09:36h

Já sim,

Para variar, apache estava consumindo muito recurso junto com o mysql.

Dei uma melhorada nas coisas removendo completamente o apache e colocando o lighttpd.

A melhora foi considerável load average 0.25 0.55 0.75 , apesar de ainda estar cedo e o pessoal que acessa realmente o fórum chega mais tarde.

Também dei uns tapas da configuração do mysql usando como base as configurações que vem de exemplo dele.

Instalei também o APC cache e mysql tuning

Vou dar uma monitorada nos próximos dias, esta pensando em talvez colocar algo como o memcache para testar.

vlw pessoal


6. Re: Servidor web [RESOLVIDO]

Joao
stack_of

(usa Slackware)

Enviado em 12/05/2011 - 09:57h

Até onde sei o lighttpd é imbatível em páginas estáticas. Talvez uma combinação Apache2+Lighttpd?
Tem um tutorial aqui no VOL sobre isso.


7. Re: Servidor web [RESOLVIDO]

Eduardo Treska
eduardotreska

(usa Ubuntu)

Enviado em 12/05/2011 - 10:39h

é uma possibilidade sim.

Vou dar uma restada nesta idéia.

Vlw a dica, vou tentar e digo o que rolou.


8. Re: Servidor web [RESOLVIDO]

Joao
stack_of

(usa Slackware)

Enviado em 12/05/2011 - 21:17h

Fiquei devendo o link:

http://www.vivaolinux.com.br/artigo/Otimizando-seu-web-server-com-Apache2-+-Lighttpd/


9. Re: Servidor web [RESOLVIDO]

Eduardo Treska
eduardotreska

(usa Ubuntu)

Enviado em 13/05/2011 - 09:11h

stack_of

Vkw mesmo a dica, achei realmente muito interessante a idéia..


Obrigado






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts