Problema com o GLPI [RESOLVIDO]

1. Problema com o GLPI [RESOLVIDO]

julio vitor vaz da rocha
julio456

(usa Debian)

Enviado em 20/11/2017 - 16:41h

Olá, boa tarde, sou novo na área e estou com problemas na instalação do GLPI, uma vez que segui diversos tutoriais, continuo tendo o mesmo problema. Então, é o seguinte, logo após seguir todos os passos determinados pelos tutorais e vou acessar o glpi pelo ip "localhost"/glpi , ele não carrega a interface gráfica corretamente, e fica somente códigos na tela.

com a seguinte codificação:


-------------------------------------------------------------------------- */ /** @file * @brief */ // Check PHP version not to have trouble if (version_compare(PHP_VERSION, "5.4.0") < 0) { die("PHP >= 5.4.0 required"); } define('DO_NOT_CHECK_HTTP_REFERER', 1); // If config_db doesn't exist -> start installation define('GLPI_ROOT', dirname(__FILE__)); include (GLPI_ROOT . "/config/based_config.php"); if (!file_exists(GLPI_CONFIG_DIR . "/config_db.php")) { include_once (GLPI_ROOT . "/inc/autoload.function.php"); Html::redirect("install/install.php"); die(); } else { $TRY_OLD_CONFIG_FIRST = true; include (GLPI_ROOT . "/inc/includes.php"); $_SESSION["glpicookietest"] = 'testcookie'; // For compatibility reason if (isset($_GET["noCAS"])) { $_GET["noAUTO"] = $_GET["noCAS"]; } Auth::checkAlternateAuthSystems(true, isset($_GET["redirect"])?$_GET["redirect"]:""); // Send UTF8 Headers header("Content-Type: text/html; charset=UTF-8"); // Start the page echo ''."\n"; echo ''; echo ''."\n"; echo ''."\n"; echo ''."\n"; echo "\n"; echo ''; // auto desktop / mobile viewport echo ""; // Appel CSS echo ''; // CSS theme link echo Html::css($CFG_GLPI["root_doc"]."/css/palettes/".$CFG_GLPI["palette"].".css"); // surcharge CSS hack for IE echo ""; // echo ""; echo ""; echo ""; echo "
"; echo "
"; echo "
"; echo nl2br(Toolbox::unclean_html_cross_side_scripting_deep($CFG_GLPI['text_login'])); echo "
"; echo "
"; echo "
"; $_SESSION['namfield'] = $namfield = uniqid('fielda'); $_SESSION['pwdfield'] = $pwdfield = uniqid('fieldb'); // Other CAS if (isset($_GET["noAUTO"])) { echo ""; } // redirect to ticket if (isset($_GET["redirect"])) { Toolbox::manageRedirect($_GET["redirect"]); echo ''; } echo '


[...]


  


2. Re: Problema com o GLPI [RESOLVIDO]

Marcos Felipe
plimo263

(usa Ubuntu)

Enviado em 20/11/2017 - 16:45h

Boa tarde amigo, estes codigos são linhas de codigo PHP, o interpretador PHP esta instalado na maquina ? Qual distro/versão ?




3. Problema com o GLPI

julio vitor vaz da rocha
julio456

(usa Debian)

Enviado em 20/11/2017 - 16:59h

plimo263 escreveu:

Boa tarde amigo, estes codigos são linhas de codigo PHP, o interpretador PHP esta instalado na maquina ? Qual distro/versão ?



Boa tarde, estou usando debian-8.1.0, quem seria esse "interpretador de PHP"?


4. Re: Problema com o GLPI [RESOLVIDO]

Marcos Felipe
plimo263

(usa Ubuntu)

Enviado em 20/11/2017 - 17:05h

Tenta este comando no seu terminal amigo, e veja se depois sua pagina carrega.

sudo apt-get update && sudo apt-get install php5-common libapache2-mod-php5 php5-cli -y




5. Problema com o GLPI

julio vitor vaz da rocha
julio456

(usa Debian)

Enviado em 21/11/2017 - 08:14h

plimo263 escreveu:

Tenta este comando no seu terminal amigo, e veja se depois sua pagina carrega.

sudo apt-get update && sudo apt-get install php5-common libapache2-mod-php5 php5-cli -y



fiz o que você pediu, porém o erro ainda persiste :s




6. Re: Problema com o GLPI [RESOLVIDO]

Marcos Felipe
plimo263

(usa Ubuntu)

Enviado em 21/11/2017 - 08:53h

Bom dia amigo, ele fez a instalação toda sem erro ? Reiniciou o apache ?


7. Re: Problema com o GLPI [RESOLVIDO]

julio vitor vaz da rocha
julio456

(usa Debian)

Enviado em 21/11/2017 - 08:56h

julio456 escreveu:

plimo263 escreveu:

Tenta este comando no seu terminal amigo, e veja se depois sua pagina carrega.

sudo apt-get update && sudo apt-get install php5-common libapache2-mod-php5 php5-cli -y



fiz o que você pediu, porém o erro ainda persiste :s



Acabei resolvendo o problema , resolução:
pode usar tanto o vi ou nano.


sudo nano /etc/apache2/sites-enabled/000-default.conf
ALTERAR DE:

DocumentRoot /var/www/html

PARA:

DocumentRoot /var/www/







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts