Múltiplas versões de PHP no Debian 8

1. Múltiplas versões de PHP no Debian 8

Aureliano Silva
aureliano_silva

(usa Debian)

Enviado em 09/10/2015 - 14:31h

Boa tarde, galera!

Estou com dificuldade para fazer funcionar múltiplas versões de PHP no Debian 8.
Utilizando o Magento, que é homologado somente para as versões de PHP 5.4 e 5.5, vários plugins acabam nem instalando por conta da versão do PHP disponível na Jessie, que é o PHP 5.6.

Tentei seguir este tutorial mas sem sucesso...
http://www.fabiomingorance.com.br/instalando-multiplas-versoes-php-no-ubuntu-14/

Quando tento rodar o testphp540.com, ele tenta encontrar o index.php no diretório cgi-bin-php/php-cgi-5.4.0 que é justamente o diretório definido no virtualhost (parâmetro Action)
<Directory />virtual host
Options FollowSymLinks
AllowOverride All
AddHandler php-cgi .php
Action php-cgi /cgi-bin-php/php-cgi-5.4.0
</Directory>

Não era para ele tentar encontrar um arquivo dentro deste diretório, até porque php-cgi-5.4.0 é um shell script e não um diretório.
Já tentei vários tutoriais, mas até agora nada.

Se alguém já precisou configurar o Debian 8 pra trabalhar com múltiplas versões de PHP, peço a ajuda, que tá osso....

Valeu!!!


  


2. Re: Múltiplas versões de PHP no Debian 8

Weslley Bernardes
webweslley

(usa Debian)

Enviado em 22/02/2016 - 13:25h

aureliano_silva escreveu:

Boa tarde, galera!

Estou com dificuldade para fazer funcionar múltiplas versões de PHP no Debian 8.
Utilizando o Magento, que é homologado somente para as versões de PHP 5.4 e 5.5, vários plugins acabam nem instalando por conta da versão do PHP disponível na Jessie, que é o PHP 5.6.

Tentei seguir este tutorial mas sem sucesso...
http://www.fabiomingorance.com.br/instalando-multiplas-versoes-php-no-ubuntu-14/

Quando tento rodar o testphp540.com, ele tenta encontrar o index.php no diretório cgi-bin-php/php-cgi-5.4.0 que é justamente o diretório definido no virtualhost (parâmetro Action)
<Directory />virtual host
Options FollowSymLinks
AllowOverride All
AddHandler php-cgi .php
Action php-cgi /cgi-bin-php/php-cgi-5.4.0
</Directory>

Não era para ele tentar encontrar um arquivo dentro deste diretório, até porque php-cgi-5.4.0 é um shell script e não um diretório.
Já tentei vários tutoriais, mas até agora nada.

Se alguém já precisou configurar o Debian 8 pra trabalhar com múltiplas versões de PHP, peço a ajuda, que tá osso....

Valeu!!!

Estou nessa luta ja tem um tempinho, achei esse tutorial que insira a compilar manualmente as versões do PHP essa parte é até tranquilo, mas na hora de configurar os hosts e especificar as versões de cada um não tenho conseguido, de qualquer forma to mando o link se tiver um progresso não deixa de avisar.
http://www.dorianneto.com.br/php/problemas-com-versoes-do-php-nunca-mais/







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts