Ajuda com apache2 [RESOLVIDO]

1. Ajuda com apache2 [RESOLVIDO]

Julian Soares
jukinha

(usa Debian)

Enviado em 11/10/2011 - 12:58h

Bom dia, uso debian 7 (testing)

quero instalar um servidor de web aqui em casa, porém tentei , tentei e nada

vamos lá :

instalar o apache - (apt-get install apache2) e foi instala o restante dos pacotes juntos

tenho a pasta /var/www/ e dentro dela tem index.html, olhei em diversos tutoriais e todos eles me disseram pra instalar iniciar o serviço (/etc/init.d/apache2 restart) e depois ir no browser e digitar (http://localhost) ou (http://127.0.0.1) já confirmei os endereços no (/etc/hosts)

porém quando digito não aparece a mensagem de It Work


gostaria de saber como não consigo visualizar? não mechi em nenhuma configuração do apache

dentro de /etc/apache2 tem :
apache2.conf conf.d/ httpd.conf magic mods-enabled/ ports.conf~ sites-enabled/
apache2.conf~ envvars httpd.conf~ mods-available/ ports.conf sites-available/

na pastar /var/www deixei como u+g para : www-data ( acredito eu que este seja o usuario do apache) e as permissões em 745 *

mesmo assim ainda não consigo acessar o index.html

o que eu estou fazendo de errado? se puderem me ajudar ficarei mt grato,

quero colocar um LAMP, mais nem consigo passar do apache :(




  


2. Re: Ajuda com apache2 [RESOLVIDO]

Daniel Lara Souza
danniel-lara

(usa Fedora)

Enviado em 11/10/2011 - 13:17h

apos tudo isso já reiniciou o apache2 ?
e verificou os logs também do apache para ver o que pode ser ?


3. Re: Ajuda com apache2 [RESOLVIDO]

Julian Soares
jukinha

(usa Debian)

Enviado em 11/10/2011 - 13:42h

ja apos feito tudo isso, reiniciei o apache e nada

verifiquei os logs agora (/var/log/apache2/access.log) e não consta nada.. ;(


4. Re: Ajuda com apache2 [RESOLVIDO]

Diego Oliveira da Silva
dolivervl

(usa Slackware)

Enviado em 11/10/2011 - 13:49h

Após reiniciar o apache verifique se o serviço está ativo:
# ps -aux|grep apache2

Caso esteja ativo, dê um telnet na porta 80:
# telnet 127.0.0.1 80

Se não estiver ativo, verifique na configuração o IP e PORTA.

Verifique também ser não existe uma instalação antiga do apache.




5. Re: Ajuda com apache2 [RESOLVIDO]

Julian Soares
jukinha

(usa Debian)

Enviado em 11/10/2011 - 14:06h

segue a saída dos comandos:

dark ~ # ps -aux | grep apache2
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
root 7935 0.0 0.0 71588 3008 ? Ss 13:42 0:00 /usr/sbin/apache2 -k start
www-data 7938 0.0 0.0 71320 2060 ? S 13:42 0:00 /usr/sbin/apache2 -k start
www-data 7941 0.0 0.0 295016 2484 ? Sl 13:42 0:00 /usr/sbin/apache2 -k start
www-data 7942 0.0 0.0 295016 2488 ? Sl 13:42 0:00 /usr/sbin/apache2 -k start
root 14391 0.0 0.0 7792 860 pts/0 S+ 14:00 0:00 grep --color=auto apache2


dark ~ # telnet 127.0.0.1 80
Trying 127.0.0.1...

não sai disso.


dark ~ # tcpdump -nnq -i eth0 host 127.0.0.1
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth0, link-type EN10MB (Ethernet), capture size 65535 bytes
14:07:37.629738 IP 10.0.0.61.54803 > 127.0.0.1.80: tcp 0
14:07:37.891254 IP 10.0.0.61.54805 > 127.0.0.1.80: tcp 0
14:07:40.630195 IP 10.0.0.61.54803 > 127.0.0.1.80: tcp 0
14:07:40.894156 IP 10.0.0.61.54805 > 127.0.0.1.80: tcp 0
14:07:46.646194 IP 10.0.0.61.54803 > 127.0.0.1.80: tcp 0
14:07:46.902180 IP 10.0.0.61.54805 > 127.0.0.1.80: tcp 0
14:07:58.662201 IP 10.0.0.61.54803 > 127.0.0.1.80: tcp 0
14:07:58.918210 IP 10.0.0.61.54805 > 127.0.0.1.80: tcp 0




/etc/apache2/ports.conf = listen 80 e 443


dark ~ # cat /etc/hosts
127.0.0.1 localhost
127.0.1.1 dark
10.0.0.1 server
10.0.0.3 lucia




6. tentou desligar e ligar de novo?

Leandro Correa dos Santos
nukelinux

(usa Ubuntu)

Enviado em 11/10/2011 - 15:45h

Dica tosca, mas comigo aconteceu isso também.
Reiniciei o pc e o apache funcionou (vai entender).

Não curto a ideia de usar LAMP. Instalar 'direto' é mais prático (pelo menos pra mim)


7. Re: Ajuda com apache2 [RESOLVIDO]

Julian Soares
jukinha

(usa Debian)

Enviado em 11/10/2011 - 15:49h

nukelinux escreveu:

Dica tosca, mas comigo aconteceu isso também.
Reiniciei o pc e o apache funcionou (vai entender).

Não curto a ideia de usar LAMP. Instalar 'direto' é mais prático (pelo menos pra mim)
como assim usar LAMP e instalar ' direto' qual as diferenças ?




8. Re: Ajuda com apache2 [RESOLVIDO]

Diego Oliveira da Silva
dolivervl

(usa Slackware)

Enviado em 11/10/2011 - 16:52h

jukinha escreveu:

nukelinux escreveu:

Dica tosca, mas comigo aconteceu isso também.
Reiniciei o pc e o apache funcionou (vai entender).

Não curto a ideia de usar LAMP. Instalar 'direto' é mais prático (pelo menos pra mim)
como assim usar LAMP e instalar ' direto' qual as diferenças ?



LAMP é um pacote que vem com a instalação automática de Apache, MyQSL e PHP.




9. Re: Ajuda com apache2 [RESOLVIDO]

Julian Soares
jukinha

(usa Debian)

Enviado em 11/10/2011 - 19:32h

RESOLVIDO.

coisa simples, q deu dor de cabeça kkkkkkkk o importante que resolveu!

a parte das configurações esta ok, a minha interface de 'lo' estava desativado, só foi subir (ifconfig lo up) que dai funcionou!

obrigado aos que ajudaram!

att.

Julian






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts