Erro do OpenGL ao abrir AVD do Android Studio [RESOLVIDO]

1. Erro do OpenGL ao abrir AVD do Android Studio [RESOLVIDO]

Kenad Wanderson Araújo Silva
DiggerPixel

(usa Manjaro Linux)

Enviado em 11/07/2017 - 09:55h

Bom dia galera, sou um pouco novo com ArchLinux Manjaro, mas estou tentando usar o Android Studio porém ao startar o avd dá o seguinte erro:

emulator: WARNING: encryption is off
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 155 (GLX)
Minor opcode of failed request: 24 (X_GLXCreateNewContext)
Value in failed request: 0x0
Serial number of failed request: 42
Current serial number in output stream: 43
QObject::~QObject: Timers cannot be stopped from another thread
Falha de segmentação (imagem do núcleo gravada)

As configurações dá máquina que estou usando são essas:

System: Host: kenad-pc Kernel: 4.9.35-1-MANJARO x86_64 (64 bit) Desktop: KDE Plasma 5.10.3
Distro: Manjaro Linux
Machine: Device: portable System: Dell product: Inspiron 5452 v: 1.4.1
Mobo: Dell model: 0F77J1 v: A00 UEFI [Legacy]: Dell v: 1.4.1 date: 04/25/2016
Battery BAT1: charge: 14.1 Wh 53.0% condition: 26.7/28.0 Wh (95%)
CPU: Quad core Intel Pentium N3700 (-MCP-) cache: 1024 KB
clock speeds: max: 2400 MHz 1: 740 MHz 2: 2350 MHz 3: 2258 MHz 4: 2379 MHz
Graphics: Card: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller
Display Server: x11 (X.Org 1.19.3) driver: intel Resolution: [email protected]
OpenGL: renderer: Mesa DRI Intel HD Graphics 405 (Braswell) version: 4.5 Mesa 17.1.4
Audio: Card Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series High Definition Audio Controller
driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k4.9.35-1-MANJARO
Network: Card-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter driver: ath9k
IF: wlp2s0 state: up mac: 90:cd:b6:1f:44:7b
Card-2: Qualcomm Atheros
IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives: HDD Total Size: 500.1GB (25.0% used)
ID-1: /dev/sda model: WDC_WD5000LPCX size: 500.1GB
Partition: ID-1: / size: 98G used: 23G (25%) fs: ext4 dev: /dev/sda3
ID-2: /home size: 261G used: 94G (38%) fs: ext4 dev: /dev/sda4
Sensors: System Temperatures: cpu: 60.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 179 Uptime: 10:11 Memory: 1702.0/3869.9MB Client: Shell (bash) inxi: 2.3.23

Alguém sabe como resolver? Estou há dias batendo cabeça. Se alguém souber fico muito agradecido!



  


2. Consegui resolver

Kenad Wanderson Araújo Silva
DiggerPixel

(usa Manjaro Linux)

Enviado em 11/07/2017 - 10:35h

Resolvi o problema executando o android studio com o seguinte código:

LD_PRELOAD='/usr/$LIB/libstdc++.so.6 /usr/$LIB/libgcc_s.so.1 /usr/$LIB/libxcb.so.1 /usr/$LIB/libgpg-error.so' android-studio








Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts