Configurar ATI Radeon HD 7800 Series

1. Configurar ATI Radeon HD 7800 Series

João Paulo Ramos Rezende
jprrezende

(usa Debian)

Enviado em 23/05/2013 - 19:47h

Pessoal,

estou com um problema muito sério e já quebrei a cabeça durante várias semanas e ainda não consegui resolver.
É o seguinte tenho um PC com uma placa de video ATI Radeon HD 7850 e não estou conseguindo configurá-la corretamente.
O meu sistema é Debian Wheezy 3.2.0-4-amd64.

Sem instalar o driver proprietário o Xorg.conf nem é criado, mas o sistema funciona normal (com o gnome3 em modo simplificado), e também o audio HDMI não é reconhecido.

Após instalar o driver da ATI Catalyst 13.4 (última versão até o momento) o gráfico melhora e o driver é instalado sem erros mas o audio ainda não é reconhecido pelo sistema. Eu não sei como faço pra saber se a aceleração 3D está funcionando mas o Gnome inicializa com todos os efeitos.

lspci:

00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.4 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 5 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev a4)
00:1f.0 ISA bridge: Intel Corporation B75 Express Chipset LPC Controller (rev 04)
00:1f.2 IDE interface: Intel Corporation 7 Series/C210 Series Chipset Family 4-port SATA Controller [IDE mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
00:1f.5 IDE interface: Intel Corporation 7 Series/C210 Series Chipset Family 2-port SATA Controller [IDE mode] (rev 04)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Pitcairn PRO [Radeon HD 7800]
01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Device aab0
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 09)

aplay -l:
device_list:252: no soundcards found...


Ontem formatei a máquina e ainda não instalei o driver da ATI.

O que devo fazer?



  


2. Re: Configurar ATI Radeon HD 7800 Series

Andre (pinduvoz)
pinduvoz

(usa Debian)

Enviado em 23/05/2013 - 20:42h

Não sei como é no Debian 7 com Gnome 3, mas no Ubuntu vc precisa ativar o som da saída HDMI pelas configurações de som (o vídeo é automático, ou seja, basta plugar; o som é manual).

Eu acho que vc deveria instalar o driver da HDMI do jeito Debian, ou seja, pelos repositórios. Pesquise sobre isso.


3. Re: Configurar ATI Radeon HD 7800 Series

Andre (pinduvoz)
pinduvoz

(usa Debian)

Enviado em 23/05/2013 - 20:46h

Aqui:

http://va.mu/cYwK

Deve haver mais material.

Aliás, seria legal achar um guia direcionado ao Debian 7 Wheezy.


4. Re: Configurar ATI Radeon HD 7800 Series

João Paulo Ramos Rezende
jprrezende

(usa Debian)

Enviado em 23/05/2013 - 22:58h

Quando o driver proprietário está instalado aparentemente tudo funciona legal, com exceção do audio, e então após alguns minutos de uso o X congela, somente o mouse funciona. Então marquei a hora que travou e pelo dmesg notei que apareceu este erro no mesmo instante do congelamento.

[fglrx:firegl_apl_loadDatabase] *ERROR* APL: apl initialize fail.

Todas as vezes que congela tem o mesmo erro.