ATI radeon xpress 1100 reconhecida como xpress 200m (debian)

1. ATI radeon xpress 1100 reconhecida como xpress 200m (debian)

Gustavo Sartori Pottker
gustavopottker

(usa Arch Linux)

Enviado em 23/03/2011 - 08:40h

Olá! estou usando o Crunchbang linux, que é baseado no debian Squeeze, e estou tendo o seguinte problema:
Quando digito
lspci | grep VGA

aparece

01:05.0 VGA compatible controller: ATI Technologies Inc RS482 [Radeon Xpress 200M]

porém, minha placa é a Radeon Xpress 1100.

O problema é que quando eu instalo os drivers free, o sistema muitas vezes trava, a tela fica com linhas verticais coloridas e nada funciona senão um hard reset (este problema é documentado para o driver - http://wiki.debian.org/AtiHowTo ).

Mas o método de instalar o driver proprietário descrito aqui: http://wiki.debian.org/ATIProprietary#Squeeze não funciona. Diz que o meu adaptador não existe.

Quando tento instalar o driver disponível no site da ATI, não consigo criar os pacotes de instalação, tendo a seguinte resposta:

sh ./ati-driver-installer-9-3-x86.x86_64.run --buildpkg Debian/stable

debian/rules build
dh_testdir
make: dh_testdir: Command not found
make: *** [build] Error 127
dpkg-buildpackage: error: debian/rules build gave error exit status 2
Removing temporary directory: fglrx-install.zhvoei

Se alguém puder me ajudar, eu fico muito agradecido!

Abraços,

Gustavo.


  


2. Re: ATI radeon xpress 1100 reconhecida como xpress 200m (debian)

Perfil removido
removido

(usa Nenhuma)

Enviado em 23/03/2011 - 08:52h

aí temos duas possibilidades: ou a placa está sendo detectada errada ou vc NÃO tem a placa que pensa que tem.

Para eliminarmos a dúvida, recomendo usar um live-cd qualquer - que n seja do debian - e rodar novamente o lspci para saber a verdadeira placa.

se conferir com o resultado do debian, comprou gato por lebre.




3. Re: ATI radeon xpress 1100 reconhecida como xpress 200m (debian)

Gustavo Sartori Pottker
gustavopottker

(usa Arch Linux)

Enviado em 24/03/2011 - 10:56h

Olá, obrigado pela sugestão do live cd.

Porém, não há erro algum, eu conheço meu hardware, estou com ele já faz 4 anos e já testei diversos sistemas operacionais.

Estou em dúvida quanto ao qual componente do software pode ter identificado errado o hardware. Será o próprio Kernel? ou o Udev? ou será que o driver seria o mesmo tanto para uma, quanto para outra placa?
Já usei o sistema sem ocorrer problema algum de travamento e tenho absoluta certeza que é o driver de vídeo, só que o problema é trocar por outro.

Abraços,

Gustavo.


4. Re: ATI radeon xpress 1100 reconhecida como xpress 200m (debian)

Reynaldo Matos Hortensi
reynaldohortensi

(usa OpenSuSE)

Enviado em 19/06/2011 - 14:45h

Acho que o problema é a versão do X.org:

"Description:
Automated installer and Display Drivers for X.Org 6.7, 6.8, 6.9, 7.0, 7.1, 7.2, 7.3, or 7.4"

Retirado de: http://support.amd.com/br/gpudownload/linux/Legacy/Pages/radeon_linux.aspx?type=2.4.1&product=2....

Eu tenho um notebook dell vostro 1000 que tem a seguinte saída para "lspci | grep VGA":

01:05.0 VGA compatible controller: ATI Technologies Inc RS482 [Radeon Xpress 200]

Ou seja, são baseados no mesmo chip RS482. Aqui eu uso driver aberto que aparece na saída do "lsmod" como "radeon", que pertence ao pacote xserver-xorg-video-radeon que é automaticamente instalado quando vc instala o pacote xserver-xorg-video-ati. O pacote xserver-xorg-video-ati instala o xserver-xorg-video-radeon (no nosso caso) ou o xserver-xorg-video-radeonhd (para as placas radeon hd, mais recentes).

O que ocorre é que o suporte do driver proprietário para a nossa placa foi cortado em abril de 2009, quando foi lançado o lançado o catalyst 9.4, restando o catalyst 9.3 que só suporta até o Xorg 7.4 que, por sua vez, só pode ser instalado num kernel antigo (acho que é o 2.6.27).

Resumindo, pra usar o driver proprietário que você tentou instalar só voltando pro kernel 2.6.27 e xorg 7.4.

Espero ter ajudado, apesar do tópico ser meio antigo.
Abraços,
Reynaldo


5. Valeu Reynaldo!

Gustavo Sartori Pottker
GustavoPottker

(usa Arch Linux)

Enviado em 19/06/2011 - 20:03h

Eu também percebi depois de um tempo esse motivo (que não era mais suportado), mas não tão precisamente. Achei uma pena. O fato é que eu queria mudar o driver porque o driver livre estava dando alguns bugs (travava tudo, com listras na tela, e tinha que reiniciar o pc).
Vi que este bug fora relatado, mas não achei uma solução satisfatória.

Mais recentemente, meu notebook não estava conectando na internet da minha namorada, por ser sem senha. Ou melhor, conectava, mas não navegava.
Instalei várias distros diferentes, sem sucesso. Instalei o Windows, funcionou.

Imaginei que um notebook de 2006 seria hoje bem suportado pelo Linux, mas vejo agora que ele na verdade deixou de ser suportado!

Muito obrigado por responder o tópico!

Abraços,

Gustavo.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts