i2c i2c-2 sendbytes: NAK bailout. Erro linux e monitor sumindo imagem.

1. i2c i2c-2 sendbytes: NAK bailout. Erro linux e monitor sumindo imagem.

Perfil removido
removido

(usa Nenhuma)

Enviado em 22/08/2020 - 02:54h

Pessoal, inicialmente meu pc começou a dar um problema muito estranho:

Iniciava, funcionava normalmente e depois do nada a imagem do monitor sumia, os monitorores e o pc continuavam ligados e não desligava apertando e/ou segurando o botão power do gabinete, apenas desligava cortando a energia (tirando da tomada).

Isso começou a acontecer mais vezes e mais rápido (logo após o inicio do OS), estava usando o mint.

Então reparei na mensagem de erro toda vez que ligo o computador (segue na imagem).

Já retirei a placa de vídeo e deixei apenas um monitor onboard, ja usei apenas um monitor offboard (como eu utilizei por muito tempo), reinstalei o mint, troquei para o Ubuntu e nada, a mensagem de erro continua aparecendo.

Alguém ja passou por isso e conseguiu uma solução?

Referente ao primeiro problema dos monitores derrubando a imagem, já desmontei ele todo, limpei, passei limpa contato, no cooler, conectores, etc. Troquei pasta termica do processador e da placa de vídeo. Resumindo, dei uma geral no hardware todo e NADA. Continua acontecendo. :(


  


2. Re: i2c i2c-2 sendbytes: NAK bailout. Erro linux e monitor sumindo imagem.

Ricardo Groetaers
ricardogroetaers

(usa Linux Mint)

Enviado em 24/08/2020 - 01:26h

NatNat escreveu:
Iniciava, funcionava normalmente e depois do nada a imagem do monitor sumia, os monitorores e o pc continuavam ligados e não desligava apertando e/ou segurando o botão power do gabinete, apenas desligava cortando a energia (tirando da tomada).

-configuração de gerenciamento de energia no sistema e no setup
-configuração do comportamento do botão liga/desliga no sistema e no setup
-mal contato entre cabo/botão/conector na placa mãe
-forçar resolução e ou frequência que o monitor não suporta.
-desligamento incorreto, corrupção do sistema de arquivos (ver figura acima), erros se acumulando no sistema causando repetição do problema em intervalos menores

NatNat escreveu: ... Troquei pasta termica do processador e da placa de vídeo. Resumindo, dei uma geral no hardware todo e NADA. Continua acontecendo. :(

-Extremo cuidado com as perninhas do soquete da placa mãe onde se coloca o processador.
-Pasta térmica nesse processador é só um pouquinho no centro. Excesso de pasta prejudica troca de calor.

Sistema de arquivos no disco provavelmente está corrompido e com ele o sistema operacional.




3. Re: i2c i2c-2 sendbytes: NAK bailout. Erro linux e monitor sumindo imagem.

Perfil removido
removido

(usa Nenhuma)

Enviado em 24/08/2020 - 02:09h

ricardogroetaers escreveu:

-configuração de gerenciamento de energia no sistema e no setup
-configuração do comportamento do botão liga/desliga no sistema e no setup
-mal contato entre cabo/botão/conector na placa mãe
-forçar resolução e ou frequência que o monitor não suporta.
-desligamento incorreto, corrupção do sistema de arquivos (ver figura acima), erros se acumulando no sistema causando repetição do problema em intervalos menores


O botão está funcionando normalmente, apenas quando as imagens somem que ele não responde, assim como as configurações pois eu não mechi nelas antes de começar a acontecer...

Esse erro aparece na inicialização do sistema e na hora de desligar (quando aperto para desligar normalmente), eu pesquisei sobre ele mas nao achei nada que arrume isso, e também não sei se tem alguma ligação nos casos...

Procurei as logs mas só consigo achar as logs que aparecem após o inicio atual do sistema, antes disso não, outras datas não. (Não sei se é normal, pq as logs que eu costumava analisar era de servidores então tinha de varios períodos).


-Extremo cuidado com as perninhas do soquete da placa mãe onde se coloca o processador.
-Pasta térmica nesse processador é só um pouquinho no centro. Excesso de pasta prejudica troca de calor.

Sistema de arquivos no disco provavelmente está corrompido e com ele o sistema operacional.



Eu troquei a pasta e o processador mas foi depois que já estava ocorrendo esse problema, a placa de video estava esquentando bastante tambem, troquei a pasta do chipset e a temperatura ta de boa mas continua acontecendo isso...

Bom, a princípio as imagens caiam, e ficava preto o monitor mas era notável que estava ligado (imagem1), isso o monitor ligado na placa de video. O monitor ligado onboard desligava totalmente.

Ai faz poucos dias que começou a cair a imagem mas algumas vezes o monitor ligado na placa de video ficava com a imagem branca. (Imagem2)

E nesse exato momento, caiu a imagem e ficou azul!?

Eu já testei as memórias, ontem coloquei 4 coolers ligado na fonte e essa terceira imagem que aconteceu agora é com outro hd que coloquei para testar, nesse hd de teste a promeira vez desligou e ficou branca e a segunda é essa ultima imagem, não da pra ver direito mas é um azul, porém nao igual aquele da famosa tela azul, mas um azul puxado para lilás, estou perdida já pois nao sei o que pode ser.
(O incrível é que isso já aconteceu enquanto eu estava na tela de bios, assim como na instalação do mint tambem).
Estou me perguntando se não pode ser a fonte, já estou sem quem culpar.
Fonte bluecase blu 230 atx

Segue relatório.
https://linux-hardware.org/?probe=d0abdb5c4d




4. Re: i2c i2c-2 sendbytes: NAK bailout. Erro linux e monitor sumindo imagem.

Ricardo Groetaers
ricardogroetaers

(usa Linux Mint)

Enviado em 26/08/2020 - 07:09h

NatNat escreveu:
O botão está funcionando normalmente, apenas quando as imagens somem que ele não responde, ...

Embora, em tese, seja um comando por hardware, nesse tipo de placa/fonte (que permanece até hoje) esse botão nunca desliga de fato o micro.
O micro fica em stand by. Pode ser ligado, por exemplo, por uma chamada telefônica ou de rede. Só desliga mesmo se tirar o plug da tomada.
Um problema elétrico, ainda que causado por software (um driver por exemplo) pode afetar o funcionamento desse botão.

Obs:
-Nunca conecte ou desconecte um teclado com o cabo de força ligado na tomada (pode danificar a placa mãe). Mesmo com um teclado usb é bom não arriscar.
-Placa de vídeo offboard é Nvidia, Ver sugestões para Mint 20 no site do Linux Mint. Provável haver ai um problema.
-Tudo é eletricidade, um problema aqui influi ali.
-Verifique HD, mal contato num HD pode influir no vídeo
-Cabo vga de má qualidade pode prejudicar o video e sobrar para o HD.
-Não sei dizer se 4 coolers ligados na fonte são significativos, depende da potencia e tensão deles e da fonte. Não dá para liga-los na placa mãe?
Aqui tenho 3 coolers, 1 da propria fonte, 1 da cpu (ligado na placa mãe, cpu fan) e 1 como exaustor na traseira do gabinete ligado na placa mãe, sys fan.
-Sua fonte é um tanto modesta para suportar muitos dispositivos conectados e em uso simultâneo:
http://www.bluecase.com.br/home/index.php?route=product/product&product_id=114
http://www.bluecase.com.br/produtos/Fonte_Bluecase_BLU230_ATX-SMALL.pdf
Voce pode arrumar ideia de provocar bad blocks na mídia dos HDs entre outros problemas.



5. Re: i2c i2c-2 sendbytes: NAK bailout. Erro linux e monitor sumindo imagem.

Perfil removido
removido

(usa Nenhuma)

Enviado em 26/08/2020 - 11:08h


ricardogroetaers escreveu:
Placa de vídeo offboard é Nvidia, Ver sugestões para Mint 20 no site do Linux Mint. Provável haver ai um problema.

Eu não entendi, eu vou olhar no site mas realmente não entendi o que vc quis dizer...
A minha primeira acusação foi nela, eu desmontei ela toda, ate o cooler dela eu abri passei o limpa contato para não travar a ventuinha, etc.
Porém eu liguei apenas um monitor onboard e aconteceu o mesmo problema, por isso descartei a possibilidade de ser a placa de video.

...-Não sei dizer se 4 coolers ligados na fonte são significativos, depende da potencia e tensão deles e da fonte. Não dá para liga-los na placa mãe?...

Os cabos estão de boa.
Eu vou explicar o que fiz, além do cooler da fonte e do processador, eu adcionei mais 4 coolers no gabinete, como minha placa é uma GIGABYTE GA-G31M-S2L ela só tem uma entrada fan "adcional", onde fica proximo a placa de video, a princípio eu liguei todos os fios dos coolers juntos em um plugin que encaixa nessa entrada mas fiquei com medo de que estivesse pegando muita energia da placa mãe e ela acabar dando mais um problema. Então eu comprei um plugin macho (esqueci o nome dele) que encaixa na entrada do cabo da fonte, aquele usado antes do SATA para conectar o hd, estão ligados em 12V - amarelo e preto - todos no mesmo fio.

...-Sua fonte é um tanto modesta para suportar muitos dispositivos...
Voce pode arrumar ideia de provocar bad blocks na mídia dos HDs entre outros problemas.

Eu estava quase crente que seria a fonte, essa veio no pc quando peguei ele, por isso ontem comprei uma nominal 500w para testar, bom... Continuo com o mesmo problema, desligou entre as 16h/17h. Depois a noite desligou novamente.

Achei duas logs de erros na pasta crash mas uma me deixou pertubada, não compreendi ela muito bem:

Procurei sobre SIGSEGV mas não sei se isso tem conexão com meu problema...
Também estou verificando as logs de ontem de madrugada que foi a ultima vez q caiu a imagem então preferi ligar ele só agora, tem bastante mas eu não conheço muito, quase não entendo.

PS: após cair as 17h eu decidi atualizar a bios novamente, pra saber se poderia ter alguma ligação, já não sei mais onde procurar. Atualizado com sucesso mas problema continua

Edit1: Uso o drive noveau como visto na imagem, pesquisei o erro logs e achei esse forum:

Sera que isso me ajuda? Eu nao atualizei para o drive nvidia que o sistema esta disponibilizando porque nas primeiras vezes que usei ele tava funcionando de boa mas a ultima vez que instalei deu uns problemas, entao deixei o d noveau mesmo.


6. Re: i2c i2c-2 sendbytes: NAK bailout. Erro linux e monitor sumindo imagem.

Ricardo Groetaers
ricardogroetaers

(usa Linux Mint)

Enviado em 27/08/2020 - 00:47h

Desculpe, mas na minha modesta opinião voce está entrando num labirinto do qual, provavelmente, não logrará sair.

Para que 4 coolers adicionais? Não sei como arrumou espaço para isso. Vai acabar "cruzando ou colidindo vento" e formando turbulência em vez de um fluxo.
Atualização de BIOS, guardou cópia do original?
Corte do sinal de vídeo para o monitor pode ter várias causas, até mesmo uma solda rachada ou componente eletrônico defeituoso.
Existe 2 dispositivos (placas/circuitos) de vídeo diferentes funcionando ao mesmo tempo, se o sistema operacional suporta isso, eu não sei.
Não sei como ligar 2 monitores, cada um a um dispositivo de vídeo diferente.
Tambem não entendo nada de logs do sistema, um desenvolvedor saberia explicar melhor.

Quanto a SIGSEGV, peço ver, por exemplo:
https://en.wikipedia.org/wiki/Segmentation_fault
https://pt.wikipedia.org/wiki/SIGSEGV







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts