USB

1. USB

Rogerio Ponce
rpi

(usa Debian)

Enviado em 01/08/2008 - 15:07h

Boa tarde!

Uso Debian. Recentemente troquei a placa e processador da minha máquina: placa: K8N4-E - sempron 3000+ 64 bits e uma placa de video gs8400

Instalei novamente o debian, só que dessa vez utilizei o AMD64.
Só que a distro não reconheceu as portas usb. (instalei 2X)
ou seja, eu utilizo um hd ide, e no /dev não existem nenhum sda.
Fiz uma pesquisa, inclusive na VOL e tudo o que me disseram pra fazer foi feito, mas sem sucesso.

Acredito que meu primeiro problema é fazer o linux reconhecer o hardware.

Obs. no Windows funciona normal.

Talvez alguem possa me ajudar?

Obrigado.

Rogério.


  


2. USB

Edwal F. Paiva Filho
nicolo

(usa Ubuntu)

Enviado em 01/08/2008 - 15:48h

O que dá para fazer é conectar o dispositivo, abrir um terminal e dar o comando
lsusb
Se não listar nada vai precisar verificar o hardware.
Se listar como root
mount /dev/...o dispositivo listado /ponto de montagem
Fiz isso no slack e funcionou.



3. Re: USB

Fábio Farias
Fabio_Farias

(usa openSUSE)

Enviado em 01/08/2008 - 16:06h

Quando conecto um pendrive no Suse, o dispositivo fica montado em /media e não em /dev. Não seria isso? (Se eu estiver enganado, me perdoem por favor. Ainda sou iniciante em Linux).


4. USB

Edwal F. Paiva Filho
nicolo

(usa Ubuntu)

Enviado em 04/08/2008 - 12:30h

Não é bem isso. O /media é somente um ponto de montagem,que aliás pode ser qualquer diretório, mas de preferência um diretório vazio com qualquer nome.
Só que quando der o comando mount como root você começa pelo dev
mount /dev/sda1 /media/meu-usb
Quando você dá o comando
lsusb
com o dispositivo conectado ele conta em que /dev ele enfiou o dispositivo. Depois disso é mole, é só rodar o comando mount.
lsusb= significa liste os usb´s


5. hardware USB não foi identificado

Rogerio Ponce
rpi

(usa Debian)

Enviado em 04/08/2008 - 13:24h

Então, pessoal, qdo entro com lsusb não me retorna nada.

Preciso saber se existe alguma maneira de forçar o kernel a identificar meu hardware.
A configuração da minha máquina esta no tópico inicial e lembrando, eu tenho um dual boot com o windows e nesse a usb funciona normal.


6. Re: USB

Cristiano
sempreslack

(usa Slackware)

Enviado em 04/08/2008 - 14:52h

você pode tentar mecher na bios e ativar o plug and play. tenta isso e posta a resposta. Abraços


7. plug and play

Rogerio Ponce
rpi

(usa Debian)

Enviado em 05/08/2008 - 10:45h

Na bios o plug and play já estava ativado, pra não perder a viajem desativei e nada, voltei a ativar, e nada tb.

Interessante que na Bios reconhece qdo tenho o pen drive conectado.

qdo entro como o comando lspci -v |grep usb

aparece o seguinte:

0000:00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2) (prog-if 10 [OHCI])
0000:00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a3) (prog-if 20 [EHCI])

qdo entro com o comando lsusb não me retorna nada.

De tantas pesquisas, entendo que terei de instalar algum drive da nVidia que seja compatível com o chipset da placa mãe K8N4-E. Mas ainda não consegui localizar esse drive, nem no site da nVidia.

Rogério.



8. RESOLVIDO...

Rogerio Ponce
rpi

(usa Debian)

Enviado em 08/08/2008 - 10:50h

Boa dia, pessoal...

Pra finalizar esse tópico com sucesso, quero apresentar a solução do meu problema, depois de muita pesquisa na net, consegui.
minhas portas USB estão funcionando muito bem.
Essa solução é para placas mãe K8N4-E ASUS, sei tb que tem outras placas que necessitam dessa alteração.

No /boot/Grub/menu.lst

estava assim:

title Debian GNU/Linux, kernel 2.6.18-6-amd64
root (hd0,5)
kernel /vmlinuz-2.6.18-6-amd64 root=/dev/hda5 ro acpi=off
initrd /initrd.img-2.6.18-6-amd64
savedefault

mudei para pci=nommconf no lugar de acpi=off, veja abaixo:

title Debian GNU/Linux, kernel 2.6.18-6-amd64
root (hd0,5)
kernel /vmlinuz-2.6.18-6-amd64 root=/dev/hda5 ro pci=nommconf
initrd /initrd.img-2.6.18-6-amd64
savedefault

Rogério.