Driver de Som no debian 7.1 não detectado

1. Driver de Som no debian 7.1 não detectado

Marcelo Jose da Silva
marceloadm

(usa Debian)

Enviado em 22/11/2013 - 10:17h

Bom dia amigos do Vol.
Eu tenho o debian 7.1 64bits instalado em meu notebook, instalei o kernel 3.11 mas deram muitos problemas, então removi. Depois da remoção, meu áudio parou de funcionar, já tentei vários Tuto's e não está funcionando, alguém poderia me dar uma ajuda nesse aspecto. Dentro da configuração de áudio, na aba hardware não consta nenhum.

Retorno do comando "lspci":

00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)

Retorno tentativa de ativar alsamixer:

alsactl: init:1743: No soundcards found...

Muito obrigado.




  


2. Driver de Som no debian 7.1 não detectado

Edwal F. Paiva Filho
nicolo

(usa Ubuntu)

Enviado em 22/11/2013 - 12:53h

O Debian tem um ícone de som na configuração e dá para verificar se está aparecendo o hardware.

Se não estiver aparecendo o hardware vai ter que instalar a parte multimedia novamente.

Instalar o alsa e o pulse novamente.

Use o synaptic

sudo synaptic


3. Re: Driver de Som no debian 7.1 não detectado

Marcelo Jose da Silva
marceloadm

(usa Debian)

Enviado em 22/11/2013 - 13:34h

Mestre, reinstalei o alsa e o pulse, mas mesmo assim o hardware não aparece. O bicho tá pegando.


4. Re: Driver de Som no debian 7.1 não detectado

Glauber GF
mcnd2

(usa Debian)

Enviado em 22/11/2013 - 17:37h

Cara, não sei se vai rolar, mas tente ai.

Rode o comando "cat /proc/asound/modules" e vê qual é o modulo que está seu som.

Exemplo:

[email protected]:~$ cat /proc/asound/modules
0 snd_hda_intel


Dessa forma você identificou o modulo de som e agora vamos chamar o mesmo para ser carregado.

[email protected]:~$ su
[email protected]:# modprobe snd_hda_intel



...


5. Re: Driver de Som no debian 7.1 não detectado

Marcelo Jose da Silva
marceloadm

(usa Debian)

Enviado em 22/11/2013 - 17:52h

Mestre, o resultado não foi satisfatório, parece que o diretório asound não existe:

Retorno comando:

[email protected]:~# cat /proc/asound/modules
cat: /proc/asound/modules: Arquivo ou diretório não encontrado




6. Re: Driver de Som no debian 7.1 não detectado

Glauber GF
mcnd2

(usa Debian)

Enviado em 22/11/2013 - 20:27h

Pela GUI tem essa forma, tente ai:

http://www.linuxbrasil.org.br/configuracoes_iniciantes/som/configuracao_do_som.html

...


7. Re: Driver de Som no debian 7.1 não detectado

André Canhadas
andrecanhadas

(usa Debian)

Enviado em 22/11/2013 - 22:02h

Vamos ver:
Primeiro rode como root:

alsactl init

Reinicie e veja se ativa.

Segundo caso o primeiro não de resultado

apt-get install --reinstall libasound2 libasound2-doc alsa-base alsa-utils alsa-oss alsamixergui alsa-modules-2 alsa-source alsa-tools


Terceiro caso os anteriroes não de resultado:

alsamixer

aperte f6 e veja se sua placa esta na lista se estiver ela foi reconhecida
caso esteja selecione uma de cada vez e aumente os volumes de esc para sair e rode

alsactl store


veja se tem a linha "snd" no arquivo /etc/modules caso não tenha adicione sem as aspas

Instale os pacotes "firmware-linux" e "firmware-linux-nonfree" para isto deve ativar os repositorios nonfree no arquivo /etc/apt/sources.list

Caso nada funcione poste aqui a saida:

lsmod | grep snd
dpkg -l alsa*



8. Re: Driver de Som no debian 7.1 não detectado

Marcelo Jose da Silva
marceloadm

(usa Debian)

Enviado em 22/11/2013 - 23:59h

Boa noite amigo, o caso está muito sério.
Segue a saída solicitada:

[email protected]:~# lsmod | grep sdn
[email protected]:~# dpkg -l alsa*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Nome Versão Arquitectura Descrição
+++-==============-============-============-=================================
un alsa <nenhuma> (nenhuma descrição disponível)
ii alsa-base 1.0.25+3~deb all ALSA driver configuration files
ii alsa-oss 1.0.25-1 amd64 ALSA wrapper for OSS applications
ii alsa-tools 1.0.25-2 amd64 Console based ALSA utilities for
ii alsa-utils 1.0.25-4 amd64 Utilities for configuring and usi
ii alsamixergui 0.9.0rc2-1-9 amd64 graphical soundcard mixer for ALS
un alsaplayer <nenhuma> (nenhuma descrição disponível)
ii alsaplayer-als 0.99.80-5.1 amd64 PCM player designed for ALSA (ALS
ii alsaplayer-com 0.99.80-5.1 amd64 PCM player designed for ALSA (com
ii alsaplayer-gtk 0.99.80-5.1 amd64 PCM player designed for ALSA (GTK
un alsaplayer-int <nenhuma> (nenhuma descrição disponível)
un alsaplayer-out <nenhuma> (nenhuma descrição disponível)

Muito obrigado pela ajuda tá?


9. Re: Driver de Som no debian 7.1 não detectado

André Canhadas
andrecanhadas

(usa Debian)

Enviado em 23/11/2013 - 00:22h

marceloadm escreveu:

Boa noite amigo, o caso está muito sério.
Segue a saída solicitada:

[email protected]:~# lsmod | grep sdn
[email protected]:~# dpkg -l alsa*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Nome Versão Arquitectura Descrição
+++-==============-============-============-=================================
un alsa <nenhuma> (nenhuma descrição disponível)
ii alsa-base 1.0.25+3~deb all ALSA driver configuration files
ii alsa-oss 1.0.25-1 amd64 ALSA wrapper for OSS applications
ii alsa-tools 1.0.25-2 amd64 Console based ALSA utilities for
ii alsa-utils 1.0.25-4 amd64 Utilities for configuring and usi
ii alsamixergui 0.9.0rc2-1-9 amd64 graphical soundcard mixer for ALS
un alsaplayer <nenhuma> (nenhuma descrição disponível)
ii alsaplayer-als 0.99.80-5.1 amd64 PCM player designed for ALSA (ALS
ii alsaplayer-com 0.99.80-5.1 amd64 PCM player designed for ALSA (com
ii alsaplayer-gtk 0.99.80-5.1 amd64 PCM player designed for ALSA (GTK
un alsaplayer-int <nenhuma> (nenhuma descrição disponível)
un alsaplayer-out <nenhuma> (nenhuma descrição disponível)

Muito obrigado pela ajuda tá?

opa o primeiro inverteu é

lsmod |grep snd




10. Re: Driver de Som no debian 7.1 não detectado

Marcelo Jose da Silva
marceloadm

(usa Debian)

Enviado em 25/11/2013 - 08:41h

Dei mole na sintaxe; kkk, segue a saída:

[email protected]:~# lsmod | grep snd
snd_seq_midi 12848 0
snd_seq_midi_event 13316 1 snd_seq_midi
snd_rawmidi 23060 1 snd_seq_midi
snd_seq 45126 2 snd_seq_midi_event,snd_seq_midi
snd_seq_device 13176 3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer 22917 1 snd_seq
snd 52889 4 snd_timer,snd_seq_device,snd_seq,snd_rawmidi
soundcore 13065 1 snd

Att,



11. Re: Driver de Som no debian 7.1 não detectado

André Canhadas
andrecanhadas

(usa Debian)

Enviado em 25/11/2013 - 09:39h

marceloadm escreveu:

Dei mole na sintaxe; kkk, segue a saída:

[email protected]:~# lsmod | grep snd
snd_seq_midi 12848 0
snd_seq_midi_event 13316 1 snd_seq_midi
snd_rawmidi 23060 1 snd_seq_midi
snd_seq 45126 2 snd_seq_midi_event,snd_seq_midi
snd_seq_device 13176 3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer 22917 1 snd_seq
snd 52889 4 snd_timer,snd_seq_device,snd_seq,snd_rawmidi
soundcore 13065 1 snd

Att,


Realmente nada dos módulos referentes a placa como snd_hda_intel.

Verificou na Bios se esta placa esta ativa?

Se estiver ok poste a saida:

lspci |grep Audio




12. Re: Driver de Som no debian 7.1 não detectado

wellington joão da Silva
wellingtonjoao

(usa Manjaro Linux)

Enviado em 25/11/2013 - 10:00h

Amigo verificar como está o arquivo dentro de /etc/modprob.d/

procure por um com o nome blacklist dentro dele deve ter alguns modulo se tiver basta comenta os modulos intel.

marceloadm escreveu:

Bom dia amigos do Vol.
Eu tenho o debian 7.1 64bits instalado em meu notebook, instalei o kernel 3.11 mas deram muitos problemas, então removi. Depois da remoção, meu áudio parou de funcionar, já tentei vários Tuto's e não está funcionando, alguém poderia me dar uma ajuda nesse aspecto. Dentro da configuração de áudio, na aba hardware não consta nenhum.

Retorno do comando "lspci":

00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)

Retorno tentativa de ativar alsamixer:

alsactl: init:1743: No soundcards found...

Muito obrigado.







01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts