apt-get update/upgrade - Atualização automática

Publicado por Mário Andrade em 27/03/2013

[ Hits: 88.453 ]

 


apt-get update/upgrade - Atualização automática



Pessoal, é o seguinte, geralmente quando vamos instalar algum programa via terminal, precisamos digitar sudo apt-get update e apt-get upgrade.

Visando facilitar estes pequenos comandos, eu uso um pequeno script que desenvolvi para otimizar isso.

Digite no terminal:

sudo nano /bin/atualiza

Obs.: este nome "atualiza" pode ser o nome que você desejar.

Com o editor Nano aberto, copie e cole estes comandos:

#!/bin/bash

apt-get update
apt-get upgrade


Feche o editor e salve o arquivo (F2 e a letra S, para confirmar).

Agora digite no terminal:

sudo chmod +x /bin/atualiza

Obs.: se você tiver mudado o nome "atualiza", altere aqui também.

E pronto, toda vez que for fazer esses processos, basta digitar:

sudo atualiza

E todos os processos serão feitos de forma automática, enquanto você vai tomar um cafezinho.

Um forte abraço a todos.

Viva o Linux, viva a liberdade...

Outras dicas deste autor

Teclado Acer Aspire One com acentos e cedilha

Leitura recomendada

O comando sl

Ajustando o delay de repetição do teclado

Como anexar arquivos em email pelo modo texto

Uso efetivo do shell

Alternativa para inicialização do KDE no Slackware 10.2

  

Comentários
[1] Comentário enviado por removido em 21/05/2013 - 00:58h

Boa dica

[2] Comentário enviado por usemacosx em 21/05/2013 - 04:21h

otima dica para os amadores e usuarios de windows que querem mudar

[3] Comentário enviado por mbrainiac em 29/12/2013 - 12:57h

Obrigado Mário,

Como sempre tenho costume de atualizar o sistema antes de usar, foi muito bom.

fiz algumas alterações


#!/bin/bash

/etc/init.d/clamav-freshclam restart
freshclam
apt-get update
apt-get upgrade



Valeu

[4] Comentário enviado por everton_melo em 17/05/2014 - 11:31h

Bom dia Mario, primeiramente obrigado pela dica, excelente! Precisa de uma ajuda sobre um erro que ocorre quando tento atualizar, vou postar abaixo, se você souber alguma informação de como corrigir, eu agradeço!

[email protected]:/home/everton# atualiza
Ign cdrom://Debian 7.5.0 wheezy Release.gpg
Ign cdrom://[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 DVD Binary-1 20140426-13:37] wheezy Release.gpg
Ign cdrom://Debian 7.5.0 wheezy Release
Ign cdrom://[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 DVD Binary-1 20140426-13:37] wheezy Release
Ign cdrom://Debian 7.5.0 wheezy/contrib amd64 Packages/DiffIndex
Ign cdrom://Debian 7.5.0 wheezy/main amd64 Packages/DiffIndex
Err cdrom://Debian 7.5.0 wheezy/contrib i386 Packages
Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
Err cdrom://Debian 7.5.0 wheezy/main i386 Packages
Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
Ign cdrom://Debian 7.5.0 wheezy/contrib Translation-en_GB
Ign cdrom://Debian 7.5.0 wheezy/main Translation-en_GB
Err cdrom://[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 DVD Binary-1 20140426-13:37] wheezy/contrib amd64 Packages
Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
Err cdrom://[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 DVD Binary-1 20140426-13:37] wheezy/main amd64 Packages
Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
Err cdrom://[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 DVD Binary-1 20140426-13:37] wheezy/contrib i386 Packages
Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
Err cdrom://[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 DVD Binary-1 20140426-13:37] wheezy/main i386 Packages
Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
Ign cdrom://[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 DVD Binary-1 20140426-13:37] wheezy/contrib Translation-en_GB
Ign cdrom://[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 DVD Binary-1 20140426-13:37] wheezy/contrib Translation-en
Ign cdrom://[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 DVD Binary-1 20140426-13:37] wheezy/main Translation-en_GB
Ign cdrom://[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 DVD Binary-1 20140426-13:37] wheezy/main Translation-en
Hit http://security.debian.org wheezy/updates Release.gpg
Hit http://security.debian.org wheezy/updates Release
Hit http://security.debian.org wheezy/updates/main Sources
Hit http://security.debian.org wheezy/updates/contrib Sources
Hit http://security.debian.org wheezy/updates/main amd64 Packages
Hit http://security.debian.org wheezy/updates/contrib amd64 Packages
Hit http://security.debian.org wheezy/updates/main i386 Packages
Hit http://security.debian.org wheezy/updates/contrib i386 Packages
Hit http://security.debian.org wheezy/updates/contrib Translation-en
Hit http://security.debian.org wheezy/updates/main Translation-en
W: Failed to fetch cdrom://Debian 7.5.0/dists/wheezy/contrib/binary-i386/Packages Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs

W: Failed to fetch cdrom://Debian 7.5.0/dists/wheezy/main/binary-i386/Packages Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs

W: Failed to fetch cdrom://[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 DVD Binary-1 20140426-13:37]/dists/wheezy/contrib/binary-amd64/Packages Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs

W: Failed to fetch cdrom://[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 DVD Binary-1 20140426-13:37]/dists/wheezy/main/binary-amd64/Packages Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs

W: Failed to fetch cdrom://[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 DVD Binary-1 20140426-13:37]/dists/wheezy/contrib/binary-i386/Packages Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs

W: Failed to fetch cdrom://[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 DVD Binary-1 20140426-13:37]/dists/wheezy/main/binary-i386/Packages Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs

E: Some index files failed to download. They have been ignored, or old ones used instead.

[5] Comentário enviado por everton_melo em 17/05/2014 - 11:38h

Mario, abacei de achar a solução em outro forum, de qualquer maneira agradeço! abraço.

[6] Comentário enviado por Huslene em 05/09/2016 - 18:33h

Oi Mbrainiac, qual a diferença do comando que vc criou em relação ao do Mário.
O que ele faz



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts