Xorg não funciona mesmo com input-hotplug configurado

Publicado por Francisco Raimundo da Silva em 30/06/2009

[ Hits: 4.024 ]

Blog: http://www.facebook.com/profile.php?id=100003055572272

 


Xorg não funciona mesmo com input-hotplug configurado



Quem usa distros com pacotes mais atuais deve ter se deparado com um ambiente gráfico que não sobe mesmo configurando algumas opções em /etc/X11/xorg (http://sidux.com) ou lidando diretamente com as configurações do hal (Configuração de teclado e dispositivos de entrada em geral a partir do HAL no Xorg 1.5 e superiores).

Depois de pesquisar um pouco achei a solução: trata-se de uma opção do kernel "nopat" que deve ser passada na linha do kernel em /boot/grub/menu.lst ou /etc/lilo.conf.

Um exemplo do meu menu.lst:

kernel /boot/vmlinuz-2.6.30-0.slh.4-sidux-686 root=UUID=ca3ae68b-b85d-4766-a511-e5cb010510e1 ro quiet vga=791 nopat

Você pode fazer o mesmo no lilo em /etc/lilo.conf adicionando "nopat" sem aspas na linha append, exemplo:

append = "hda=scsi hdb=scsi hdc=scsi hdd=scsi hde=scsi hdf=scsi hdg=scsi hdh=scsi apm=power-off nomce noapic nopat"

Seguido de:

# lilo

Reinicie o sistema e você verá o X novamente, tanto com drivers de vídeo proprietários quanto open sources.

Fiquem com Deus!

Referência:
Outras dicas deste autor

Resolvido: su, sudo, kdesu e gksu não funcionam

Lendo manpages no Firefox

Conhecendo e usando o debdelta

Aplicativos no KDE/Plasma sem bordas a hora que você quiser

Kernel Liquorix: não dá o Boot [Resolvido]

Leitura recomendada

Solucionando problema de som do Skype no Ubuntu

Automatizando o boot de VMs

D-Link 500G da BRT sem provedor

Como remover o painel lateral do Unity - Ubuntu 12.04

Wireless Broadcom 43xx no Ubuntu 7.10

  

Comentários

Nenhum comentário foi encontrado.



Contribuir com comentário