Wireless no ASUS X45

Publicado por Thiago Evaldo Araujo Pinheiro em 28/08/2013

[ Hits: 5.156 ]

 


Wireless no ASUS X45



Escrevo esta dica para quem teve a "linda" ideia de comprar um notebook ASUS X45C, ou semelhantes.

No meu caso, recebi esse notebook de manhã, pertinho da hora do almoço, e às 14:00 hs., já estava formatando para me livrar daquele maravilhoso software que tem mania de ligar bem rápido, mas leva muito tempo pra desligar e consome muito hardware desnecessariamente.

Instalando o Debian Wheezy neste dia 17/08/2013, percebi que o Wireless não funcionava e então, dei início à pesquisa.

Como eu achava que a placa Wireless vinha da Atheros, fui em busca dela no site do Debian, mas para minha surpresa, era pra ter buscado por Ralink, só que até aí instalei alguns softwares, como tentativas frustrantes.

# apt-get install linux-image-$(uname -r)
# apt-get install build-essential
# apt-get install linux-headers-$(uname -r)

# apt-get install firmware-atheros
  # A frustração começou aqui com fortes emoções que não se sente assistindo filme de terror

# apt-get install firmware-iwlwifi
# apt-get install firmware-linux-free

# apt-get install collectd-core
  # Finalmente fiquei desiludido e decidi atirar pra todos os firmwares bem chateado

# apt-get install zd1211-firmware

# apt-get install firmware-ralink
  # E foi nesse primeiro tiro que já acertei. Que sorte!!!

Quando, finalmente desisti, pensei em instalar o "firmware-ralink", porque li esse nome solto em algum lugar e tive uma surprêsa.

O Wireless funcionou perfeitamente! A única complicação é que a luzinha do Wireless não liga.

Então, se você, como eu, tem um notebook da ASUS e não consegue usar o Wireless depois de tudo instalado via cabo de rede, não se preocupe, você já tem a solução, instale o pacote "firmware-ralink".

=D

Outras dicas deste autor

Positivo Mobile V43 + Fedora 10

Leitura recomendada

Áudio do Acer 5542 com Ubuntu

Instalando o modem Motorola SM56 no Linux

SpeedStream 5200 em roteador - Parte 2

Configurando driver da placa ATI no DELL INSPIRON 5000 Series Special

[ResuLinux] Configurando suporte a Bluetooth

  

Comentários
[1] Comentário enviado por leleoar em 30/01/2014 - 14:51h

legal estou com o mesmo problema, irei tentar fazer isso.. caso der certo colocarei a minha experiencia muito obrigado pela dica.

[2] Comentário enviado por Rochelly em 15/11/2015 - 13:50h

Mano vc é o CARA!!!!!!
Comprei um x450l , já foi difícil instalar ele com a UEFI , depois tive esse problema com o wi-fi, agora funcionou, brigadão mesmo !!!!



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts