Usando o OpenOffice para modificar legenda de filme

Publicado por Ricardo em 30/01/2008

[ Hits: 7.699 ]

 


Usando o OpenOffice para modificar legenda de filme



Esta dica visa mostrar como editar automaticamente um arquivo de legenda (srt) quando um trecho inicial do filme foi cortado. Por exemplo, você removeu o trecho inicial de um episódio de TV que mostrava cenas de episódios anteriores. Com isso a sua legenda original ficou sem sincronia com o seu filme. Como corrigir este problema?

Preparando o arquivo srt

1) Inicialmente, abra o arquivo srt no OpenOffice Writer. Esse arquivo possui legendas com a seguinte estrutura:

1
00:00:01,800 --> 00:00:06,097
"Anteriormente..."

2) Mande substituir " --> " por "#" em todo o texto (pode ser "#" ou qualquer caractere que não ocorra no texto).

Obs: Não se esqueça de incluir os espaços antes e depois de "-->".

3) Selecione todo texto e mande converter texto em tabela escolhendo o caracter "#" como separador de colunas.

4) Selecione toda a tabela gerada pelo oowriter, copie (Ctrl-C). Abra uma nova planilha do oocalc, clique na célula A1 e cole (Ctrl-V) a tabela do oowriter.

Usando o OpenOffice Calc

1) Na planilha, delete as linhas iniciais contendo as legendas correspondentes ao trecho do filme que foi deletado.

2) Escolha uma célula qualquer (I1, por exemplo) para ser a referência de tempo e nela coloque o tempo do filme que foi deletado. Por exemplo: se 1 min e 23,254 s foram cortados coloque em I1 o valor 00:01:23,254.

3) Na importação do oowriter para o oocalc a coluna B ficou com o tempo de saída das legendas. Nas células C1, D1, E1 e F1 coloque as seguintes fórmulas:

C1: =SE(ÉTEXTO(A1);A1;SE(ÉCÉL.VAZIA(A1);"";SE(TRUNCAR(A1)/A1=1;A1;TEXTO(A1-$I$1;"hh:mm:ss,000"))))
D1: =SE(ÉTEXTO(A1);"";SE(ÉCÉL.VAZIA(A1);"";SE(TRUNCAR(A1)/A1=0;" --> ";"")))
E1: =SE(ÉTEXTO(B1);B1;SE(ÉCÉL.VAZIA(B1);"";SE(TRUNCAR(B1)/B1=1;B1;TEXTO(B1-$I$1;"hh:mm:ss,000"))))
F1: =C1 & D1 & E1

4) Agora selecione de C1 até F1, copie (Ctrl-C), selecione de C2 até Fn, sendo n a última linha a conter legenda e cole (Ctrl-V). A coluna G contém o texto do seu novo arquivo srt.

5) Pronto. Agora é só Selecionar o conteúdo da coluna G (de G1 até Gn), copiar (Ctrl-C), abrir o editor de textos de sua preferência (kwriter, gedit, por exemplo) e colar (Ctrl-V). Salve o novo arquivo com extensão srt e já pode-se assistir ao filme com a legenda devidamente sincronizada.

É isso!

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

GULZO - Grupo de Usuários Linux da Zona Oeste do Rio de Janeiro

Ativar temas do Emerald no Ubuntu

Ajustar a data do sistema

Gambas 2 (parte 3)

Internet aliada ao conhecimento = crescimento

  

Comentários

Nenhum comentário foi encontrado.



Contribuir com comentário